Sign in with
Sign up | Sign in
Your question

Vista doesn't see my additional hard drives as part of a RAID array

Tags:
  • NAS / RAID
  • Asus
  • Windows Vista
  • Storage
Last response: in Storage
Share
July 24, 2008 1:06:55 AM

My system has been running fine for quite some time. I'm running Vista Ultimate on an ASUS P5ND2-SLI mobo.

I just picked up 2 new 500 GB SATA drives to use for data storage, RAID 1. My OS will remain as is, on a single, non-raid drive.

I hooked up the two SATA drives and followed the instructions from my ASUS user guide:
Via BIOS, I enabled RAID and selected the drives.
Via the NVIDIA Raid Utility I set up the RAID array as Mirrored and selected the drives. It seemed to go well.

But Vista does not recognize the two drives as a RAID array. It shows two distinct drives (this was with the Vista Disk Management Util and with Device Manager as well)

I called ASUS and got someone on the phone fairly quickly, although they informed me that I had done everything correctly so this must be a Vista issue. According to the ASUS rep, I do NOT need RAID drivers for Vista because the OS is not installed on the array.

Any ideas. Thanks for any help.
-Andy

More about : vista additional hard drives part raid array

July 24, 2008 1:51:48 PM

What did you have the SATA controller set to before settingit to RAID? (ide, ahci, etc. not sure what choices there are for nvidia)

Do you have 1 or 2 drive letters for the 2 500gb drives?

Are there any listings with bangs in device manager?
July 24, 2008 2:21:02 PM

If you do the mirroring you should duplicate the content of the first drive to the other drive exactly. Before setting it to RAID.

I think drivers is still necessary to make that successful, well I maybe wrong but as I recall when I setup a server with 2 HDDs mirrored together, without driver sometimes it fails.
Related resources
July 25, 2008 2:13:08 AM

rozar,
In my Bios, under Onboard Device Configuration, there is an NVRAID Configuration section. I can set RAID to enabled or disabled. It was disabled prior to this installation, but I have set it to Enabled now. I also have the ability to set the individual drives as Enabled or Disabled for RAID and I have done so. It seems to work because once RAID is enabled, I can hit F10 during boot up to get the NVRAID Utility. According to the NVRAID utility, my RAID array is all set. As a matter of fact, when I boot up I get a message (from BIOS?) telling me that I have a RAID array. I had never seen that before.

Also, I have no items in Device Mgr showing errors, however one with a ?. An unknown device with a value of ACPI\PNPB006. It's been like that ever since I installed Vista quite a while ago.

There are no drive letters assigned yet to the drives yet. But I guess that's because I haven't formatted any partitions yet.

pogsnet,
Since these are brand new drives, there is no data on them. Should I have them formatted first? I thought I was supposed to do that once the mirror was set up. They are currently not formatted at all.
Regarding the drivers, I can't even find any on the web. I see posts on forums where people say they installed them, but I can't find anything on the ASUS website. My board is the ASUS P5ND2-SLI. However, in Device Mgr, I clicked on NVIDIA nForce RAID Controller and was able to update the driver (much to my surprise). Now I am using v 5.10.2600.995 from 7/2007. But still no luck. It could be I have the most current driver.

Thanks
-Andy
July 25, 2008 2:06:08 PM

I do not have any experience with your board but the trick will be to get disk manager to only see 1 disc and not 2. It might be worth it to call your motherboard maker and ask them. I suspect you are missing a driver in some way.
a b G Storage
July 25, 2008 2:23:02 PM

In the BIOS, did you set the parameters of the RAID array?
It will ask you if the Array is bootable, or storage, you have to set that feature as well. Don't know if that is what is causing this or not, but you do have to set that feature correclty as well.
July 25, 2008 2:47:58 PM

Did you re-install the NVidia mobo drivers? The raid controller may have not installed properly since you enabled it after your installation of Vista.
July 25, 2008 2:55:34 PM

You did not have the BIOS setup properly to detect the RAID array. It sounds like you now have it setup properly. Try recreating the RAID array in whichever RAID controller you are using. You do not need to use both the Nvidia and VIA Raid controller unless you have Raid arrays setup on both controllers so I would disable whichever one you are not using. Check your motherboard documentation to see which SATA ports go to each controller. Make sure that the drives you want to use in a RAID array go to the same controller, you cannot have one drive going to a Nvidia SATA port and another going to a VIA SATA port and expect to be able to create a RAID array. At least I was not able to.

Finally, if you are positive that all your hardware is hooked up and setup properly than go the disk manager in Vista and see if you have an option to create a new partition out of your RAID array. I only had to do this once to get Vista to recognize an array but you may have to. The array will show up in the disk manager as unallocated space, 1 TB if you have the drives striped, 500gb if you have them mirrored.

I hope I did not confuse you with this. It is actually really simple, my explanation skills just suck.
July 25, 2008 3:02:25 PM

rozar: I have called the mobo manufacturer, ASUS. They said I did everything correctly and I should contact Microsoft! They also told me I need no RAID drivers (since I am not booting off of the raid array).

jtpublisher: In the NVidia RAID utility I set the the parameters of the raid array. I set Boot = "no" and a few other params. I set the RAID type=Mirror and one I can't recall (I'm at work now so I can't check) it was something like file size or something (choices = 64, 128, optimal). The odd thing is whenever I set Boot="no", if I come back in it switched to Boot="yes". According to ASUS, that shouldn't matter. Weird huh?

tgstyle: I did upgrade the NVidia RAID controller drivers, but not the mobo drivers. I'll try that tonight.

Question: Should these drives be formatted prior to creating the RAID array?

Thanks
July 25, 2008 6:46:23 PM

No need to format them. The raid creation will overwrite the data.
July 27, 2008 1:36:45 AM

tgstyle, This may sound like a dumb question, but how do I reinstall mobo drivers? Under device manager, I can load drivers for all sorts of stuff, but not the mother board itself right? As I said, I already updated the RAID controller drivers.

I was looking at the BIOS version. I have Phoenix Award Bios V 6.00PG, then it says ASUS P5ND2-SLI ACPI Bios Revision 0605. According to the ASUS site, that is up to date.
But when I enable BIOS, I see Media Shield IDE ROM 5.27. Is that BIOS as well? Does the mobo switch BIOS if RAID is enabled? I can't figure out if the Media Shield version is the latest and greatest for my pc.

Crashed97tsi, thanks for your input as well. Below I said "Via BIOS, I enabled RAID", I meant via as in "with the". Sorry for the confusion, I have no "Via bios". In any case, if I don't enable the RAID in my "normal" bios screens, I won't be able to add the specific config settings in the NVIDIA RAID Untility. It will never be accessible to me. It seems that turning on RAID in the BIOS (there are no settings there for RAID type) simply enables the NVIDIA Utility for me so I can set up the array. Regarding the SATA ports, with BIOS I can enable them in pairs 1&2 AND 3&4. So I'm guessing that they work together in those pairs. But I have tried using the drives in all different combinations.

I'm really starting to get frustrated as I have tried a lot of stuff, re-booted many many many times, all with no progress. Maybe this is really a Vista issue. If so, I doubt I'll get any support out of MSFT, but I can try.
July 28, 2008 4:38:34 PM

Easiest way is to download the nforce drivers from nvidia.com for your motherboard. You may want to uninstall the previous ones in Programs and Features - should be listed as NVidia Drivers. Careful if you have an NVidia videocard make sure you don't uninstall those drivers. Once uninstalled reboot and install the drivers you downloaded.
July 29, 2008 2:42:02 AM

I do have a NVidia Drivers item in Programs and Features, but it isn't specific as to which device, and I also have an NVidia GeForce video card.

But assuming this is the MotherBoard driver, doen't Vista need that to do everything? Will I be killing the whole system if I uninstall it?
July 29, 2008 4:01:31 PM

Vista should have basic drivers built-in, since you have to install the NVidia drivers after a vista install. You didnt use the mediashield for your main OS drive so you should be fine there as well.
July 30, 2008 12:07:46 AM

Continued bad news. I re-installed the NVidia mother board drivers but that didn't help. I got back on the phone with a rep from ASUS. He walked me through the process. We did find one thing out of wack so I was optimistic but in the end, it made no difference. He says I've got everything set up correctly. As a last ditch effort he had me try something interesting. I removed my current drive, leaving only the RAID array. I set it up as the boot drive and installed Vista on it. He thought that Vista may configure the drive properly, then I could switch back. The interesting part is that with the 2 drives set up as 1 Mirrored RAID array, Vista only gave me once choice of drives to install on, just as it should. But when all was said and done, my regular Vista OS saw the array as two different drives.

I'm starting to think this will never work!
-Andy

April 18, 2009 12:06:29 AM

Did you ever find a fix for this. I have the same issue. I all ready have a mirrored array running vista 64 (300GB). I added a 2nd array 1.5TB. In Bios it shows as healthy mirror. In Vista it shows 300 GB NVIDIA Raid. Then 2 seperate 1.5 TB Drives.

Thanks.
April 18, 2009 1:37:52 AM

Nope, I never figured it out. Seems like this board doesn't support RAID on Vista
!