Sign in with
Sign up | Sign in
Your question

DHCP can't be found - IP defaulting to 169.254.X.X

Last response: in Wireless Networking
Share
March 2, 2009 2:44:16 PM

I've been using a LINKSYS WCG200 v2 with COX high speed internet for more than a year with no problems. Connected to the LINKSYS is a desktop PC (Ethernet cable) and a laptop (wireless). Both have Vista and use the COMODO software firewall.

Suddenly, my desktop PC started losing internet connectivity. It turns out when my IP is set to expire (e.g., Lease Expires: Sat, Feb 28, 09 10:46:41 PM), it doesn't get renewed. When that happens, the IP defaults to 169.254.105.7, which of course is out of the range for the Default Gateway (i.e., > 192.168.0.1). I've read that 169.254.x.x is assigned by the IPAC service when no DHCP can be found.

When this happens, my laptop can still connect to my home network and access the internet. Sometimes, the IP for the desktop seems to renew on its own (usually several hours later) and connectivity is restored; but it again fails when the lease expires.

And this is odd: If I unplug the modem and plug it back in, the IP still defaults to 169.254.X.X. If I unplug my PC, plug it back in, and start up the PC, same thing. But - If I unplug the whole power strip (which the modem and PC are plugged into), plug it back in, and boot up the PC, the IP *sometimes* defaults to the correct range (i.e., > 192.168.0.) and I have connectivity. But the moment the lease expires (usually an hour later), the IP doesn't get renewed and defaults to 169.254.X.X.

The properties for TCP/IPv6 and TCP/IPv4 are both set to:

- Obtain an IP ... address automatically
- Obtain a DNS server address automatically

What I've tried:

1. Reset the modem and adapater - no change.
2. Checked all cable connections and lights - all good.
3. Replaced Ethernet cable and coaxial cable with new ones - no change
4. Stopped firewall and antivirus
5. Tried ipconfig /release and ipconfig /renew, but I always get this error at the renew step:

"An error occurred while renewing interface Local Area Connection: unable to contact your DHCP server. Request has timed out."

6. All variations of: unplug coaxial, unplug modem, plug in modem, renew/release, etc. - no change. The renew step always gives the same 'can't connect to DHCP server' error.
7. Repairing/resetting the WINSOCK (i.e., netsh winsoc reset)
8. Every step listed here: http://kb.resnet.purdue.edu/print.php?articleid=1385
9. Voodoo

Any ideas what else I should look for?

Thank you.
November 6, 2011 7:43:47 PM

ever figure this out??

I have this same thing...maddening
November 17, 2011 6:04:12 AM

Hosts obtain these addresses by auto-configuration, such as when a DHCP server may not be found
!