Sign in with
Sign up | Sign in
Your question

Unable to Setup RAID/AHCI on Intel Motherboard DX48BT2

Last response: in Storage
Share
July 27, 2008 5:47:54 PM

I am unable to setup RAID/AHCI on Intel Motherboard DX48BT2.

HARDWARE:
Motherboard Intel DX48BT2 (with Chipset X48 & ICH9R Controller)
Processor Intel Core2 Quad Q9300 2.5Ghz
HDD SATA WD Raptor 150GB (for Operating System)
HDD SATA Seagate Barracuda 7200.11 500GB
Memory Corsair TWIN3X2048-1333C9DHX 2GB
Graphics Card HIS Radeon HD 3870

SOFTWARE:
OS Windows Vista Ultimate 64-bit (SP1) & 32-bit (SP1)
Motherboard BIOS Update: 1554 [BTX3810J.86A] (latest)
Intel Matrix Storage Technology (RAID) driver: version 8.2.3.1001 (latest)
Marvell (RAID) driver: version 2.10.0.10 (latest)

In order to take full advantage of my SATA-II HDDs, I want to enable NCQ on my computer. This I understand is possible with SATA AHCI or RAID configuration. I have set SATA controller to RAID mode in the mobo BIOS (so that the system is at least RAID-ready and is also AHCI enabled for NCQ). I downloaded the latest Intel Matrix Storage RAID drivers and Marvell RAID drivers to root directory in a USB drive.

When I try to pre-install the SATA drivers with Vista Ultimate 64-bit edition (with Load Driver option during Vista installation), I get the error "No drives were found. Click Load Driver to provide a mass storage driver for installation". When Load Driver is clicked, it presents the 64-bit drivers from Intel as well as Marvell, but fails to install both.

When I try to install the SATA drivers with Vista Ultimate 32-bit edition, I get the error asking me to contact Intel for the latest drivers, whereas both the Intel & Marvell drivers are the latest ones.

An Intel troubleshooting link for controller ICH7R suggests that Windows Vista has its own RAID & AHCI drivers and there is no need to pre-install such a driver. I have even tried this. It leads to a blue screen of death when Windows Vista is trying to install!

The above three combinations have also been tried with SATA AHCI configuration selected in the mobo BIOS, but the results are the same.

Would appreciate help as I am relatively new to high-end computing.

Thanks & regards,

Nasser
July 28, 2008 1:09:15 PM

If you haven't tried both RAID & AHCI and your bios allow this config, try enabling both.

Hi F2 on POST, go to Advanced, Drive Configuration, Configure SATA as; select RAID & AHCI.

I'm aware that your setup isn't RAID, but one of the builds I did required both options on to be able do IDE, SATA DVD & SATA HDD.
July 30, 2008 3:37:59 PM

auscanzukus,

thank you for your suggestion. the bios does not allow simultaneous selection of both ahci and raid.

i have come across similar posts which state that after using the "load driver" option, an error message pops up stating that no drive could be located. However, i am still looking for a solution.
Related resources
July 30, 2008 7:13:32 PM

nasser,

Seems we are having a similiar issue. Well not so much similiar but I think the root cause will be the same.

I am trying to migrate from IDE mode to RAID mode but the Marvell controller doesnt seem to recognize my drives. If you do a CTRL-M at bios at does your Marvell Bios config show any drives loaded?
Mine doesnt and I think that is the root cause of my problem, if yours is the same then maybe we can work this together and get somewhere with it.

I am going to try and run a clean vista install and see where that gets me.

I have an almost identical config except I have the 2.66 Quad Core, a 250GB OS HD and 4GB of RAM.

Let me know what CTRL-M tells you and we'll go from there.

Mike
July 30, 2008 7:16:27 PM

I also meant to say that the manual says RAID mode initiates RAID and AHCI.

Mike
July 31, 2008 5:29:54 PM

You did set up the arrays right? Or define a simple volume?

You dont need AHCI and RAID you do one or the other. RAID would include all features of AHCI.
August 1, 2008 3:30:43 AM

I actually have my system up and running now, I didnt realize that both Intel Matrix Storage Manager and the Marvell utility run at the same time. I ended up reinstalling Vista from scratch once the raid was setup in Intel Storage manager.
September 8, 2008 4:03:06 PM

Hi Guys,

I'm using the DX48BT2 with multiple Raptors, but I want to use
SAS drive's, The LSI SAS3041Controller in not working on this
board. Does anyone know a controller that wil work?

Cheer!
Anonymous
a b V Motherboard
a b G Storage
May 27, 2009 3:48:59 AM

is it even possible to use the Marvell RAID driver for internal sata? I don't recall seeing that limitation anywhere, but the more I look for documentation, the more I just see it mentioning IDE and 2 esata ports, nothing on internal 6 sata
!