Sign in with
Sign up | Sign in
Your question

Keyboard not responding before boot and in Bios

Last response: in Overclocking
Share
March 17, 2008 11:09:08 PM

I wasn't really sure if this was the proper place for this article but i am trying to solve a problem. When I try to enter the BIOS my keyboard does not respond. My computer consists of EVGA 680i with phoenix BIOS, 2GB Patriot
800mhz memory, C2D E6750 @ 2900mhz, and Windows Vista Premium 64-bit.My keyboard is a Logitech G15. All of my software is up to date and Vista is also.

I was about to overclock my machine, something I have done a little in the past, so I shutdown my computer and turned it back on. When the screen came up telling me all of the specifications I tried to hit the DEL key but it did not respond. I hit all of keys including ESC and AWD+F2 but had no change. I tried numerous times again but ended with the same result. I moved it to different USB ports but that didn't work either. After the boot my keyboard becomes fully functional including its LCD. I plugged in my old PS2 Dell keyboard and restarted my machine and it worked. I could enter the BIOS without a problem. I'm not sure if the new Logitech software is causing this problem but it may be the cause.

Any help you can provide is greatly appreciated
March 18, 2008 1:56:18 AM

Very interesting. I am posting to reassure you as the very exact thing happenned to me over the weekend during my new build. (Specs in signature) I fortunately had a PS2 keyboard around and use it to configure the bios, setting it up for the first time. I did not know the PS2 keyboard would work - I was just desperate to get the bios settings adjusted for the first time. So yeah, if anyone knows the cause of this, it would be a relief to know why this happens.
Related resources
April 23, 2008 11:24:57 PM

Yea, foxman has it right. My board, GA-P35-DS3P, will disable the keyboard and mouse by default after post and before the OS loads the drivers. This means that I have no way to choose my OS in say a dual boot config or safe mode. There is a setting in the BIOS to enable both the key board and mouse during boot. For your board, it might be the USB legacy support. Also, it's definitely not software as BIOS doesn't run any software.
May 14, 2008 5:58:51 PM

It's always a good idea to keep an old keyboard and mouse that plug into the old style ports. You can pick them up for almost nothing at Walmart or any computer store. Most bios today support USB mouse and keyboard during bootup...., but not all and some have it disabled as the default.

I keep a set from an old computer in a drawer in my study and they've come in very handy from time to time.

If you work for a company that uses computers to any extent, just ask the IT people and they'll probably be glad to give you a set that have just been laying around or that they were going to throw out.
May 14, 2008 10:54:27 PM

PS2 keyboards and mouse needs to die, seriously. But things like this prevents that from happening.
Anonymous
a b K Overclocking
November 20, 2009 12:43:15 AM

Same problem here. Not much use on the 'net for answers.

Here is how to solve it.

Unplug all your other USB devices, except the USB keyboard

If you've already done that, open your case, and unplug the internal memory card reader.

Presto - USB keyboard work as standard legacy devices.

I have no idea why some of these internal memory card readers have this effect. I had the same trouble with a SanDisk external reader, but of course, that is easier to unplug.

It is only at boot time, and only if you select USB Legacy Support (or equivalent 'USB Keyboard Support', etc, in the BIOS). After the OS has booted, everything works fine.
Anonymous
a b K Overclocking
May 9, 2010 8:50:30 PM

Quote:
Same problem here. Not much use on the 'net for answers.

Here is how to solve it.

Unplug all your other USB devices, except the USB keyboard

If you've already done that, open your case, and unplug the internal memory card reader.

Presto - USB keyboard work as standard legacy devices.

I have no idea why some of these internal memory card readers have this effect. I had the same trouble with a SanDisk external reader, but of course, that is easier to unplug.

It is only at boot time, and only if you select USB Legacy Support (or equivalent 'USB Keyboard Support', etc, in the BIOS). After the OS has booted, everything works fine.



Hey guys;
this worked for me. The computer I am working on is an HP and it has the multi-card reader (usb powered) in it and when I uplugged it, I was able to use a usb keyboard to access everything at boot time....THANKS ANONYMOUS!
February 19, 2011 1:38:05 AM

another fix that worked for me WITHOUT requiring you to OPEN PC is to simply insert a memory card into one of the slots prior to powering on pc and ensuring only the usb keyboard is plugged in. leave the internal memory card reader plugged in.

i was able then to use my usb keyboard inside BIOS :) 
February 29, 2012 2:17:21 PM

It's a subtle thing that actually enforces you boot Micro$oft OS. Micro$oft OS is the first choice and default choice! Add that to the keyboard not working and draw your conclusions....who has Ps2 keyboards today?
!