Sign in with
Sign up | Sign in
Your question

Hitachi Ultrastar A7K1000 1TB write-cache settings...

Last response: in Storage
Share
July 31, 2008 9:00:41 AM

Hi!

Anyone with this Hitachi drive that is having write-caching bit being reset?

Got the drive a month ago to put into an aging ASUS A7N8X-E Deluxe system. This has a Sil3112 controller and Sil3114-based PCI controller card to some other drives. They don't support SATA-II/300. Installed a Syba Sil3124-based PCI card and drive works on there no problem.

Except write-caching. It is off on the drive seeing as it is a server drive. Part number indicates use on SUN Microsystems.

Used the Hitach hard drive tool to set the write-cache bit, but that software doesn't seem to understand the 3124 card. I used a HP with ICH7 controller and set the write-caching on. Back into the ASUS machine and everything is perfect. Fast speed read or write even across the PCI bus.

Sunday... Windows dies after SP3 uninstall (don't ask, it was irritating). Re-installed XP on Monday, installed SP3 properly, everything is 100% but the setting on the Hitachi is back to no write-caching.

I had to pull the power completely. Bad enough during machine boot up for the ASUS board to reset its own BIOS settings.

I'm thinking this write-cache setting is not held across power downs it seems. Previously, machine was off, but power supply still plugged in.

Has anyone had issues with keeping the write-cache setting on these drives or others that by default have it set to disabled?

I might have to use the Silicon Image Java SATA RAID tool to enable the setting on boot in Windows, but this thing BSOD'd my machine after installing java after it was installed. :p 

Any help welcome.
July 31, 2008 3:36:54 PM

Normally write caching is controlled by either the OS or the controller.

Have you tried going into device manager, finding the drive under hard drives, right click on it and go to properties, then the policies tab. There if the radio button for performance is selected you should have an option for write caching.
July 31, 2008 6:00:12 PM

I'm aware of that setting, but unfortunately it is always greyed out. It's set to performance, but I guess that doesn't work. :) 

Do you perhaps know the registry setting for forcing it?

I'm downloading a later Java SATARAID utility. This other one keeps BSODing the machine. I might just swap them on the PCI bus seeing as that was probably the setup I had when the Java tool worked.

Just flashed the controller bios to a RAID BIOS, but still no difference. The Hitachi tool still doesn't pick up the 3124 controller's drives.

I'm not so sure about that story regarding the controller or OS controlling the write cache. I connected the drive into a Intel ICH7- or ICH9-based PC, ran the Hitachi tool and set the write cache to on, then put it back into my PC and write caching was available. So this means the write caching information was retained between controllers. How would my controller know I had switched this on on the other PC? The only thing that remained on during this was the power feed; drive hooked to my PC's power, SATA cable to the ICHx thing.
July 31, 2008 7:07:12 PM

Oh how gloriously annoying. :p 

Did that idea, swapped the location of the 3114 and the 3124 controllers. Fired up the PC, downloaded a couple of versions of that Java SATARAID tool. BSOD BSOD. :p  Googled it, found a common download somewhere for my 3114 controller which had another SATARAID tool (also java). Tool dies, doesn't show up. Remove, reinstall, reboot, it shows up with a GPIO 8 Error. :p  But it runs, I can see the drives. There's a setting for write cache for the Hitachi, but I flick it on and it just keeps reverting back to off in the GUI.

Kill it, move on. Pop open PC again, swap the location of the 3124 and 3114 on the PCI bus. Fire up windows, that tool starts up. GPIO error 8 message. :p  Boo, kill it.

But... write cache is suddenly enabled again. Reboot, try it again this time with java tool set to off. Yup, I have write cache. And I had the power off completely.

So something decided to work when switching the cards. Only thing I did different during the boot was stop by the Sil3124 BIOS.

I'll pull the power completely again later and see if it remembers its setting.

What a dumb setup. :p  I'm too cheap/broke to upgrade right now
!