Sign in with
Sign up | Sign in
Your question

AMD Vision giving no GPU options?

Last response: in Applications
Share
December 8, 2012 4:05:54 AM

Tried to go into AMD Vision to mess with my GPU (HD 4850) Since I will soon be receiving a free 4850 to crossfire from a friend, I wanted to go in and double check my settings on this one real quick, only to find that suddenly AMD Vision won't display any GPU settings, it only shows the CPU stuff for CnQ.

I already tried reinstalling Catalyst from AMD's site, is there something obvious I'm missing here to get it to show GPU stuff??
December 19, 2012 4:14:12 PM

Try these steps and let me know if you are still having issues.

Step 1:
Go to Start > Control Panel > Programs and Features and uninstall CCC and everything else with the provided ATI Catalyst Install Manager.

Step 2:
Reboot in Safe Mode.

Step 3:
Run Driver Sweeper and select the AMD box, Analyze, then Clean, make sure you have all the boxes checked.

Step 4:
Reboot again and Reinstall Catalyst Software Suite, ensure that it's the latest version, after the installation's been completed reboot once again.

Step 5:
Go to Start > Programs and Features > Turn Windows features on and off, check Microsoft .NET Framework 3.5.1 and finally, restart Windows for the last time.
m
0
l
December 27, 2012 6:53:48 AM

Well unfortunately by the time an answer was posted I had already given up looking for an easy solution and had basically done just this since there were no replies for over a week.

Basically what I ended up doing was going in and uninstalling the drivers +removing all their registry info manually. (Don't really trust Driver Sweeper, it still misses stuff sometimes or deletes too much when you have an amd processor as well.)

Didn't have to mess with .net at all, just did a complete and total uninstall of the drivers and reinstalled them. Works just fine now.

Thanks anyway though.
m
0
l
!