Sign in with
Sign up | Sign in
Your question

ICH9R Raid10 suddenly became invisible

Last response: in Storage
Share
August 8, 2008 7:27:59 AM

Greetings all:

I need help. I am using an Intel DX38BT motherboard, with 4 250GB SATA drives setup as a RAID10 (aka stripe + mirror).

Yesterday, my entire raid array became invisible in BIOS and as a "drive letter" in WinXP 32bit.

When I Boot, the raid splash screen for pressing ctrl-i shows the raid, and says it is healthy, etc. The Intel Matrix Storage Manager shows the raid is there, and healthy, but not "bootable" which it used to be.

Device Manager lists it as a disk.

However, it is NOT present in disk manager to assign a drive letter, nor does it show up as an available boot device in the BIOS.

This is particularly distressing because it was my boot drive up until last night, and it has loads of data on it.

Last night, I tried doing an MBRFIX from recovery console, but the drive is invisible to WinXP. I installed an old drive, booted from it, loaded the Intel Matrix Storage Manager and tried a full verify and repair, it found 5 verification errors, and fixed them, and declares the raid fully healthy. YET I CAN'T SEE IT.

Finally, tonight I tried using some data recovery software, but it appears not to understand raid10 and mistakenly identifies it as raid1, also it has the size WAY off, so I don't trust the recovery software.

Any ideas would be greatly appreciated.
August 21, 2008 7:56:53 AM

I see several people have read this, but none answered my thread. Since I was able to fix my problem, I will explain how here in case anyone else runs into this problem.

From what I have been able to gather, the RAID volume configuration is stored on the RAID disks themselves, so if the controller dies, a new RAID controller can, hopefully access the disks and use them w/o loosing data. Apparently, somehow the region of the drive where the RAID volume configuration information was stored must have become corrupted, which in turn caused RAID to disappear. In the Intel RAID BIOS splash screen, the RAID was flagged as Healthy, and each disk was Healthy, but there is a column there saying "bootable" and it went from "yes" to "no" once the RAID was bad.

My first priority was to get my data off. I tried several trial versions of various data recovery tools, booting from a different drive, Stellar Phoenix NTFS data recovery software was able to scan the drive, and recover my data.

Then, with my data recovered I was safe to try whatever way I wanted to get my drive recovered so I could boot, etc, and wouldn't need to re-install etc.

In the end, the only way to "fix" the RAID was to delete the volume. Then, create a new RAID volume using the same drives and configuration. Doing this restored the "bootable" flag to the RAID and it was once again visible to the OS and BIOS, but blank, no partition table.

Then, rather than format and start over, I thought, hey, the data is probably still, there, so I tried recovering the partition, and viola: the entire RAID, with all data, and OS install intact was back.

My chief frustration and concern after all this is that the Intel Matrix Storage manager utility was unable to fix this, it would verify the RAID and say it was fine, even as it was invisible to the OS. Or, I would think ideally the RAID BIOS itself should allow me to set the "bootable" flag to "Yes" again if it is "no".

If this happens to anyone else, good luck. My advice would be to first use a good data recovery tool to get back your data, as the "fix" is risky, you could easily end up with the RAID rebuilt slightly differently and your old partitions not only just deleted, which can be restored, but scrambled and un-recoverable. However, don't panic, there is hope.
!