Sign in with
Sign up | Sign in
Your question

Raid 0 Parity Error ASUS P5E3 ICH9R Sata WD Velociraptor

Last response: in Storage
Share
August 8, 2008 2:27:39 PM

The configuration listed here is causing parity errors and system lockups on this machine.
Board and drives pass all tests and seem to work OK in IDE mode, but configuring the Intel Raid controller for RAID mode causes the drives to eventually fail when running benchmarks or performing large file copies between drives. This has occured with multple Intel driver versions and board BIOS versions.
Anyone else reporting this issue or know any resolutions?
MOBO = ASUS P5E3 Premium WiFi
BIOS used = 0401 or 0505
CPU = Intel Quad QX9770
Memory = OCZ Platinum-1600 2x2GB
OS = Vista x64 SP1
Drives = 2x raid 0 arrays 4 x 300gb WD velociraptors
Intel Storage Matrix Controller ver 8.2.0.1001 (June 2008)

Errors reported in windows log files include
a) parity error on device 0 (iastor.sys raid driver)
b) iastor.sys has failed to respond in the time allocated

The intel raid monitoring app will eventually report that one of the drives in each array is failing.
After drive corruption, wiping the drives (writing zero to ALL sectors), allows them to be reinitialized and reformatted.

Running IDE mode now with no problems.
Any suggestions appreciated.
Wait for new drivers? Give up on MOBO raid and buy a dedicated controller?
September 11, 2008 7:15:15 PM

I have also problems here with my velociraptors on the ASUS P5E3 Premium Wifi. I am running 2 velociraptors in raid0 as a windows bootdevice.

I cant say anything about parity errors or log files, because i have no understanding of them.
Anyway, after some time of use (1 week after fresh install) my system will sometimes become unresponsive and i need to reboot. After this has happend a few times one of my drives will give a error on the raid status screen at bootup. The system keeps booting from de raid-device but the next week or sometime later the system wont boot anymore as the array seems to have fallen appart and the system doesnt recognize the drives as being a raid device. (no bootdevice found)

My thoughts about what could cause the problems:
-Memory issures
-One bad diskdrive, (badblocks or something (parity erros??))
-Bad raid controller (Saw a intel report about some controllers with bad ram, will check bacjk to that)
-Bad mobo some how runs drives in IDE mode at bootup (One time the array showed broken at the raid status screen at bootup and the system gave mesage "no bootdevice found". Somehow after a second reboot the raid status screen showed the proper raid setup again, and booted again. Aint the weird???)
-Bad serial interface cables. These things are realy crapy some times and get loose quiet easily. Have change them a couple of times but the error status keep comming back.

I have not that good computer understanding so the things that can cause these problems my be impossible, anyhow i just dont know realy....

Does someone know a program to check if a disk is bad?


Lian Li PC-V2100BplusII
Enermax Galaxy 1000W
ASUS P5E3 Premium Wifi-AP @n
Intel Q9450
Corsair TWINX4096-1600C7DHXIN ver3.1
MSI NX8800GTS 320MB DDR3
2x WD VelociRaptor Riad 0
Vista Ultimate 64bit OEM
December 8, 2008 3:15:40 AM

I am having the same problem with a 680i nvRaid array in raid-0. I am getting parity errors all over the place.
Whats interesting is that its in Vista 64 just like the previous posts. Other drives work fine including a pair of 74gb raptors and 1tb Caviar Blacks. Man I hate when companies don't do their homework!
Related resources
a b G Storage
December 8, 2008 3:23:12 AM

That's odd. I'm running a pair of velociraptors on an Asus P6T (Intel ICH10R) in RAID 0 on Windows Vista x64, and it works fine.
December 11, 2008 9:08:56 PM

Resurrectingt this thread. I first encountered a problem with my VelociRaptor RAID 0 issue on an Asus P5E motherboard. Got a blue screen one day...rebooted and drive on SATA 1 showed "Error Occured". Could not boot into windows. My stripe size was 64 kb. Then I restored from a backup and set stripe size to 128 and it went away for a time...so I experimented and reset stripe size to 64 again after restoring...and again...crash. Called Asus...they blamed the Southbridge chip on my mb...and wanted me to go back to 64 stripe and see how long the issue would persist...

Rather than do that...I scrapped the board, thinking I'd rather get a new board. So I ordered the EVGA X58 mb and an i7 920 processor...put everything together...installed Vista 64 Bit on 6 GB of memory...stripe sizw 64kb...and after two days of fresh install...CRASH! It is NOT the mb. My memory tests out...I think it is the VelociRaptors themselves. One is OEM and the other retail. Seems that there has to be some imbalance that occurs. HOWEVER...one major difference between the P5E and the X58...the new board is still running and I can boot into windows. Ran HD tach and my raid speeds seem normal, etc. I truly believe that something is different with the two drives that causes this....


Also...I, twice, broke up the ARRAY and tested the drives with WD Diagnostic tools...both drives PASSED with error code 000 Four times each....??????????????
Bob
January 2, 2009 10:25:02 PM

I'm also having issues with WD Velociraptors in Vista 64 on a X58 motherboard with Intel ICH10R Raid Controller.
Searching for this issue on the net, it's pretty common - you will find more forums with users having the same issue.
This seems similar to what was happening with the Seagate 1.5TB drives, which Seagate issued a firmware update for. So far WD doesn't seem to be acknowledging that this is an issue.
January 3, 2009 2:10:54 AM

I am experimenting around alot with this...because I also had the same issue with the X38 chipset (Asus P5E) with the ICH9R...one thing I have it down to is Nvidia Video drivers and possibly the extra setting in Vista I32 or 64), where you can enable Enhanced Performance. I have write cashing enabled, but NOT the Enhanced performance. I see pretty much the same performance one way or the other, but I think the aggressive write caching may cause errors...time will tell. Fresh install of Vista Ultimate 64 bit and am at three days and counting. Also not using BETA drivers from Nvidia, which DID cause a lot of errors.

Western Digital will not acknowledge the issue, but they actually offered to replace a perfectly working drive. I really wonder if they get it. Also...found an old post that may shed some light...

http://www.tomshardware.co.uk/wd-raptor-nvidia-g80-dont...

WD didn't acknowledge it then...and it looks like a few generations later...could be something...
January 3, 2009 2:27:54 AM

Some additional thoughts. I had the two VelociRaptors running in RAID on the Asus for a couple of months without errors. The latest RAID drivers could also be the culprit. 8.6.1007 is the latest...where I ran 8.5.1032 until November when the 1007's were released. Two VelociRaptors in RAID on 8/20, added the EVGA GTX 260 on 9/24 and everything was fine until 11/25. So two months with no issues...then it hit the fan. Around the time of release of the 8.6.1007's

January 14, 2009 5:33:43 PM

Any one use the Verify Volume Data option in the Matrix Storage Manager. It said my volume was ok but found some 89 bad blocks and removed them from use. Is it possible that those of us with this issue just have a bad drive? This is the 4th motherboard and different power supply and different SATA cables and the problem keeps coming back. I'm so disappointed, this is my worst build by far. It’s got to be the drives or the Intel chipset or maybe my CPU or RAM :)  but it never fails any RAM test or Prime95 tests. I’m tempted to get two more Samsung 1TB drive and swap these out. The DFI and GB board have both killed a single 1TB drive I have. It did it just last night while running the HD Tune and copying files. Now shows as unknown in drive manager. The DFI board was much worse and I’d get the RAID errors on both RIAD volumes. Maybe it was just the OS reinstall after getting the new MB. Maybe as the OS data get more and more corrupted you get more RAID errors. My system was error free for about a month after the new MB and OS install. ???? This sucks.
January 21, 2009 2:38:13 AM

OK...so I have had my system up and running error free for over a month. Let me share a post that I made on the Asus P5E and EVGA boards. Seems to have helped others as well:

OK...so my new system has the following:

EVGA X58 SLI Motherboard
Intel i7 920
Two WD VelociRaptors (300 GB each) in RAID 0
6 GB of Corsair PC1600 DDR3 SDRAM (3 x 2 for Triple Channel)
EVGA GTX 260 / 216 Superclocked

It was killing me that I had what I thought was the same issue on this board as I did the P5E, but I sorted out the issues over a three week period with three total installs of Vista Ultimate 64 bit on the new system...and came to the conclusion that the tech at Asus was wrong about the Southbridge going out on my P5E. First, let me say that the 4 GB of OCZ PC8500 that I had on the board, did go and die on me...causing some issues. At the same time...let me elaborate on an issue, that I have solved that will stop some people from having blue screens and RAID array's show errors, etc.

Seems that Vista has an extra setting within the Hardware settings for hard drives and RAID arrays. Go to COMPUTER...right click on your hard drive (s) ...Hardware tab...Double click your HDD or ARRAY and you will see a policies tab. On the policies tab...there is a setting to Enable Enhanced Performance (which is really a way of telling Windows to very aggressively cache writes. When In RAID...DO NOT ENABLE THIS! RAID is fast as it is...by enabling...the VelociRaptors will do wierd things...and then blue screen. This issue is not only with the VelociRaptor...but many other hard drives. You get a blue screen and on reboot...you will see that one of your RAID drives is showing in pink: AN ERROR HAS OCCURED. Not fun...takes breaking up the Array to get the error message to go away. Then...I tested the drives, singularly at least four times each...and neither would show errors. This is where Asus stepped in and said that the Southbridge was going on the P5E. WRONG! There is nothing wrong with the P5E Southbridge...so I ended up upgrading my motherboard, processor and memory for nothing (except for the bragging rights to the i7).

OK...so now I decided to put the P5E back to work...I always liked this board...troubles and all...it is one fast MB. In essence, I rebuilt my wife's machine this morning. She ended up with the original system that I build with the board.

Asus P5E with Intel Q9450
4 GB of OCZ PC8500 5-5-5-15
EVGA 8800 GTS 512
The Soundcard that came with the Motherboard (FX) PCIe
Two 160 GB Seagate 7200 RPM HDD's in RAID 0

Etc...

I have to tell you...I installed Vista Home Premium SP-1 64 bit on the machine this morning and it is humming. Took OCZ a week to turn around brand new memory to replace the bad chips...I kept it sitting in a drawer during the holidays..and it drove me crazy that the P5E was back in it's box and not doing it's job. So, based on all that I have learned from the experiences with the P5E and X58...be careful on some of the settings you use in Vista...can come back and bite you. I am going to let Asus know my findings...since I never sent the board in for replacement (would have been a waste of time and money to do so). This board took a pounding and came back out the other side...alive and kicking. I will have many ideas and thoughts to share...I want to thank those who appreciated what I have share til now...and wanted to start by sharing this. There is documentation thoughout the Internet about RAID and Vista and how this "Error Occured" issue has come about. There are many who have not figured it out and want to blame the motherboard makers (not all Asus or EVGA) or the hard drive makers. It's the software, plain and simple...pushing the envelope on something that is already breaking the barrier...

That's it. I am error free on my EVGA X58 system AND the P5E lives and breathes fire for three weeks, error free now. Also...Intel has released new Matrix drivers for RAID. 8.7.1007. I have installed them, but still have yet to initialize the extra setting in Vista for Enhanced Cache Writing. Give it a try...what do you have to lose?

January 21, 2009 1:59:08 PM

Sounds interesting but: Some have this issue with XP and if this setting works as a fix in Vista is it at the cost of some performance? Like you can have a faster drive but only if you slow it down. :)  Also, the SATA-2 spec has a per channel bandwidth at 300MBps but my 200MBps-ish VR RAID-0 is not supported??? :( 

Looks like the setting is in XP also. Under Policies, Write cashing and Safe Removal there is a check box for Enable write caching.

Not at home now but I think there is a write caching setting per RAID volume in the Intel RAID software that is disabled by default and (I would think) take precedents over the OS setting.
January 21, 2009 2:08:32 PM

Virtually NONE! That's the odd part.
January 21, 2009 2:17:35 PM

Added some to my pervious post. :) 

I’ll be sure to give it a shot. Have you been running checkdisk? It seems like every time I run it there is always something it fixes. Indexing error or space marked as used and so on.
January 21, 2009 2:43:05 PM

Haven't seen errors in CHKDSK like that in a long time
Anonymous
a b G Storage
February 12, 2009 9:06:56 PM

bobmitch said:


That's it. I am error free on my EVGA X58 system AND the P5E lives and breathes fire for three weeks, error free now. Also...Intel has released new Matrix drivers for RAID. 8.7.1007. I have installed them, but still have yet to initialize the extra setting in Vista for Enhanced Cache Writing. Give it a try...what do you have to lose?



I'm also error-free since two weeks running the new drivers!
Sad but true to wait over half a year for that fix.

I found much users having the same issue, allway the same sys-config:

- Vista64
- X48 (proberly X58 too)
- VelocyRaptor Raid0 stripe
February 12, 2009 9:34:57 PM

Quote:
I'm also error-free since two weeks running the new drivers!
Sad but true to wait over half a year for that fix.

I found much users having the same issue, allway the same sys-config:

- Vista64
- X48 (proberly X58 too)
- VelocyRaptor Raid0 stripe



I'm running Vista32 with the “New Drivers!” but I still get random errors. Also, if I copy a really large amount of data from the RAID 0 VelocyRaptors to any other drive I have I get RAID errors every time. :( 
February 13, 2009 2:38:33 PM

So you are error free with the new drivers. Did you enable "Advanced Performance" tab as well??? This is good to know

Anonymous
a b G Storage
February 14, 2009 11:36:13 AM

Hi I just discovered this thread on google..
This problem is killing me, the fact is that I thought i resolved it some months ago than bump again..

I have a AsusP5K3 Deluxe and 2 WD Raptor74 in raid 0, Vista 32.
Everytime I boot the pc I fear looking on the boot screen for the pink"ERROR OCURED", like looking at a ghost. Sometime you can boot slowly, but after that you cannot boot anymore, and start over.
The first time it happened after installing the latest version of intel matrix manager, it took some time to understand that you should install the version that you see on the bios screen of ICH9 which is 7.5.0.1017, so I just installed the intel drivers that were on the asus site and not the latest one, on intel site.

As I said everything was fine, until now, when doing some restart bump..
The problem here is that you dont know if you fixed it, because it can happen even after months. This was my first Asus board, after a nForce4 Gigabyte which could burn mosfets in flame, but never burn a raid array. But maybe its an intel , and non asus issue.
I just want to ask, what if not istalling intel matrix manager, because I think that this is the issue, do you lost anything in performance?
As for Asus, they can update the bios portion of intel ICH9, by the way have anybody experienced their support care? Its really funny, its seems like chating with small kids..
They even said not to use raid array!!! for what the f.. I bought a 250$ board?!

I never enabled "advance performance" on the Raid properties in Device Manager, but write caching is enabled by default..
Has anybody experience this without installing imatrix storage manager??
March 30, 2009 10:34:56 PM

Quote:

I never enabled "advance performance" on the Raid properties in Device Manager, but write caching is enabled by default..
Has anybody experience this without installing imatrix storage manager??

Hi I have been experiencing the same without installing the storage manager. I thought it was happening because I didn't instal the storage manager but I was wrong!

I lost a lot of valuable data when I faced this issue before. The raid controller wasn't able to detect my drives. When I contacted Seagate, they told me this was a firmware issue and told me to update the firmware. I wasn't satisfied and I replaced my disks with new ones (Their firmware was the latest). After a fresh install I saw the "Error Occured" message. Then I decided to install the latest MSM and marked the failing drive as Normal. Everything went fine for a week, however tonight, MSM told me that one of my drives in the raid0 volume is failing.

Writeback caching, enhanced performance and hard drive data cache is not enabled.

A few moments ago, I enabled the hard drive data cache (Right Click Array_000 > Enable HDD Data Cache) and marked the failing drive as normal.

This is driving me crazy!

Vista Ultimate 32Bit
Gigabyte GA-P35C-DS3R
4 GB Kingston DDR2 Memory at 800Mhz
2 Seagate XXXX.11 500 GB SATA Drives
Intel E6750 CPU at 2.66 Ghz (No overclocking)
FSP Power Supply
March 31, 2009 5:06:21 AM

I have found that the last two sets of Intel RAID Drivers (8.7.0.1007 & 8.8.0.1009) have alleviated all my problems with my array errors. I was getting errors withing days of a fresh install of Vista Ultimate 64 Bit...now, I have been up and running error free since Jan 1. I first noticed errors after a RAID driver release in Nov...and in Dec Intel released new drivers that were also problematic. The last two releases from Jan and now March seem much more stable. I have all the advanced settings enabled on my RAID and things are stable. You might try the new drivers here...

32 Bit: http://downloadcenter.intel.com/filter_results.aspx?str...*+32&lang=eng&strOSs=164&submit=Go%21]

64 bit: http://downloadcenter.intel.com/Filter_Results.aspx?str... Operating Systems

I am running Vista Ultimate 64 Bit on my EVGA ICH10 Motherboard since Jan with No errors, and I installed Vista Home Premium on my Asus P5E with two 160 GB Seagate 7000.9 drives since Jan as well with No errors. I truly believe that Intel has only fixed the driver issue since the 1007's and so far the 1009's look good, enhanced write caching and all
April 24, 2009 2:04:21 PM

I know that the issue comes and goes for some, myself included and I’ve seen the issue on my system with the VR 300 RAID and a Samsung 1TB RAID. They Samsung RAID also had the errors but not as often as the VRs. I broke up the Samsung RAID and I’ve not seen an error on them since but the VR RAID continued to have errors. I could go weeks without seeing an error but it seems that large long file transfers from the VR RAID would give me an error every time. I even put a test folder with about a 100GB of HD movies and every time I would try and copy it I’d get RAID errors. Then…

I saw that Gigabyte posted (3/19/09) a new BIOS for my board and it had an update to the Intel AHCI ROM. I can no longer force RAID errors by copying my test folder. I’m sure I’ve just jinxed it by posting this but I’m keeping my fingers crossed.
!