Sign in with
Sign up | Sign in
Your question

Microsoft Camera Wizard

Last response: in Windows XP
Share
Anonymous
July 18, 2005 1:12:52 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Can someone please explain this in plain non-techie English? My Microsoft
Camera Wizard no longer comes up when I insert the thing from my HP digital
camera in the slot on my PC. Nothing happens! Just a brief flash of
something on the monitor, then nothing! I can't do the test below because
there is no "add button" when the "perfmon.exe" opens.

How do I get the wizard back so I can unload my camera?

Find all Files and Folders does not find the Microsoft Camera Wizard, and I
can't find it in Windows Explorer/Programs.

I have WXP-Home/SP1. I downloaded some XP security updates but don't know
if they caused the problem.

Thanks........

===================================
Details
Product:Windows Operating System
ID:4099
Source:WmiAdapter
Version:5.2
Symbolic Name:WMI_ADAPTER_OPEN_SC_FAIL
Message:o pen of service failed.

Explanation
The performance counter DLL could not communicate with the Windows
Management Instrumentation (WMI) Performance Adapter service. WMI allows
developers to define high-performance objects. WMI includes a performance
counter DLL that makes these performance objects visible in Perfmon. This
DLL communicates with WMI through the named WMI Performance Adapter service.
When the performance counter DLL cannot communicate with the WMI Performance
Adapter service, WMI high-performance objects are not visible in Perfmon.
The most common reason they cannot communicate is that the service is not
enabled (start type=disabled). Most high-performance objects come from
device drivers such as those commonly used for batteries in laptops.

User Action
To verify that the WMI Performance Adapter service is enabled
Click Start, point to Control Panel, point to Administrative Tools, and then
double-click Services.
Double-click WMI Performance Adapter.
In the Startup type list, click Manual.
To verify that there are high performance counter objects in WMI
Use Cscript to run the following script:
' Find all performance classes
computer = "."
namespace = "root\wmi"

Set WMISvc = GetObject("winmgmts:\\" & computer & "\" & namespace)
Set colSWbemObjectSet = WMISvc.Subclassesof("Win32_Perf")
for each cls in colSwbemObjectSet
wscript.echo "Class name: " & cls.path_
next
The output should look approximately like this:
Class name: \\YOUR-MACHINE\ROOT\wmi:Win32_PerfRawData
Class name: \\YOUR-MACHINE\ROOT\wmi:Win32_PerfFormattedData
Class name: \\YOUR-MACHINE\ROOT\wmi:MSBatteryClass
Class name: \\YOUR-MACHINE\ROOT\wmi:BatteryTemperature
Class name: \\YOUR-MACHINE\ROOT\wmi:BatteryStatus
If Win32_PerfRaw and Win32_PerfFormattedData are the only subclasses, then
there are no high-performance objects in WMI. If there are high-performance
objects in WMI, verify that they are correctly enabled in Perfmon.
To verify that high-performance counters are correctly enabled in Perfmon

At the command prompt, type perfmon.exe, and then press ENTER.
Click the Add button (+). This adds a test WMI object to Perfmon.
In the Performance objects list, click WMI Objects.
Click Add, and then click Close.
In the list of counters, verify that the number of instances for HiPerf
Classes is greater than zero.
This procedure confirms that the start type is manual and the WMI
Performance Adapter service is enabled. If this corrective action does not
solve the problem, check for other error messages that are closer to the
root cause.

Currently there are no Microsoft Knowledge Base articles available for this
specific error or event message. For information about other support options
you can use to find answers online, see
http://support.microsoft.com/default.aspx.
Anonymous
July 18, 2005 1:20:18 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

~ Free Spirit ~ wrote:
> Can someone please explain this in plain non-techie English? My
> Microsoft Camera Wizard no longer comes up when I insert the thing
> from my HP digital camera in the slot on my PC. Nothing happens!
> Just a brief flash of something on the monitor, then nothing! I
> can't do the test below because there is no "add button" when the
> "perfmon.exe" opens.
>
> How do I get the wizard back so I can unload my camera?
>
> Find all Files and Folders does not find the Microsoft Camera Wizard,
> and I can't find it in Windows Explorer/Programs.
>
> I have WXP-Home/SP1. I downloaded some XP security updates but don't
> know if they caused the problem.
>
> Thanks........

- Why SP1? Why have you chosen not to update?
- Installed your camera/card reader's drivers/software yet? Checked for
updates?
- Sounds like you have a card reader - dos the card work in another
computer's reader?
- Do any cards work in said reader?
- Is it just one user with the problem, or does any user logged into your
computer have this issue?
- Have you contacted HP? Looked on their web page for patches?

--
Shenan Stanley
MS-MVP
--
How To Ask Questions The Smart Way
http://www.catb.org/~esr/faqs/smart-questions.html
Anonymous
July 19, 2005 4:47:58 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

"Shenan Stanley" <newshelper@gmail.com> wrote in message
news:o 45$%238ziFHA.3012@TK2MSFTNGP12.phx.gbl...
> ~ Free Spirit ~ wrote:
> > Can someone please explain this in plain non-techie English? My
> > Microsoft Camera Wizard no longer comes up when I insert the thing
> > from my HP digital camera in the slot on my PC. Nothing happens!
> > Just a brief flash of something on the monitor, then nothing! I
> > can't do the test below because there is no "add button" when the
> > "perfmon.exe" opens.
> >
> > How do I get the wizard back so I can unload my camera?
> >
> > Find all Files and Folders does not find the Microsoft Camera Wizard,
> > and I can't find it in Windows Explorer/Programs.
> >
> > I have WXP-Home/SP1. I downloaded some XP security updates but don't
> > know if they caused the problem.
> >
> > Thanks........
>
> - Why SP1? Why have you chosen not to update?

## I did update and couldn't stand SP2. It was a real PIA. I unsinstalled
it.

> - Installed your camera/card reader's drivers/software yet? Checked for
> updates?

## No updates are needed as everything was working fine, had been for
months - then NOTHING but that brief flash - no wizard.

> - Sounds like you have a card reader - dos the card work in another
> computer's reader?

## I don't have another PC with WXP so I can't know or test that.

> - Do any cards work in said reader?

## What reader? The wizard read the memory stick from the camera.

> - Is it just one user with the problem, or does any user logged into your
> computer have this issue?

## I'm the only one that uses this PC.

> - Have you contacted HP? Looked on their web page for patches?

## Why would HP have a MS camera wizard patch? The problem started
suddenly after over a year of working flawlessly.
>
FS.......
Related resources
Anonymous
July 19, 2005 12:46:24 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

~ FreeSpirit ~ wrote:
> Shenan Stanley wrote:>> ~ Free Spirit ~ wrote:
>>> Can someone please explain this in plain non-techie English? My
>>> Microsoft Camera Wizard no longer comes up when I insert the thing
>>> from my HP digital camera in the slot on my PC. Nothing happens!
>>> Just a brief flash of something on the monitor, then nothing! I
>>> can't do the test below because there is no "add button" when the
>>> "perfmon.exe" opens.
>>>
>>> How do I get the wizard back so I can unload my camera?
>>>
>>> Find all Files and Folders does not find the Microsoft Camera
>>> Wizard, and I can't find it in Windows Explorer/Programs.
>>>
>>> I have WXP-Home/SP1. I downloaded some XP security updates but
>>> don't know if they caused the problem.
>>>
>>> Thanks........
>>
>> - Why SP1? Why have you chosen not to update?
>
> ## I did update and couldn't stand SP2. It was a real PIA. I
> unsinstalled it.

Ah - one of those.

>> - Installed your camera/card reader's drivers/software yet? Checked
>> for updates?
>
> ## No updates are needed as everything was working fine, had been for
> months - then NOTHING but that brief flash - no wizard.

Yeah - you install Windows XP updates and don't think you need any other
updates. No. Nothing could change with the Windows Updates that could
cause you to need updates for your Camera/Card Reader software.. Nope..
Right.....

>> - Sounds like you have a card reader - dos the card work in another
>> computer's reader?
>
> ## I don't have another PC with WXP so I can't know or test that.

No friends either? Someone you know must have a computer.

>> - Do any cards work in said reader?
>
> ## What reader? The wizard read the memory stick from the camera.

So - I forgot my mind-reading cap again. Still sounds to me like you need
to uninstall/reinstall the camera software and check for updates from the
camera manufacturer's web page..

>> - Is it just one user with the problem, or does any user logged into
>> your computer have this issue?
>
> ## I'm the only one that uses this PC.

That's great - create another user anyway - just because you are the only
one that uses the computer doesn't mean you cannot have multiple users (you
already do whether you know it or not) and it definitely doesn't mean your
profile has not gone corrupt on you. Create another user and verify the
problem is not user-specific.

>> - Have you contacted HP? Looked on their web page for patches?
>
> ## Why would HP have a MS camera wizard patch? The problem started
> suddenly after over a year of working flawlessly.

Why would HP have... hmmm Let's think here - although I may be wrong on the
type of camera - *if* it was an HP, it is their responsibility - not
Microsoft's - to make the camera work with whatever OS you choose.. unless
(of course) they choose not to (which many system manufacturer's love to
do.) So - *if* the camera is an HP, then they may have a "patch" to
counteract the installation of some Microsoft patch that you installed so
that your camera works agoan.

Did you ever try simply uninstalling the uupdates you installed right before
noticing the problem? Did you ever go to the manufacturer's web page for
the camera just to check if those who made the actual hardware might have
advice/drivers?

So what if it was working fine for a year - nothing last forever - even you
will stop working - no matter how flawlessly you worked for the year
beforehand. heh In this case though - you have clues to go on and a
possibility of fixing it. =)

--
Shenan Stanley
MS-MVP
--
How To Ask Questions The Smart Way
http://www.catb.org/~esr/faqs/smart-questions.html
Anonymous
July 28, 2005 3:41:46 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

"Shenan Stanley" <newshelper@gmail.com> wrote in message
news:eYMGBhGjFHA.1412@TK2MSFTNGP09.phx.gbl...
>~ FreeSpirit ~ wrote:
>> Shenan Stanley wrote:>> ~ Free Spirit ~ wrote:
>>>> Can someone please explain this in plain non-techie English? My
>>>> Microsoft Camera Wizard no longer comes up when I insert the thing
>>>> from my HP digital camera in the slot on my PC. Nothing happens!
>>>> Just a brief flash of something on the monitor, then nothing! I
>>>> can't do the test below because there is no "add button" when the
>>>> "perfmon.exe" opens.
>>>>
>>>> How do I get the wizard back so I can unload my camera?
>>>>
>>>> Find all Files and Folders does not find the Microsoft Camera
>>>> Wizard, and I can't find it in Windows Explorer/Programs.
>>>>
>>>> I have WXP-Home/SP1. I downloaded some XP security updates but
>>>> don't know if they caused the problem.
>>>>
>>>> Thanks........
>>>
>>> - Why SP1? Why have you chosen not to update?
>>
>> ## I did update and couldn't stand SP2. It was a real PIA. I
>> unsinstalled it.
>
> Ah - one of those.

$$$ I reinstalled SP2 the other night. This time there are/were no
problems. :-)

>>> - Installed your camera/card reader's drivers/software yet? Checked
>>> for updates?

>> ## No updates are needed as everything was working fine, had been for
>> months - then NOTHING but that brief flash - no wizard.

> Yeah - you install Windows XP updates and don't think you need any other
> updates. No. Nothing could change with the Windows Updates that could
> cause you to need updates for your Camera/Card Reader software.. Nope..
> Right.....

$$$ I don't know - you tell me! Does updating MS products mean I also have
to start hunting down updates for everything else now?

>>> - Sounds like you have a card reader - dos the card work in another
>>> computer's reader?

>> ## I don't have another PC with WXP so I can't know or test that.

> No friends either? Someone you know must have a computer.

$$$ Not one with that slot to read a card - no.

>>> - Do any cards work in said reader?

>> ## What reader? The wizard read the memory stick from the camera.

> So - I forgot my mind-reading cap again. Still sounds to me like you need
> to uninstall/reinstall the camera software and check for updates from the
> camera manufacturer's web page..

$$$ It looks that way........

>>> - Is it just one user with the problem, or does any user logged into
>>> your computer have this issue?

>> ## I'm the only one that uses this PC.

> That's great - create another user anyway - just because you are the only
> one that uses the computer doesn't mean you cannot have multiple users
> (you already do whether you know it or not) and it definitely doesn't mean
> your profile has not gone corrupt on you. Create another user and verify
> the problem is not user-specific.

$$$ I don't know what you mean to "create another user." I wouldn't know
how to do that.

>>> - Have you contacted HP? Looked on their web page for patches?

>> ## Why would HP have a MS camera wizard patch? The problem started
>> suddenly after over a year of working flawlessly.

> Why would HP have... hmmm Let's think here - although I may be wrong on
> the type of camera - *if* it was an HP, it is their responsibility - not
> Microsoft's - to make the camera work with whatever OS you choose.. unless
> (of course) they choose not to (which many system manufacturer's love to
> do.) So - *if* the camera is an HP, then they may have a "patch" to
> counteract the installation of some Microsoft patch that you installed so
> that your camera works agoan.

$$$ I'll do a search for a "patch." I can see why people dislike updating
so much now. You update one thing and that screws up something else.... so
you update THAT, and something else gets screwed up.

you ever try simply uninstalling the uupdates you installed right before
> noticing the problem?

$$$ Nothing was changed before the problem started with the camera.

Did you ever go to the manufacturer's web page for
> the camera just to check if those who made the actual hardware might have
> advice/drivers?

$$$ No, why would I since I wasn't have a problem?

> So what if it was working fine for a year - nothing last forever - even
> you will stop working - no matter how flawlessly you worked for the year
> beforehand. heh In this case though - you have clues to go on and a
> possibility of fixing it. =)

$$$ I'll see if I can find an update for the camera after reinstalling the
sw - and hope to god updates for the camera don't fxxx up Photo Deluxe or
some other sw ..........

Thanks......

FS.......
>
> --
> Shenan Stanley
> MS-MVP
> --
> How To Ask Questions The Smart Way
> http://www.catb.org/~esr/faqs/smart-questions.html
>
!