Sign in with
Sign up | Sign in
Your question

VPN is disconnecting every 3-4 minutes

Last response: in Wireless Networking
Share
Anonymous
a b D Laptop
March 5, 2009 4:57:47 PM

I have a broadband connection. I am able to connect to my workplace VPN when I directly connect my laptop to the modem.

But when I connect the modem to the Wireless router , and my laptop connects to the internet using wifi. Now if I connect to the VPN, the VPN is disconnecting in 3-4 minutes.

I am using windows VPN connection.

When I put my system in the DMZ , the vpn is not getting disconnected every 3-4 minutes. But I am facing very low browsing speed.

Please help me solve this issue.
May 25, 2009 4:07:01 AM

I know this thread is a few months old, but I was pulling my hair out for over a year trying to figure out why my VPN kept disconnecting after 3 minutes whenever I was connected via router, but worked fine when I connected directly to my DSL modem.

I searched everywhere on the internet, and couldn't find a solution to this problem. So, hopefully, this will help others searching online trying to figure out how to solve this particular VPN disconnect issue.

Anyway, the solution lies within how the modem and router are configured for PPPoE and NAT. I'm not going to try and explain what that stuff means (maybe someone else can), because I don't understand it. But, long story short, I logged into my modem (in my case, my DSL modem had an address of 192.168.something) and noticed that it was set for PPPoE on the modem level. What I had to do was change that setting so that it was performed at the router level. This probably means that you'll have to configure your router to log into your ISP's network (so you'll have to remember whatever your ISP username/password is).

If you do a google search for "Double NAT" you'll find out more about what's causing the problem. I found this link which seems to give a decent explanation: http://support.iprimus.com.au/index.php?Itemid=214&id=5...

So, if you can log into your modem and your router (using your web browser) to change their settings, you should be able to solve this problem.
April 24, 2012 6:31:46 AM

Even though this explained the same problem I was having, the resolution didn't involve "Double NAT". The solution was a simple check box on my D-Link router in the APPLICATION LEVEL GATEWAY (ALG) CONFIGURATION. See here for the solution to this problem for me.
a b D Laptop
April 24, 2012 8:07:21 AM



Hello and welcome to Tom's Hardware Forums.

Your link is to a post nearly as old in relative terms as this necro thread you've resurrected. Do you think these folks haven't resolved their problem by now? Do you by any chance have financial interests in that website?


!