Sign in with
Sign up | Sign in
Your question

GA-P35-DS3R/S3R Version 1 Intel RAID problem

Last response: in Motherboards
Share
December 16, 2007 6:21:20 PM

I currently run a P35-DS3R/S3R Version 1 motherboard.

The rest of my hardware:

2GB (2x1GB) Corsair DDR2 XMS 2 800mhz
XP Pro sp2
2 160GB Hitachi SATA drives
8800GTS 640mb

My problems I've been having are using RAID. According to my user manual I have the P35 Express Chipset as well as the ICH9R SATA/RAID controller. I followed procedure on installing RAID on the two SATA drives. I am using RAID 1 and it configured successfully. Prior to setting these drives in RAID 1 I made a complete backup/clone (sector by sector) to another drive using Norton Ghost. Once I created that RAID for those two disks, I then copied everything back using Ghost to the disks set up in RAID. The name of that raid partition is JDr1 and that's where the data was copied. In bios, under Integrated Peripherals, I changed SATA RAID/AHCI Mode to RAID as manual says which only seems correct. Once I saved and loaded the OS I get a blue screen and it immediately restarts and loops over and over. It does this in both Normal and Safemode.

I then thought maybe I need to update the drives so I set SATA RAID/ACHI mode to disabled to boot into Windows. I went to the Gigabyte website to download the latest Intel drivers for the Intel SATA/RAID controller. Upon installing I get an error saying, "This computer does not meet the minimum requirements for installing this software. Setup will now exit." I then thought that was really weird so proceeded to Intels site to download the drivers hoping this was a mistake. I found the drivers and got the same error. I then download the IntelĀ® Chipset Identification Utility and then it shows me I don't have the P35 Express chipset but I have the Detected Chipset: Intel(R) G33 Express Chipset. For my other chipset components it gave me the following:

Memory Controller:
Intel(R) 82G33 Memory Controller Hub

I/O Controller:
Failed to identify your ICH

Integrated Graphics:
Not Detected or Disabled

No I/O Controller?!? I don't see how it can't recognize anything if it set up RAID
just fine in the BIOS using Intel Matrix Storage Manager. The RAID even showed up in bios just fine. Any idea's what's going on?
December 16, 2007 10:16:47 PM

I cant explain the non ICH detect however,

Ive heard of the BSOD's once changing to RAID. The only way ive heard of fixing it is reinstalling windows. When booting the windows setup you need to press F6 to load your RAID driver so it detects the drive.

Its also a bit hard for the system to install RAID drivers if the RAID is disabled in the bios which is the reason why you get this "This computer does not meet the minimum requirements for installing this software. Setup will now exit."
December 17, 2007 2:20:27 AM

I am experiencing the exact same problem with a Gigabyte GA-P35-DS3L.

To clarify, this is what the Intel Chipset Identification Tool is showing:

Chipset

Detected Chipset:
Intel(R) G33 Express Chipset

Chipset Components

Memory Controller:
Intel(R) 82G33 Memory Controller Hub

I/O Controller:

Failed to identify your ICH

Integrated Graphics:
Not Detected or Disabled

Pretty crazy, seeing as how my board is supposed to have the P35 chipset. Unlike rootjd's board, my board does not have RAID capabilities.

I'm experiencing another very strange problem (Vista 64-bit won't intstall, BSOD before the first installation screen appears) and this is a brand-new motherboard, so I have to wonder if I have a faulty product at this point.
Related resources
December 17, 2007 1:33:27 PM

Just tried a clean install using Vista. I had both drives in RAID, and just in case have a floppy containing the drivers for the ICH RAID Controller. I proceeded to do a clean install of Windows Vista x86 and noticed the Raid volume did in fact show up as well as the other partition which is about 5.7GB for the pagefile. So the two drives still have all of the XP installation as well as all of my files. They're identical. Once I selected the volume "drive 0" 147gb, Vista wouldn't go any further and told me "Windows is unable to find a system volume that meets its criteria for installation"

So I figured it was the drivers. I took the floppy and tried to install them by using the button during the install to get the drivers in the system but they failed to load. I got an error saying the Intel ICH8/ICH9 SATA RAID driver could not be installed.

Amankhan, I'm wondering the same thing myself. I'm also not comfortable with Gigabyte becuase I've tried to call them numberous times and the same lady (operator) answers and always says they're out to lunch and I must leave a message. I've left messages and still no response.
December 17, 2007 1:58:48 PM

rootjd--
Can you verify that you're using the Intel Matrix raid and not the Gigabyte raid? (Both in the BIOS utility and the driver disk?)


Can you post exactly what drives you have in the system, and how they are configured for RAID?

As a note, Vista ships with RAID drivers for ICH9 and several versions prior. In AHCI mode, you can install using the Vista AHCI drivers, but you won't get RAID capability.

Can you try removing all disks except the one(s) you're trying to install to?

Another thing to note-- with Intel Matrix Storage Manager, you can migrate from a single disk to a RAID volume, even if the single disk is your boot volume. So, if you can install to a single disk in RAID mode, you can later do a "Create from Existing" which will migrate from your single disk to, say, a RAID1 volume. The only thing to note is that if you have 2 disks, install on the smaller of the two because when doing a "Create from Existing" the disk(s) you add must be at least as big as the original disk.


December 17, 2007 2:28:51 PM

Rockchalk,

I am using the Intel RAID configured in RAID 1 Mirror with a 5.7 GB partition. The two drives I'm using for the RAID1 are Hitachi Deskstar HDS722516VLSA80.

I have those two drives cloned from another drive. Now when I try booting from just one drive, the keyboard is nonresponsive. I've tried PS/2 and 2 usb keyboards and still nothing. I even tried booting in safemode and still no success which is why I am willing to overwrite all data on the 2 cloned drives (not my one drive with the OS). I am on AIM at r00tjd. I'll even bump some points up too =]
December 17, 2007 2:47:46 PM

rootjd--

When you say you have keyboard issues when booting from just one drive 1) Man, that's weird and 2)Is it a single non-RAID disk or a degraded RAID1 volume?

Have you tried installing using a single unformatted disk while in RAID mode?

Is your goal to install XP or Vista? You are willing to clean install, correct?

Don't worry about points-- I'm more interested in the problem and its solution.

BTW, Intel Matrix RAID 1 volumes-- you can go into the OROM (bios utility) and "mark disk as non-RAID" When you do this on a disk in a RAID1 volume, the disk will no longer be part of a RAID volume, but it will still have all of the data that was on the RAID volume-- it'll still be bootable if the volume was.


Hmm, another thought-- what port is your CD/ DVD drive attached to? Is it one attached to the ICH or the Gigabyte controller?

In the BIOS, what is the boot order? Is it the optical disk followed by the RAID volume?
December 17, 2007 3:06:23 PM

Rockchalk,

It is very weird because now I'm not able to use any keyboard.

I have no tried installing using a single unformatted disk while in RAID yet.

I wonder why the floppy RAID driver I downloaded from their site will not work when I click Load Drivers during Vista setup. very strange

One of them is a single non raid disk (raptor-x) which has the same problem as a single raid disk (one of the hitachi's). The boot order is floppy, hard disks, then cdrom. The cd/dvd drive is IDE and attached to the only IDE interface (presumably the ICH) on the board.

But yes I'm willing to do a clean install of VISTA on the two Hitachi's while keeping the backup of my data on the Raptor.
December 17, 2007 4:53:21 PM

You should try this. If what I understand is that the RAID array has XPSP2 installed on it now.
1. reset the bios to defaults, restart
2. set bios options to RAID on Intel sata controller, restart
3. Your raid that was setup previsously should now show on the Intel controller during boot.
4. Boot from XP CD
5. Hit F6 during XP setup
6. Hit S and use the Intel ICH9R RAID floppy driver
7. Continue to the 2nd ,, I repeat,, "2nd" repair option and do a windows repair.

That should install the Intel RAID driver and allow the OS to boot while on the Intel RAID controller set to RAID.
Link to the Intel F6 driver for the ICH9R controller : http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...* XP Professional&lang=eng
January 16, 2008 10:33:00 AM

@Amankhan:
DS3L doesn't have Intel Matrix RAID. Only DS3R has the proper chip (ICH9R).

@All:
RAID works on this board but you need to:

1. Switch to RAID mode in BIOS
2. Install Windows using F6 method (floppy with RAID drivers)

If you already have Windows installed in RAID mode with Intel Matrix Storage drivers like I did (because I had ICH7R before), you can boot to DOS and using DISKEDIT.EXE from Norton Utilities edit the file C:\WINDOWS\SYSTEM32\CONFIG\SYSTEM (but make a backup first). Your goal is to replace all instances of PCI system, vendor, subsystem and subvendor ID with those of your new controller.

For example, if you had ICH7R on Intel made mainboard and now you have Gigabyte, you will search for:

  1. VEN_8086&DEV_27C3&SUBSYS_58428086&REV_01


And replace it with:

  1. VEN_8086&DEV_2822&SUBSYS_B0001458&REV_01


You also need to replace:

  1. pci#ven_8086&dev_27c3&cc_0104


With:

  1. pci#ven_8086&dev_2822&cc_0104


In other words, you need to find all instances of similar strings (be it ANSI or Unicode) which mention DEV and 27C3 and replace 27C3 with 2822. For me it worked, but keep in mind that I alread had RAID drivers installed.

Moreover, you cannot install RAID drivers unless the controller is set to RAID mode in BIOS because its system ID changes. There is a workaround (untested though) -- you can try to install the RAID driver manually by copying inf, cat and sys files to appropriate locations and adding proper registry keys (which you can find in iastor.inf file). But that is no small task, it requires good understanding of the .inf file structure and registry.

It is simpler to just switch to RAID mode and reinstall Windows.
January 23, 2008 5:00:38 PM

so like most people using the gigabyte GA-p35-DS3R i've had pretty annoying RAID issues. I originally had a RAID 1 (d:\ not for booting). I installed windows(had F6 issues) and didnt have the bios setup correctly for RAID. Had a lovely blue screen on just about any RAID attempt booting up in XP.

So im going to reinstall windows XP with the BIOS settings of the Intel Matrix Raid turned on. Should i also set the OnBoard Sata/IDE Control Mode to RAID or IDE?

ALso when installing windows. Should i install floppy drivers for the Intel Matrix as well as from a second floppy containing the Jmicron Drivers or will installing 2 sets of drivers mess with windows?

1 last thing. Lets say i get the RAID setup ok and Windows installs fine and loads up fine...do i need to install a RAID manager inside windows as well??
February 16, 2008 3:24:45 AM

@justlearning:
1. As I said one cannot switch to RAID once the Windows has been installed in non-RAID mode. Windows has to be installed with RAID drivers, or otherwise when you switch the controller to the RAID mode it will not be able to see the disk and thus will be unable to boot from it.

2. If you will be using Intel RAID, then you need to enable just Intel RAID. Enabling RAID mode for Jmicron controller will most likely prevent you from using IDE CD/DVD drive.

3. If you don't have any IDE devices connected to Jmicron controller, you can also install Jmicron in RAID mode using floppy drivers, but you can also do that later after Windows finishes initial install using newer drivers from the website if any.

4. You don't need the manager unless you want to manage your RAID (add drives, make new volumes, monitor health, etc). What you will need though is Intel Chipset Installation Utility to properly install other mainboard devices such as PCI-Express and USB ports.
Anonymous
a b V Motherboard
January 18, 2009 1:06:00 AM

Hello Everybody.

I have the same or almost the same problem. I used to have NVIDIA Motherboard with RAID Mirroring configuration active. Because the motherboard stop working I had to move to buy a GA-EP45C-DS3R motherboard

Note: I have two 500GB Maxtor HHD.

Because, this is a new motherboard and I had already install windows xp. I fallow the next steps.

1) I disable one of the both hard drives, so I just keep one.
2) I enabled RAID feature in the BIOS.
3) I created a floppy with the RAID driver.
4) I reinstall windows and pressed F6 to install the new RAID drivers.
5) I selected repair windows
6) Everything worked fine until the windows login showed up ("Windows is starting up").

Windows stop in this step and I don't know what else to do. I tried to login in safe mode but I had the same result.

Any idea what is causing that windows stop in this step?

Regards MangelRuiz
!