Sign in with
Sign up | Sign in
Your question

Raid 1 - Hdd Crash - Cant boot

Last response: in Storage
Share
August 25, 2008 12:27:17 AM

Hello.

I seem to have a big problem.
I just recieved all my new hardware for my new computer, which i quickly installed.

I created a Raid 1 with 2 partitions with my 2 new Seagate 7200.11 harddrives.
Everything went fine, and i started installing all the programs i need and then moved all my data from my old laptop.

Everything was perfect up til now.

Then suddenly while installing a program it stalled and i had to do a hard boot.
It booted right up and there were no errors to be found.

I thought it was a problem with the software.
Soo i tried again and everything went fine.

Then installing another program later it went down again.
This time while booting, during the post screen where it shows the raid information it showed that one drive had a failure the other one was okay.

I went into the Raid settings but couldnt really do much. It showed that the 2 partitions wasnt bootable and one disk had an error.

I tried removing the disk with the error, but it still wouldnt boot up on the other drive.

I tried connecting only the drive with the error and when i entered the raid options at post it said that the drive had an error and asked if i wanted to correct it / rebuild it - i answered yes.
Then it changed status for the drive to being okay, and it showed both partitions as Rebuild and Bootable.
At the bottom of the screen it wrote that Volumes would be rebuild within the operating system.

Great i thought.

But no success.
When i try to boot up on the drive with the failure it actually goes to vista load screen and load files (the same in safe mode), but then it just stops suddenly.

If i connect only the drive that "should be" alright, it writes that it isnt bootable in the raid settings (at post).

If i Connect both drives now, it still writes Rebuild and that they are bootable. But it does the same as when only the drive with the error is connected. It starts loading and the stops.


It seem that it is a big problem as it will first rebuild the disk in the OS but i cannot enter the OS.
Soo even when i get my new hdd i am not able to rebuild the partitions.


Is there anything i can do here ?



I am thinking about installing the OS on the new disk and then try and see if am able to backup the data of the raid drive, and then create a new Raid 1.

But it seems pointless to create a Raid 1 when it is actually more or less unusable (it seems).


Could i set the drive as IDE in the bios instead of Raid ?
I have tried setting it as ACHI, which "works" in the way that the drive which didnt seem to have an error actually was bootable and it started loading Vista, but it just kept restarting all the time at a certain point during load.
Could it harm the data on the drive, if setting it to IDE ?



Best regards

Martin


More about : raid hdd crash boot

August 25, 2008 2:03:01 AM

Status update:

I managed to get the OS to load by doing a Vista Repair.
It actually didnt work (at least it wrote).

But when i restarted it wrote that the partition with OS was bootable (the other one still wasnt).

Right now it is trying to rebuild.


I will need to figure out to make both disks bootable, and somehow verify that both disks are 100% okay or if one of them should be replaced.

Anyone know how i can check if the disk is 100% okay ?
!