Sign in with
Sign up | Sign in
Your question

High CPU usage on one core of E6600

Tags:
Last response: in CPUs
Share
December 4, 2007 1:50:42 PM

Has anyone run across this issue?

Some background:
I recently installed an EVGA 8800GT (plain vanilla - no overclock), and I botched the install a bit because I neglected to uninstall the drivers for my 7900GTO before installing the 8800GT drivers. Once I got that all figured out, I ran some benchmarks and was surprised to find that my scores with the 8800GT were all lower than with my 7900GTO. I was at about 5900 in 3DMark06 before the upgrade and about 5200 after. In 3DMark05, I was at 10,200 approximately before and about 9800 after. My Fear benchmark improved ever so slightly from 38FPS average to 39FPS at 1920x1200 with all of the goodies enabled. I flashed the BIOS for my motherboard as well as the chipset driver, but that didn't seem to solve my problem. Device manager shows the adapter as working properly. As I was looking for the root cause, I noticed that my CPU usage was heavily assymetrical. At idle, core 1 was under heavy usage while core 2 was barely registering. Under load, the second core ramps up, but seems to stay about 30% below core 1, unless core 1 is maxed. Task manager shows only system idle processes taking up 98 to 99% of the cycles. When I click the "Performance" tab and select View>Show kernel times, almost all of the usage is kernel related (shows up red).

Since I can't identify specific processes that may be causing this issue, I'm wondering what my next steps should be in getting to the root cause of my problems, both with the strange CPU usage and my graphics card performance. I think I will try uninstalling the 8800GT and reverting fully to the 7900GTO and see if I can replicate my old benchmarks and, more importantly, see if this solves my assymetrical cpu usage issue. Is there a CPU analyzer that can give me more info on what the heck core 1 on my CPU is doing? I have CPU-Z installed, but all that tells me is that both cores are 2.4GHz.

Oh, a couple of other bits of information that may or may not matter:

1) CPU-Z shows my multiplier occasionally going from the normal value of 9 down to 6 and back again, or course affecting the clock speed (2.4GHz to 1.6GHz). Is this normal?
2) The CPU usage for core 1 bounces constantly in 3-10 %pt increments, so it will go from 35 to 41 to 32 to 38, etc., changing every second or two. Again, is this normal? All the while, core 2 is barely registering any usage...most often zero.
3) It's been about a week since my last anti-virus and spyware scan (ZoneAlarm)...I kicked off a scan this morning so I'll see if it turns up anything when I get home this evening.

Any suggestions? I'd really appreciate some help as I'm pretty new to being my own sysadmin since building my computer late last year.
December 4, 2007 1:59:49 PM

You should be able to isolate the process.

On taskmanager (alt+ctrl+del), click processes, then click twice on CPU column. That should put any processes using the CPU on top.

Yes, its normal to see the multiplier switch 6 to 9. Its speed step which was designed to help reduce power consumption and heat.

With my system at idle, its basically 99% idle, so it shows 1-3% usage. So you do have something running in the background. You just need to figure out what.
December 4, 2007 2:35:44 PM

You may want to give process explorer a shot too, to see if you have hardware interrupts leeching CPU.
Related resources
December 4, 2007 2:44:18 PM

Thanks for the post, Grimmy. Good to know that the multiplier changes are normal.

I thought my config would show up in my post, but since it didn't, here's what I'm running (all at stock speeds):

ASUS P5B DELUXE/WIFI
Intel Core 2 Duo E6600 w/Arctic Cooling Freezer 7 Pro
EVGA 8800 GT
2GB OCZ Platinum XTC PC6400
Seagate Barracuda 160GB & 320GB HDDs
Creative Labs X-Fi Xtreme Music
Antec Truepower Trio 550
Thermaltake Armor
XP Professional
Dell Ultrasharp 24" 2407FPW
Logitech G15 keyboard and G5 mouse
December 4, 2007 3:22:21 PM

ghmage, thanks for the post. Process Explorer looks like it will be helpful. In looking it up, I came across the Sysinternals web page, and I think I will also look at RootkitRevealer (since I believe the processor usage is the result of kernel activity), and LiveKd (a kernal debugger).

I'm clearly in over my head! Hope I don't brick my system!
December 5, 2007 4:00:07 PM

Have you had any luck fixing this? I have an E6600 based system that is doing this exact same thing. Seemed to start up out of the blue and I couldn't identify anything new that had been done/added to the system to start this.

After a reboot it won't do it at first but at some point 5 or 10 minutes later it will just start up, maxing the the first core. Even if you don't even touch the system after rebooting, other than logging in.

It is doing it on my wife's system. We each have identical systems and it is not doing it on mine. Please let me know if you have figured out anything on the cause and fix of this!

I have updated the BIOS on both machines to the latest version and made sure she has the same driver versions I have, still no luck resolving it.
December 5, 2007 5:03:05 PM

Working through the problem whenever I get time. I managed to download and run Process Explorer - you can get this from the Sysinternals website at:

http://www.microsoft.com/technet/sysinternals/default.m...

...I'm finding this site quite useful for both system diagnostic utilities and the forum. Process Explorer shows that my high cpu usage is caused by hardware interrupts. This only gets you partway there because you have to figure out what hardware. From what I've read, the next step will be to download and run a utility called RATTV3, which can be found at:

http://www.microsoft.com/whdc/DevTools/tools/RATT.mspx

My understanding is that this will identify the particular device driver that is hogging my cpu cycles at the kernel layer. Take a look at this thread on the Sysinternals forum:

http://forum.sysinternals.com/forum_posts.asp?TID=12353...

Let me know if you figure out your issue. I'll post my findings once I have a chance to do some more poking around tonight.
December 6, 2007 12:48:51 AM

Awesome thanks a lot JJ! I was just about to post the same findings on mine. I was running the Process Explorer on her machine until the CPU0 starting hogging .. and sure enough, same as yours, it is Hardware Interrupts that are doing it.

Thank you for posting the next steps on where we go from here, with the RATTV3 utility.

I will post as when I can run that utility and find out which actual device driver is the culprit.

Thank you again for posting those next steps, that would have been my first question once I found out it was the Hardware Interrupts causing it. =D
December 7, 2007 12:17:43 AM

jeejoo,

I found the cause of my problem. I'm a bit embarrassed to say that it was caused by a tv tuner card that wasn't seated properly. Interestingly enough, one of the first things I did when I encountered my problem was to check that nothing was unseated during my videocard upgrade, and everything seemed in order. It wasn't until I noticed that none of my shows were recording that I discovered that my computer couldn't find my tv card. I had to physically remove and reseat the card for it to work.

I'm a bit embarrassed that the first thing you should check was the culprit, but I'm posting so that it can be a lesson to other noobs who are trying to diagnose high cpu usage problems. Do yourself a favor and physically remove and reseat all pci/agp cards and ram before doing anything else!

Good luck with your issue. I learned quite a bit about my computer using Process Explorer, Process Monitor, RATTV3 and Rootkit Revealer! Oh, and I now have a defragged and error checked hdd, and I've used ccleaner to clear out a bunch of detritus!
December 7, 2007 6:14:45 AM

Oh it happens. :lol: 

I remember when I worked as Lan Administrator, my boss had a problem with his laptop. He powered up his laptop, and his CRT monitor didn't come up Turns out he didn't latch his laptop to the docking station.

Boy was he embarrassed. After that he said... I could have done that myself, now.. get to werk! :lol: 
!