Sign in with
Sign up | Sign in
Your question

Problems with detection of SATA Hard Drive

Last response: in Storage
Share
September 8, 2008 8:51:23 PM

Motherboard: Asus P5KC
HDD: Seagate Sata II 250gb

It's plugged into a master slot of the 4 ICH9 Intel Sata ports.

First of all, the Bios detects it. But on first boot up it hangs for about 40-45 seconds on the SATA Hard-drive detection.

No matter what I do I can't get anything else to see it. I'm currently booting from an old IDE drive because I couldn't get a fresh install of XP or Vista to see it. But I can't even get my currently loaded Windows XP x64 to see it after installing the Intel chipset drivers from the Intel website.

There is NOTHING to indicate it exists in device manager.

NOTHING can see this bloody drive.

I've tried changing the cables, and messing with all the appropriate bios settings.

It's got to be something obvious, it always is. What's the deal?

Unfortunately I cannot use the one Jmicron SATA slot on my board because my graphics card won't fit in with it plugged it. So it has to be these ICH9 things.

Cheers,
Rich
September 10, 2008 9:36:42 AM

in my opinion you should look for switching the reference of the HD on the bios , try playing with it from RAID to IDE, sometimes it works.

there is something I dont understand,
its an additional HD or the primary where you need to boot up from?
if its addition and its sata and not IDE then change ICH slot.
if its primary and you cant boot up from , its because you lack the driver of the sata controller which you need to insert in a floppy when you install XP .

check for cables , maybe it wont get electricity or maybe the sata cable is not good.

if you still find problems contact me.
September 14, 2008 8:55:46 AM

I am suffering from the EXACT same problem. I've got a Seagate 750gb SATA slave data drive that just simply stopped working. I'm suffering the same computer "hangs" that you're describing. If I power down my system completely then power it up I boot into Windows fine. If I'm quick enough I can open up Windows Explorer and see that my HDD is recognized, then after a few seconds my screen freezes, all HDD activity stops (across all drives), and I simply have to wait. Sometimes lasting minutes, it finally returns control to me. Upon doing so, my previously viewable HDD now disappears and is unrecognizable by ANYTHING just as you've said - even the Disk Manager. So that's what happens on a cold boot.

If I reboot my computer after the above scenario, my motherboard goes through it's posting and does it's several minute long hang when it tries to detect the "bad" HDD. After obviously failing, it once again continues as if nothing is wrong, boots Windows (I'm using Vista 32 btw), and doesn't allow me access to the drive.

Just as you've described, I've switched SATA ports, cables, jumpers, and even played around in the BIOS to no avail.

During one of my "briefly usable" startup sessions, I managed to launch Windows' Disk Manager. It displayed all 3 of my drives - c:\, d:\, and e:\. E:\ is the one I've been having trouble with. So fairly confident that if I erased the partition/tried to format the disk I'd be able to retrieve the data with various software online, I QUICKLY tried to do just that. I was able to erase the primary partition from the drive and I believe reinitialize it. Though once again the computer then locked up. As before It returned control to me only to have my now partitionless drive disappear again.

So I'd obviously REALLY rather not have to RMA this drive, because if I do that, I'm never getting any of my data back without paying up the wazoo for it. So if ANYONE has any suggestions for me/us we'd both appreciate it immensely.

~Void
Related resources
September 15, 2008 11:00:45 AM

try loading this hd drive on another computer and see if he can see everything..

on the seagate 750 GB and 500 GB they got a jumper to determine which speed should it work.
try lowering it to 1.5 Gb per sec and see the result .
maybe your mobo isn't good enough for the hdd to run on 3.0 Gb per sec.

any help you can mail me .

Noam
September 16, 2008 5:13:35 AM

My motherboard works fine for running SATA II @ 3.0gb/sec as I have two other drives doing just that. Also the 750 that just went bad has been running without error since December. I went ahead and took your advice however and threw a jumper on there limiting it to 1.5gb/sec, the results were somewhat as I suspected. I was able to access the drive for about TWICE as long as I was able to before. I did a quick format on it through the Disk Manager, and assigned a drive letter to it (E:\). I then tried to use my data recovery software (FreeUndelete v2.1). The minute it tried to access the HDD it did the same thing described above - freezing for several minutes, then returning control to me and disappearing.

I'd love to try sticking the drive in another computer, only problem is that the other computer I have is ANCIENT and am actually surprised it's still up and running. So without another computer with SATA ports to try using, any other recommendations for me to try? If it comes down to RMAing it, any tips to make the process go smoother?

Thanks for the timely response and helpful feedback, I appreciate it.

~Void
September 16, 2008 6:30:23 AM

im sorry ,
I think it might be 2 things,
or that you have somewhat electricity problem.. (maybe the psu on the HD itself gone wrong or something)
or the motor is not fine.

both ways its RMA..
I'm sorry pal..

by the way .. I done that only yesterday at my work..
some of my clients has your problem , and I tried to place the HD on another PC and it run smooth (yet).. if it still will create errors than I think I will RMA either.

sorry ..

Noam
September 18, 2008 9:42:57 AM

Yup... RMA is on it's way. Thanks for the help though, it's much appreciated.

~Void
!