Sign in with
Sign up | Sign in
Your question

Harddrive suddenly uninitialized... now not working

Last response: in Storage
Share
September 9, 2008 4:11:18 PM

Hey guys,
I'm having a dilemma with a 200GB WD drive which has some university files i really want to ironically -_- backup, its not to old but i guess it has been well used. I recently got a ide to sata converter so i could use the drive in a computer with no more available IDE ports. It worked for a while then one day i turned the computer on and the drive was not showing up at all, only in the control panel -> admin tools -> comp management -> storage -> disk management. It was showing up as a uninitialized drive and so i tried to initialize it but it wouldn't work.

Then i unhooked another hard drive and used its cable to connect this drive via IDE, there i was able to initialize it which made no difference i still can't access it to get my uni files. I'm thinking the initialize may have been a bad idea as i heard its kind of like a quick format :S Anyway my question is where do i go from here in attempts to get the drive working period and then how do i go about trying to recover my files.

Any help is GREATLY appreciated, these files unfortunately mean more to me now then they did a few years ago. I guess its my own fault for not backing up but I've learnt my lesson lol.
September 10, 2008 7:35:38 PM

Keep it connected to the IDE port. Download and run the demo of GetDataBack for NTFS. Let is scan the drive and see if it finds your files.

If it does, you can pay at that point to recover the files. ($79).
September 11, 2008 2:23:53 PM

thanks worked brilliantly :) 
Related resources
!