Sign in with
Sign up | Sign in
Your question

HELP! Xinput1_3.dll error message!

Last response: in Windows 7
Share
August 22, 2011 6:30:24 AM

First off, some of my system specs;

Windows 7 Home Premium 64 bit
AMD Phenom II X4 955 3.2 Ghz
Ati Radeon HD 6570 1GB Dedicated video memory
8GB DDR3 RAM

Okay, so, yesterday I bought Fallout: New Vegas off of Steam. It doesn't run for some reason, and so one of my attempted solutions was to run it straight from the .exe file. So I did, and when I do that, I get "C:\Windows\system32\XINPUT1_3.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support." I know that xinput1_3.dll is a DirectX file, and I had already downloaded and updated my DirectX several times as an attempt to fix this problem, so I located the file in my system32 folder, moved it, and downloaded DirectX again (I did it using an older version, a newer version, and the redistributible version that comes with the game), and it replaces the file each time, but I still get the error message. So I figured that this is the reason the game won't run, and am looking for a way to fix this error. I have also already updated my video drivers, and my Windows is up to date. Any ideas? All help will be appreciated. Thanks in advance.
August 22, 2011 5:33:13 PM

das_stig said:
Download and install June 2010 DirectX 9c End User Runtime.

http://www.microsoft.com/download/en/details.aspx?id=81...


Thanks for the reply. Already tried that, and tried it again, but still no fix :( 

EDIT: After installing it didnt work, I thought i'd try extracting the xinput1_3.dll file to my system32 folder. Now when i run FallousNV.exe I get "FalloutNV.exe - Application Error The application was unable to start correctly (0x000007b). Click OK to close the application." and the game won't launch. Any ideas on how to go about fixing this, now?
m
0
l
Related resources
August 23, 2011 5:35:03 PM

Bump.
m
0
l
August 24, 2011 9:12:55 PM

Bump. I still need help :/  Any ideas would be appreciated.
m
0
l
August 25, 2011 6:11:08 PM

Bump.
m
0
l
February 14, 2012 4:48:13 PM

Okay so i had the exact same problem with my new Vegas. i have no idea how it happened. First of all i downloaded a program called dependency walker to find what my game relied on to run. after locating the xinput i deleted both from system32 folder and the sysWOW64. Then go through your steam folders and run the redist of direct x. Worked for me.
m
0
l
June 14, 2012 11:31:52 PM

That worked for me BigFatMcGove, although you only need to delete the sysWOW64 file.
m
0
l
!