Sign in with
Sign up | Sign in
Your question

Finding CHS values for 2.5" hard drives?

Last response: in Storage
Share
September 12, 2008 2:19:59 PM

I want to put notebook drives in a Cobalt Qube 3 so it can run fanless. I bought a Seagate Momentus 120GB drive (ST9120822A) but the Linux boot process said the drive wasn't recognized. I confirmed the drive was good by testing it on another computer. Tried another 2.5" drive (pulled from a Western Digital Passport chassis) and confrimed the 2.5-3.5 adapter works - Linux correctly sized the drive (60GB).

Found this PDF at Seagate's site (http://www.seagate.com/docs/pdf/datasheet/disc/ds_momentus_5400.pdf) that shows all the Momentus 5400.3 drives have logical CHS of 92049/16/63. I think this is outside the tolerance of the Cobalt's IDE controller and/or Linux loader kernal version. I need a drive with cylinders in the 30,000 range.

The datasheets I pulled for Western Digital Scorpio (http://www.wdc.com/en/library/portable/2879-701278.pdf) and Fujitsu drives (http://www.fujitsu.com/downloads/COMP/fcpa/hdd/mhw20xxat_datasheet.pdf) don't mention CHS values. The drives don't have to be 120GB, but those are the largest the controller appears to support (24-bit LBA).

Can anyone suggest where/how I can determine a drive's CHS before purchasing, especially since the manufacturer doesn't provide?

TIA,
Loyd
September 12, 2008 2:43:17 PM

google??????????..it's got to be out there somewhere....:) 
September 12, 2008 3:05:55 PM

Google wasn't helping me out last night when I looked. Tried again just now with WD1200BEVE chs and found this page: http://kernel.org/pub/linux/kernel/people/tj/crazy-unloads/acer-aspire-1690-hdparm which shows

ATA device, with non-removable media
Model Number: WDC WD1200BEVE-00WZT0
Serial Number: WD-WXEY07V39813
Firmware Revision: 01.01A01
Standards:
Supported: 8 7 6 5
Likely used: 8
Configuration:
Logical max current
cylinders 16383 16383
heads 16 16
sectors/track 63 63
--
CHS current addressable sectors: 16514064
LBA user addressable sectors: 234441648
LBA48 user addressable sectors: 234441648
device size with M = 1024*1024: 114473 MBytes
device size with M = 1000*1000: 120034 MBytes (120 GB)

So I'll RMA the Seagate for the WD Scorpio and see how it goes.
!