Sign in with
Sign up | Sign in
Your question

RAID 1 + 1 with Asus P5Q-E and XP pro

Last response: in Storage
Share
September 18, 2008 12:28:46 PM

Hi experts,

I was under the assumption, that "hardware" RAID 1 was possible with 2 of 3 drives using the onboard RAID controller on the P5Q cards.
But I am having great difficulties setting up RAID 1 on my new computer.

My system (relevant parts):
- 1x 150 GB VelociRaptor drive (SATA)
- 2x 1 TB Caviar Black Drives (SATA)
- 1x Asus P5Q-E Motherboard
- Win XP Pro with SP3 installed (on the 150 GB drive)

My Plan is to have the 150 GB drive as boot/system/C: drive, and the TB drives in RAID 1 as storage drives.

I have tried to change the setting in the BIOS for SATA drives to RAID instead of IDE. When I do that, I can access the BIOS RAID setup during bootup (using Ctrl+I), and set up the TB drives to RAID 1. However, when the setting in the BIOS is set to RAID the OS won't boot.
If I change it back to IDE, the system will boot just fine.

I have also tried to set the drives to RAID inside XP, but the "mirror" option is grayed out, and not available.

Am I missing some settings/drivers or something to be able to make "hardware" RAID 1 drives?
Are there any possible third party software that I can use for setting up my drives as RAID 1 inside windows?

In short, what can I do to set up my TB drives to RAID 1??

More about : raid asus p5q pro

September 18, 2008 1:02:20 PM

Did you set which drive is the boot drive in the bios under hard drive section and 2 did you load the raid software so XP can work with a raid setup?
September 18, 2008 1:34:40 PM

Nope, where can I do that??

where do I load the RAID software??

I have been trying the different options in the "Configure SATA as" option. The different options here are: IDE, RAID and AHCI. But the system cannot boot on other options than IDE.
Related resources
September 23, 2008 7:03:03 AM

in the openning dialogue you will see hit f6 to add scsi drivers and such, that's also for the raid drivers, but if your not using raid to boot then after starting os from the boot drive you can just install the raid drivers into windows. XP isn't like vista, you have to install the raid drivers so the os can see the raid chips.
October 26, 2008 3:30:10 PM

To tosa,

Please check that you have setup sata disks as raid in setup motherboard screen at the beginning (hit del when start). When restart hit Ctrl+I to start Raid manager software and select the best configuration for your raid 0,1,5 or 10. then your sata will be prepared to be used with windows.

Any problem contact me. I have it and it really works.

December 5, 2008 3:01:51 PM

To tosa,
I am a guest here so I don't know if I can reply. I am going to submit a short reply to see if I can reply at all.
1. Have you been successful yet as it is now Dec 5, 2008 as I write?
2. Your WinXP must be using the Intel driver (Iastor.sys) even though it will not participate in the RAID.
3. This is a simple matter if you want to reinstall your WINXP, but possibly more difficult if you don't.
4. I am running a different ASUS MOBO (P5E-VM HDMI) with Intel ICH9R controller and multiboot with Xp and Vista.
5. I was able to install Intel driver in both XP and Vista post OS install and convert to RAID 1. Although you also want to use RAID 1, I wanted to mirror my system disk, which is not quite what you want to do, but I am certain the technique I used will work for you. It involved registry changes in WINXP, but you may be able to avoid that because you don't want your system disk to participate in the RAID. Nevertheless, your system disk MUST be running the Intel driver, IASTOR.SYS.
December 12, 2008 4:13:59 PM

Hi all, I'm having the same problem as tosa, just about the same scenario ( 3 HD SATA, 1 Boot and S.O. and 2 more with Raid 0 ) , same XP, and cant figure how to put that to work, can you guys please help.
Thanks in advance ,
Jose Alves
December 23, 2008 5:48:58 AM

I am trying to establish a similar setup with an Asus P5Q Pro mobo; specifically, I am trying a raid 1 with two identical WD500 HDs while keeping my XP SP3 (32bit) install and program files on a separate single (non-raid) hard drive.

I have tried to setup raid 1 after installing xp and also with a clean install following the user manual which are similar to the suggestions above.
My problem occurs only when I select RAID via the bios, do the intel matrix setup, and try to boot xp... about half way through the splash-screen I get the blue-screen with a memory location error. Also, if I turn on RAID in the bios, ctrl+I intel matrix setup, and attempt to install windows with the appropriate raid drivers via floppy, I get the same screen right after the raid driver procedure when windows starts to install.

I may be forgetting to do something in the bios. I also read that my memory might be causing the problem, but if I have the RAID off in the bios I can boot just fine?

This is the first time I have attempted to raid my system; however, I have much computer experience and have used suggestions posted here at TH and around the web with no success.

I do not want my boot drive to be raid however it displays that way in the bios. Also, in the ctrl+I intel matrix storage manager it displays my raid drives as boot?

I am doing something dumb. Hopefully someone might be able to point it out... possibly it might help the OP and others too.
December 29, 2008 11:33:56 AM

To aka50:
What you are attempting will not work after OS install (without a lot of trickery and registry changes), but you should certainly be able to accomplish your objective with a clean install FROM CD, using the F6 method to install the Intel Raid driver (IASTOR.sys). I have done it. It is difficult to tell from what you have written what the precise order is that you have done things. Try setting the BIOS to RAID just before booting from the CD, but waiting until after OS install is complete to use CTRL-I to do the raid setup.
January 18, 2009 9:32:15 PM

UPDATE: RAID 1 Now Working!

For those of you looking for a POSSIBLE solution to this / my problem here is what I did:

I followed this article (after doing hours of research):

http://forums.hexus.net/hexus-hardware/112584-how-enabl...

Summary: (WARNING - this solutions contains changes to your registry which can result in you loosing all your data; read the article carefully and make sure your system is equivalent!)

I am using an ASUS P5Q Pro motherboard which I purchased in Fall 2008.
I have three hard drives: HD1 1TB, HD2 500GB, and HD3 500GB.
I wished to use HD1 1TB as my system drive while creating a RAID 1 (mirror) with my two 500GB drives.

I DID NOT copy my IaStor.sys file during the install of XP PRO sp3; thus, after switching my BIOS from IDE to RAID mode and attempting to boot, the boot would fail and go into an endless loop. (I could switch back to IDE mode and boot successfully, with obviously no RAID).

Following the Hexus article above, I copied the IaStor.sys file into my c:\windows\system32\drivers folder. I then created the .reg file (code in article) and doubled clicked it to run / make the registry changes.

Next, I restarted and switched from IDE mode to RAID mode in the BIOS. Exited the BIOS and quickly pushed CRTL+I when the RAID screen popped up. Created my RAID volume using HD2 and HD3. Exited the RAID setup and booted successfully from the OS. I installed the intel software, formatted the one RAID hard drive (HD2 and HD3) and began to save files to it.

GOOD LUCK to you!

-aka50
!