Sign in with
Sign up | Sign in
Your question

HDD Slave Disappeared from BIOS

Last response: in Storage
Share
September 18, 2008 2:58:28 PM

I installed a second internal 40G HDD about 2 years ago and made it the master and bootup drive and made the original 27G HDD the slave. No problems until a couple days ago when the HDD just disappeared. When I enter the setup program at startup to view the BIOS settings, the HDD is no longer an option. I'm at work right now and don't have the particulars on the models but the new HDD is a WD and the old one is a Seagate (Barracuda I think).

Is this what happens when an HDD dies?

How can I confirm the death or preferably perform a resurrection?

All help greatly appreciated.
September 18, 2008 3:26:39 PM

Sounds like a battery prob? You may have to manually edit the
hd specs in your bios to get them recognized. Secondary to that is
a conflict in boot drivers....go here and take a quick look:

http://www.fixingmycomputer.com/
September 18, 2008 3:29:44 PM

take the slave, make it master (while taking the master and setting aside for now). try booting from a disc like Bart P.E. and access the files...

http://www.nu2.nu/pebuilder/
Related resources
a c 342 G Storage
September 18, 2008 6:31:30 PM

Try this simple step first. It depends on the concept that, over time, connection points build up oxides and dirt and eventually ruin the connection. But if that's all it is, they can be cleaned simply.

Turn off all power, disconnect from the power cord, and open the case. Go to both the power supply cord and the data signal cord for the missing larger HDD. Carefully unplug each cable at the HDD, then plug back in again. Do this two or three times for each cable. Then repeat back where the other ends of the cables plug into motherboard connectors. Close up the case, reconnect power and reboot into BIOS.

See if the HDD had been rediscovered. If not, try the BIOS screen that auto-detects all connected drives and see if it can find it for you. Even if your BIOS somehow lost the specs on how to handle the drive, the auto-detect tool should be able to figure it out.

If this simple connector-cleaning procedure does not solve the problem, then start looking for other solutions.
September 19, 2008 4:52:56 PM

Thanks for the replies.

Things have gone from bad to worse. BTW, I wasn't clear in my original post, it was the primary slave HDD, the original 27G drive that disappeared. That's a moot point now.

I powered down, removed the signal cable from the "missing" slave HDD and from both the secondary master and slave drives (cd and floppy). I plugged the HDD in as the secondary master and powered back up. The drive was still not recognized. I powered down and removed the drive to look at it and saw no physical damage to it. I removed the primary master HDD (without removing the cables) in order to blow the dust out. Then I reinstalled and recabled everything, checking twice to make sure that it was cabled correctly and powered back up.

I then had no signal to my monitor. The machine gave its usual beep and four green lights to say everything is fine but no monitor signal. I replaced the video card (like for like NVIDIA TNT2) about 3 weeks ago because I was getting shadows and lines in the display. I tried reinstalling the old card, no display. I reinstalled the new card and got display again. But now my primary master bootup HDD is gone as well as the slave. The system is not recognizing any HDD so it hangs up after running the BIOS routine and says no OS found.

I tried removing and reseating the primary signal cable from the mobo, no difference. I tried booting up with the Dell Resources and Diagnostics CD in the CD drive and now I have no display again.


HELP!!!!!!!!!

Am I dealing with a mobo problem here? I'm too much of a novice to correctly diagnose that.

Will try the boot from another environment once I can get a copy of it. I'm now using a computer that can't write CD's. If I can get a display again I will try to manuall edit the HD descriptions although I didn't see a way to do that in the BIOS setup I have.
!