Sign in with
Sign up | Sign in
Your question

NFS: Pro Street Problem

Last response: in Systems
Share
December 3, 2007 11:44:47 PM

I just bought Need for Speed Pro Street for the pc. The problem I am having is framerates. I have to run the game at 800x600 in order to keep smooth framerates and the game looks like **** at that res. If I go higher res I start dropping frames like mad. I have:

AMD FX-55
1GB Dual channel RAM
1950 Pro

Solid cooling- my temps on the card are 45 and the proc is only 50. I have the newest drivers from AMD/ATI as well.
Any help on this would be awesome. Thanks everyone.

More about : nfs pro street problem

December 3, 2007 11:46:24 PM

Very easy solution... get more ram. Preferably 2x1 gigs. Keep lower timings. RAM gets sucked up in those kind of games.
December 3, 2007 11:49:53 PM

I was kind of thinking that. My page file jumps from 200mb to almost 900 when I start the game.
Related resources
December 4, 2007 12:40:54 AM

hughyhunter said:
Very easy solution... get more ram.


word
a b B Homebuilt system
December 4, 2007 12:59:22 AM

I am not sure if Ram is your problem. From what I am told EA has an issue with their Need for Speed Series on the PC. I was playing Need for Speed Most Wanted on a friend’s computer who has an x1950XT, with 2 Gigs of Ram, and a Pentium D 820 and the game was very JERKY. One second you are going at 200mph then the whole game freezes for a split second which throws your concentration off then BAM! You are right back to 200 mph in 0.0 seconds. Is that what is happening to you?

It is not even a gradual decline in frame rates. It is just a freeze frame about every 10 seconds I guess. I was told this is a software driver issue. I have another friend who has a GeForce 8800GTX and he reported the same issue.

Yes, I realize that Need for Speed Pro Street is like 2 or 3 generations ahead of Most Wanted but as I understand all EA racing games are like that and require a special driver or download. I know this post probably does not help much and what I am saying may not be even half accurate. I will have to check with my friend tomorrow at work and get back with you.

Besure to run windows update and make sure you are on Catalyst verison 7.11

Good luck.
December 4, 2007 1:40:20 AM

I run NFS: PS
Resolution 1680x1050 @ 60

Advanced: World: Cars:
65% Detail: High Detail: High
2x Lighting: On Effects: High
Tri Shadows: Medium Damage: High
V-Sync: Off FX: Medium Smoke: On

I've never ran a FPS counter but the game runs completly smooth with out issue for me. I can't remember what settings were default and which I changed if any.

E6600, 2GB DDR2-800, Ultimate X1950 Pro (590/1600). All stock at what they came at.

Other than the fact I don't like the game, I mean really, how am I supposed to stear while doing a wheelie? And having a Porsche GT2 all level 3 and not keeping up with an EVO and not being able to control a 750,000 car. /end rant/ it runs great.
December 4, 2007 3:09:36 AM

The game doesn't run well on single core CPU's. I am also having problems running the game smoothly.Tested it on my girlfriends pc with a E6300 (stock) and a Radeon X1900GT. No problems! This game utilises almost 100% of the CPU on a dual core system.
a b B Homebuilt system
December 4, 2007 11:20:11 AM

Quote:
Other than the fact I don't like the game, I mean really, how am I supposed to stear while doing a wheelie? And having a Porsche GT2 all level 3 and not keeping up with an EVO and not being able to control a 750,000 car. /end rant/ it runs great.
Does the game really that bad? I would kind of like to get it but then again I am interested in Burn Out Paradise. I think that game is going to be available on the PC.
December 4, 2007 1:47:25 PM

NFS PS is pretty bad I would say. Like rook said the GT2 level 3 cant keep up with a POS EVO.... I wish they take the series back to the original games style not this underground garbage.
December 4, 2007 2:02:48 PM

I have the game and it is like that. I run it at 1280/1024 at high settings with my 1900xtx overclocked and the rest of my system is bad a$$ as well and I still get studders. That is the coders fault that did the game. I can see the tires on the cars jumping around at the beginning of races and the text whil loading tracks jumps around etc etc etc. The EA people are good at putting out halph finished games and leaving them that way and never doing updates.
December 4, 2007 2:03:18 PM

What I don't like about NFS PS is that they downgraded the game- the free roam is gone. I really liked that mode, especially in NFS Most Wanted.
December 4, 2007 2:32:34 PM

My system plays the demo flawless @ 1280by1024. I have a 3870 but the one complaint I have about the demo is the steering. Using my xbox 360 controller, one little twitch and I am out of control.
December 4, 2007 2:37:01 PM

cappster said:
My system plays the demo flawless @ 1280by1024. I have a 3870 but the one complaint I have about the demo is the steering. Using my xbox 360 controller, one little twitch and I am out of control.

What is the rest of your system spec?
December 4, 2007 2:53:11 PM

NFS on the PC has usually been a failure. I got NFS Carbon and it still has a mem leak that will crash the game out randomly. They had like 3? patches for the PC and not a single one addressed that issue, and to my knowledge it still has not been fixed. Long story short - NFS + PC = fail.
December 4, 2007 3:05:44 PM

I was able to run all the NFS games on my computer exept PS. I have 1.5GB DDR RAM, AMD 64X2 @ 2.0GHz, GeForce 6600OC 512MB DDR2 VRAM manual overclocked to 527MHz core and 637Mhz Memory. The demo runs very choppy so I uninstalled it.
December 4, 2007 3:19:16 PM

That's exactly what EA does now... They have great franchises and IMO the only goal as of late is to run them in the ground.

I've bought every iteration since the first hot pursuit, and from the time they did Porsche challenge, it's all downhill from there. When they introduced the free roam, I too was excited about it, but now PS is a mere 1% of what this franchise once was.

It runs great @ 1650x1080 with everything maxed except for AA @ 2x.
December 4, 2007 3:21:34 PM

Can you guys see why the demo runs chopy on my system specs above? I would say it's the video card but still I can run games like bf2 & 2142 on high and cant run this on dirt low settings...
December 4, 2007 3:22:23 PM

jayjay said:
I was able to run all the NFS games on my computer exept PS. I have 1.5GB DDR RAM, AMD 64X2 @ 2.0GHz, GeForce 6600OC 512MB DDR2 VRAM manual overclocked to 527MHz core and 637Mhz Memory. The demo runs very choppy so I uninstalled it.

Your PC should run it fine if you upgrade your graphics card.
December 4, 2007 3:27:55 PM

Quote:
Your PC should run it fine if you upgrade your graphics card.


Agreed. The 6600 is the problem.
December 4, 2007 3:31:31 PM

What if I increase the voltage to overclock it even more would that do any thing? I payed 240 for this card and had it for alittle over a year. I guess I really wasted my money...

Edit actually now that I think of it. It might have been longer then that, I bought it shortly after vista's release.
December 4, 2007 3:43:04 PM

Quote:
What if I increase the voltage to overclock it even more would that do any thing? I payed 240 for this card and had it for alittle over a year. I guess I really wasted my money...
:o  I payed less than that for 7900GS which I bought a while back. Maybe a year or so ago.
December 4, 2007 3:56:23 PM

I had a feeling I was ripped off... I really wanted a new GPU at the time because I only had a integrated ATI X200. So I went to bestbuy not knowing any thing about GPUs and I guess they suckered me into buying it.. I thought it was a good deal though PCI-E, 512MB DDR2, shader model 3.0 support (that's all I really knew about GPUs). The real seller was the badge on the front that said "Built for Microsoft Windows Vista and XP" because I was going to upgrade to vista shortly after.

also note that mine is the 6600 OC model, not just the base 6600. Oh I just remember too I remember seeing higher series cards there like the 7300 but the guy said the 6600OC is faster and judging by the price was higher I thought he was right.

here's what I have http://www.bfgstore.com/ProductDetails.asp?ProductCode=... it's only 80 now :( 
December 4, 2007 4:03:14 PM

cfvh600 said:
What is the rest of your system spec?


radeon 3870, e6400@2.9, 2gb ddr2 800, MSI P965 Platinum, antec truepower 550 watt psu

I am able to run all settings maxed out at 1280by1024. Its just the gameplay that sucks for me.
December 4, 2007 4:18:44 PM

Probably just poor coding. Kinda like the Battlefield Series. (I loved 1942 and even 2) Even when you're getting high FPS, other things still make the game feel slow, at least that's what I notice.
December 4, 2007 4:47:29 PM

Runs perfectly smooth for me, no jitters or anything...

About the steering while doing a wheelie, you aren't supposed to :p  You'll need to tune your car so it goes straight no matter where the front wheels are. And tuning the suspensions and stuff is really important in that game, if you just buy the uppgraded parts in your car and expect it to run perfectly (like in previous games) you'll be in a world of pain. The EVO is damn slippery to drive at stock settings after the uppgrades but after some painstaking tuning it goes like mad around the corners :p  ...and my drag/wheelie car goes straight with the front wheels in the air allmost entire 1/4mile while my drift car goes faster sideways than straight ahead.. lol

Havent yet bought the Zonda though...
December 4, 2007 4:58:46 PM

I have ,,
GA-P35-DQ6
Crucial Ballistix 1gb sticks x2 DDR2 1066 @ 1180~ 5,4,4,4,5 2.25v
E4400 @ 9X355=3.2Ghz~
ASUS EAX1900XTX @ 702/837 1.5V Flashed
2 Western Digital 160GB 16mb Cache Raid0 Drives
Vista 32bit
I can run it fine but, the game has alot of glitches in it.....
I can run it on my HD T.V. @ 16XX/XXXX @ High settings and it plays the same as 1280/1074 @ High settings
It is smooth for me just glitches every where in the code.
December 5, 2007 7:13:25 AM

These are my settings for NFS PS:
Resolution 1680x1050 @ 60 on 22 inch Samsung 226BW Monitor

Advanced: World: Cars:
Brightness 65% Detail: High Detail: High
AA 8x Lighting: On Effects: High
Anisotrophic Shadows: High Damage: High
V-Sync: On FX: High Smoke: On

The game runs smooth as silk. Played for hours without freeze, crash, glitches, etc. Fraps is showing 25 FPS during gameplay. I bought the Logitech MoMo Racing Force Feedback Wheel to play this game. It feels like im driving a real car. Graphics is awesome. Gameplay is awesome.

Sure the game doesn't have free roam, police chases, story line and so on. But the races are still exciting. Sorry that a lot of you don't like the game. But i love this game. Yes i have played NFS MW and NFS Carbon.

Here are my system specs:

Antec 900 Case ( 2 120mm front intake fans, 1 120mm side panel intake fan, 1 120mm rear exhaust fan, 1 200mm top exhaust fan, 1 110mm CPU heatsink fan)
Thermaltake 750W PS
Abit IP35 Pro MotherBoard
Q6600 @ 2.4 Ghz OC'ed (356X9) to 3.2 Ghz
1GBx2 OCZ DDR2 800, 1GBx2 Corsair DDR2 800 @ 717 ~ 4,4,4,15 2.1V
2 150G Raptors, 2 500G Maxtors
BFG GeForce 8600 GTS OC
Dual boot XP 32-bit, Vista 64-bit
December 5, 2007 9:45:29 AM

yeah I would like to shed some light regarding your problem.....I have read all the stuffs posted and I think you might need to increase your RAM(not really required) but I think you might have to Defrag your Hard drive. I am playing this game too but I really dont have much of a problem though. I use a core 2 Duo 2.13 and 2 gigs of Ram and 7900GS. I am playing it on 1152 REs and everything is on the higest possible graphics option I dont get a stutter at all. The only problem i have is before the race starts the intro video the shadow on the car looks very jaggedy. Wonder if it is a driver problem...though using latest drivers. Honestly the game suckx and the world details sucks and the only good thing may be the car details is good but the graphics on NFS Most wanted was way better....

1.may be increase in RAM
2.Defrag harddrive
December 6, 2007 11:30:48 PM

Thank you so much for all the input. I am in the process of defraging my hard drive right now. When its done I'll try it out. It sounds to me that more RAM is also needed. I have 2X512 right now. Would you suggest getting another 2X512 to make 2gb total, or get 2x1gb instead. I am looking at not spending a fortune here because I just totaled my car the other night, and I am looking for new transportation. Better yet if anyone has some RAM that they are wanting to get rid of let me know. I need DDR400.
a b B Homebuilt system
December 6, 2007 11:46:10 PM

andyzzdae38 said:
Thank you so much for all the input. I am in the process of defraging my hard drive right now. When its done I'll try it out. It sounds to me that more RAM is also needed. I have 2X512 right now. Would you suggest getting another 2X512 to make 2gb total, or get 2x1gb instead. I am looking at not spending a fortune here because I just totaled my car the other night, and I am looking for new transportation. Better yet if anyone has some RAM that they are wanting to get rid of let me know. I need DDR400.
You totaled your car? I guess since you couldn't play Need 4 Speed ProStreet at decent frame rates you got bored and decided to try the real thing.
December 7, 2007 10:23:30 PM

Yeah that whole "Take it off the streets" thing didn't work for me. They better come up with something better next time :D 
a b B Homebuilt system
December 7, 2007 10:53:22 PM

LOL!

Sorry for your situation. That sucks big-time. I hate car accidents. Got to pay a fortune to restore it to its original condition. You can let your insurance handle it but then your rates shoot up.

My condolences.
December 8, 2007 9:57:35 PM

Thanks RWayne, but I found out today it's not totaled. The insurance company is getting quotes to repair it.

Anywho, I tried NFS PS after defragging, and it seems worse, especially in the cut scenes. The gameplay is dropping frames and driving me nuts. Do you think more RAM will fix it? If not any other ideas.
December 8, 2007 11:03:21 PM

i think u should go for more ram and maybe a better proc, the video card is ok... Two days ago i upgrade mobo+pro+ram and the problem was solved..i had a skt 939 athlon 3200+ and 1Gb dual chanell 400 and an radeon 2600xt and i was having problems with every resolution...form 640*480 to 1280 at low or medium i would get hickups but it wasnt related to the video card...i was gettin good frames but every 10-15 sec the whole game would freeze for a couple of seconds. Now i have 2 Gb ddr2 dual chanell and a x2 5600+ and on high i have no problems on 1024 and 1280 (if i go higher the video i get video bottlenek - slow framerates but no freezing)
i also think that the game likes dual cores a lot....which is weird 'cause it's no rts game with AI or lots of units and huge maps
defrag wont work cause the hdd is the slowest part of your pc and if the comp cant get all the data needed into your ram it will acces the hdd and slow/freeze the game
ps sorry for my bad english
December 11, 2007 12:33:27 AM

Same problem here , the game freezes every 5 to 10 seconds
for a split second whatever res or quality settings.
From 1280x1024 full detail to 800x600 everything in low detail the game just stutters and I don`t think RAM is the issue.
Every post reporting a problem was from a single core PC , such as mine.
Not the GPU either because Mechstan posted that it runs smooth on a 8600GTS , LOL .

AMD FX-55
2x1GB RAM (OCZ EL Platinum PC3200 2GB Kit)
XFX 7900GTX 512MB GPU
MSI K8N SLI Diamond Board
Enermax 600W PSU
Win XP Pro (fully updated)
December 11, 2007 1:10:37 AM

Well, let just say my video card is outdated, I have aa ATI 9600 Pro 256 Mb VC, I am running a Pentium D 820 (2.8Ghz), 1 Gb Crucial Ram @ 3-3-3-8 timing. The game runs smooth at 1280*1024 at medium to high settings with no lag, slow downs or anything. The only issue that came up was heat, after playing for 15 minutes my PC will reboot and my TEMP monitor indicate "System overheat". Replacing CPU fan with Zalman fan and opening the side of my case solved the issue! Still using Catalyst 6.14 drivers.
December 11, 2007 6:52:02 AM

rattman169 said:
Well, let just say my video card is outdated, I have aa ATI 9600 Pro 256 Mb VC, I am running a Pentium D 820 (2.8Ghz), 1 Gb Crucial Ram @ 3-3-3-8 timing. The game runs smooth at 1280*1024 at medium to high settings with no lag, slow downs or anything. The only issue that came up was heat, after playing for 15 minutes my PC will reboot and my TEMP monitor indicate "System overheat". Replacing CPU fan with Zalman fan and opening the side of my case solved the issue! Still using Catalyst 6.14 drivers.

It will run smoothly because you've got a dual core CPU. That's the problem with NFS Pro Street. It doesn't like single core CPU's at all. On a dual core you get almost 100% CPU usage when running the game.
December 11, 2007 12:06:45 PM

If you ask me that is a coding issue that hey need to fix. Which they will probably never do knowing them and there **** support. I hate there support. I like valve when they need to update something they do it right.
!