Sign in with
Sign up | Sign in
Your question
Closed

How to make Google my default Search Engine

Last response: in Applications
Share
February 6, 2013 5:02:15 PM

Hi, I have Win7 64bit on my laptop and I have been using Firefox for years. Google has always been my search engine.
I'm not sure what or when it happened but suddenly I can't get Google to stay as my search engine.
Have read through many posts about this subject but all of the suggestions don't work for me.
Firefox (which I really like but not as a search engine) comes up when I go online. Have read that to keep selecting Google would help Firefox to remember but not in my case....
Also, in Control Panel - Internet Options- Homepage, Google.com shows and is highlighted but "use current" is for some reason greyed out. I don't know what else to do....
Thanks in advance for any suggestions you might have.
February 6, 2013 10:29:43 PM

"Control Panel - Internet Options- Homepage, Google.com shows and is highlighted but "use current" is for some reason greyed out"

That settings applet applies to Internet Explorer only, not Firefox or any other web browser.
If you open Internet Explorer, then go Tools > Internet Options, you will see that
"Use current" is not greyed out (or at least it should not be).

I was a Firefox user until six months ago, only because I was waiting for Google Chrome to mature into
a fully-featured browser with all the features I needed. I now use Google Chrome all the time, and Firefox is gone:
https://www.google.com/intl/en/chrome/browser/
Score
0
February 7, 2013 4:53:40 AM

anken said:
Firefox (which I really like but not as a search engine) comes up when I go online.


That is Google, it just has the FF logo on the page.
Score
0
Related resources
February 8, 2013 8:52:17 PM

Thank you both for writing.
I have downloaded Google Chrome and made it my default browser. It's very nice but....
at this point I can't get Yahoo Toolbar which is very important to me. Yahoo Mail is also my primary email provider.
So, I reinstalled Firefox and got my toolbar back. Hopefully Google Chrome will be compatible with Yahoo in the future.

Well, so far I will have two browsers to choose from. I know that IE is still there also but I have always preferred Firefox because of the frequent security updates.
Again, thanks for writing!
Score
0

Best solution

February 8, 2013 10:52:46 PM

Open Firefox. Go to the tools menu-->options-->set the homepage to www.google.com as shown in the picture.

Share
February 9, 2013 8:31:46 PM

Whow!
It worked great! Thank you so much, aford10!!
Score
0
February 9, 2013 8:43:52 PM

You're welcome
Score
0
February 15, 2013 5:01:20 PM

Best answer selected by anken.
Score
0
April 18, 2013 4:09:54 PM

That is just to set the home page to Google lol... THE TRUE FIX is THIS!

THIS IS the True MAIN DEFAULT SEARCH PROVIDER FIX for FireFox Navigation:

Type this into search bar on top of the screen: about:config

Confirm to get to the page - (Remember DO NOT CHANGE ANY OTHER VALUES on This PAGE PLEASE!)

There will be another search bar on that page, Type in: keyword.url

Double Click that (it will show as Ask, or Bing, or whatever the search engine is set on)...

You will see a pop up menu stating value... (this is for Google Default Search Engine BTW): Type in: http://www.google.com/search?q=

Confirm... and there is your Google Default Engine until next FireFox update!

The little search on the top right hand side CAN be set to Google BUT you will need to search ONLY in that area... This is for the actual Main Navigation Bar for FireFox!

Hope this helps you all!

Namaste!
Score
0
June 5, 2013 8:29:56 AM

To make google your homepage in Firefox is not hard (link:http://a-zblogger.com/make-google-my-homepage/).If you've tried everything then go to "Help" tab>>"Troubleshooting Information" and then click "Reset firefox" and then follow the tutorial in the link i posted above.If this does not work, just reinstall firefox, and follow my tutorial.
Note: Make sure to export your bookmarks first.
Score
0
June 5, 2013 4:43:55 PM

This is already solved guys.
Score
0
!