Sign in with
Sign up | Sign in
Your question

Sapphire ATI Radeon HD 2600Pro

Last response: in Graphics & Displays
Share
December 15, 2007 4:00:39 AM

Motherboard: Matsonic MS8147C
CPU:AMD Athlon XP 2600
RAM (tell us the number of sticks and if you´re using different brands): Generic 1GB 3 sticks same brand
Video Card: Sapphire ATI Radeon HD 2600PRO -AGP : 8x 128MB Apeture (never said I was good at spelling)
0
PSU (Yes, in fourth place.) Detailed specs of the three main rails are a MUST! (...or at least the Brand & Model):Cheifmax 550w 12v-30A
Monitor (connection used):Cornerstone Color 21/75 fp
Hard drives: Maxtor 250GB : Seagate 200GB
Optical Drives:none
Additional PCI cards: Cmedia Sound Card 5.1
Number of fans present: 6 total - 2 in use

Video Card Drivers in Use (Control Panel or Catalyst Control Center?): From sapphiretech site
ATI RADEON™ HD 2400Pro/2600Pro/2600XT(AGP Only!) Windows XP(32/64-bit)(multilanguage)
XP_8.42-070914a-053413E-ATI

Motherboard Drivers Used:Matsonic Driver CD V5.8

Sorry if this has been, as I have been searching reading and following other tips and have not been able to fix my problems.

Here we go:

I just got this card today, before I bought I was reading and did see that the drivers that came with the disk did not work so I went and pre-downloaded the drivers. The driver I mentioned above is the only one I can get to work, so I am hoping that is all the drivers in one. After I installed that I tried to update the drivers on the drivers page with the ones that were newer than the
ATI RADEON™ HD 2400Pro/2600Pro/2600XT(AGP Only!) Windows XP(32/64-bit)(multilanguage)
XP_8.42-070914a-053413E-ATI
but I had no luck as I always got the
Notify >> (something )!=3 or something like that >> Failed to install (0xton of numbers and letters)

So ok, I figured it was ok, and thats where my driver situation is stuck.

Now I try to play the games that made me buy this card, COD4, NFS-PS. No Luck.

COD4 will flick the start screen for about 1/2 a second then nothing. NFS-PS will start to load then flicker the screen a ton of times, like it is trying to refresh.

I figured I would try to play some of my old games that I know work. NFS-C, NFS-MW, Tony Hawk Pro-Skater2 (old game I know), these wont even load either.

The card I just got done replacing was a Nvidia GeForce 5500FX 256MB. everything worked fine before the swap. The last ATI card I used was the Radeon 3200 32mb back in like 2002, So coming back to an ATI card was like a home coming for me.

Another problem I am having is when in the analog connector, I do not get the bios screen, if I want to see the bios screen I have to hook up my tv to the card or use the HDMI - Analog adaptor and run from the HDMI slot. Which I might just have to go back to doing, but I do not like to use adaptors, because of the signal loss.

If anyone could help me fix these problems or atleast give me some ideas I would greatly appreciate it.


Thank You
December 15, 2007 5:29:13 AM

If you do some searching around you can probably find a link to a driver cleaner. Could be that you need to clean out the old drivers and reinstall your new drivers, especially since you are coming from an nvidia card. Either that, or maybe a windows reinstall.
December 15, 2007 8:26:56 AM

Ahhhhh, Matsonic! I've owned one Matsonic board before! Got it as a bundle from Fry's with a P4 Northwood. Nothing I could ever do to get that thing running stably. Good luck, but if things haven't changed, then Matsonic will always be late with driver updates, and even then, many of those updates will introduce new problems rather than solve problems. In my experience, ECS > Matsonic. Harsh words, but I can't say enough about my bad experiences with Matsonic.
Related resources
!