Sign in with
Sign up | Sign in
Your question

My new hard drive won't boot up!

Last response: in Storage
Share
October 10, 2008 4:25:38 PM

Hello Everyone,

Background:I recently upgraded to a larger hard drive (500GB) had to get a controller card since my mobo didn’t recognize it. Started out with a 50GB with 120GB slave. Did a Norton Ghost over of everything.

Problem:
When I try to boot to just the new hard drive now I get a log-on window loop (Put in the password and flips me back to the same log-on window). When I put the old master as the slave it boots o.k. but I think it’s booting to the old hard drive even though I have them set to cable select and have the new one (500GB) as the boot up hard drive.
When I tried to go back to the original configuration (old 50GB with the 120GB as slave) I now get error message “Disk boot failure, insert system disk & press enter” which I do but after inserting the Window XP disk the curser just blinks at me. No response. Any ideas??

Specs: Windows XP Home Edition
Hard drives connected to IDE #1 on hard drive controller
BIOS Boot sequence: CD Drive/Hard drive 0/Hard drive 1/other device

More about : hard drive boot

October 11, 2008 2:01:37 AM

A logon/logoff loop occurs after a disk clone under the following conditions:

- You cloned a bootable Windows partition from one physical disk to another
- The cloning program copied the partition only, and did not copy the MBR
- This Windows installation has seen the new drive before the clone, the disk was initialized, and a partition was created on it.

When Windows sees a drive and initializes it, Windows writes a serial number to 4 bytes in the MBR (sector 0) of the disk. Any partition you create on this disk is then associated with the serial number and the drive letter that the partition is given.

When you then proceed to clone a boot partition to the new drive with a cloning program that doesn't copy the MBR, the old disk's serial number is not copied to the new disk, so the new disk retains its serial number that Windows has seen before.

When Windows boots up on the new drive, it sees the serial number of the new drive and assumes the partition that's on it now belongs on the previously selected drive letter, which almost always is not C:. Since the Windows installation boots from C:, there is now no C: drive when Windows boots up. Attempting to log on makes Windows try to load the user's registry from C:\Documents and Settings\<username>, and the C: drive isn't there, so Windows just aborts the logon attempt and logs back off.

To fix this, you have 2 choices:

Option 1. Re-clone the original drive to the new drive using a cloning program that supports copying the MBR. Acronis True Image is one that will copy the MBR.

Option 2. Erase the serial number from the new drive. Windows will re-issue a new serial number to the drive on the next bootup, and will then let you log on.

To erase the serial number from the new drive, do the following:

1. Disconnect all hard drives in the computer except the new drive.

2. Download the PhystechSoft Disk Editor, which is a .zip file.

3. Unzip the file, run the makeboot.bat file in the unzipped folder. This will make a bootable floppy disk.

4. Start up your system on the floppy, this will run the PTS disk editor.

:o  Please note that a Disk Editor is an extremely dangerous program. You can easily ruin the clone you made with this thing. Don't change any bytes except the ones I'm about to tell you to.

A review/short documentation of the PTS Disk Editor is available here. You will be running it in real DOS mode, scroll down on that page to see the real DOS mode screenshots and (brief) instructions.

5. You will want to open the physical device (not the partition), and be looking at absolute sector 0 (cylinder 0, head 0, sector 0).

6. Scroll to hex address 01B8 using the 4 arrow keys. This byte is on the row 01B0, and the column 8. Note: The columns are numbered from 0-F, in hex. Thus, column 8 is the 9th column on the screen (there are 8 columns before it, columns 0-7, and 7 columns after it, columns 9, A, B, C, D, E, and F).

Address 01B8 is the first byte of the disk serial number. The disk serial number is 4 bytes, at address 01B8, 01B9, 01BA, and 01BB.

7. Look again and make SURE you're on absolute sector 0 (cylinder 0, head 0, sector 0).

8. Zero out those 4 bytes by typing 00 00 00 00.

9. Hit Ctrl-W to write the changes to the disk.

10. Exit the disk editor (Alt-X), and reboot the computer.

Everything should now work fine.
October 11, 2008 8:28:02 PM

<Edit>: Offending message in the thread was deleted by moderators. I deleted my response as well.
Related resources
October 12, 2008 8:44:56 PM

Thanks for the answer SomeJoe. I ended up getting Partition Magic and copying over everything again. Now it works fine. I re-installed my old (Not the original C bootable) back-up drive 120 slave and that works fine also. The only problem now is that the slave is the "D" drive which used to be the CD Drive and now my PC won't recognize my CD Drive! Any ideas? I see it in device manager under "Unknown devices"
October 13, 2008 12:13:35 AM

Verify your IDE jumper configuration. IDE devices should follow these rules:

1. Use only 80-conductor cables. They are readily identifiable because they have 3 connectors that are colored blue, black, and gray. On 40-conductor cables, usually all 3 connectors are black -- don't use these.

2. Make sure the IDE cable is 18" long maximum. Some manufacturers make 24" cables -- they will not work properly and are out of spec.

3. Blue connector goes to the motherboard, devices go on the black and gray connectors.

4. You can either set both devices on the cable to cable select (CS) setting via the jumper (if you do this, the device on the black connector will become the master, the gray connector device will become the slave). OR, you can manually make one device the master and the other device the slave via the jumpers on both devices. Do NOT make one device master or slave and the other device cable select -- it will not work.

It is generally recommended that you put both hard drives on one cable, with their jumpers set to cable select. Then put your CD-ROM by itself on a different cable (i.e. different IDE channel) on the master (black) connector, with the jumper set as cable select, or if that gives you problems set the jumper to master.

Once you've verified your hardware configuration, you should be able to see all devices in device manager. You may also need to go into disk manager and change drive letters for the 2 hard drives and the CD-ROM. Sometimes changing the drive configuration like you've done can leave some devices without a drive letter assigned.
October 14, 2008 10:49:33 PM

Thanks. I have the 80-conductor cables. The hard drives are both set to CS and I have them connected to a hard drive controller card (Since my hard drive did not detect my new larger 500GB drive and I didn't want to flash my mobo). My CD Drive is connected to another controller card. It just was built that way. I'll try the drive letter change and see if that works.
October 16, 2008 3:58:10 PM

Thanks SomeJoe, Actually I just deleted the CD Drive in Device Manager (Unknown Devices) and when I re-booted it re-assigned it to another letter and I'm all good. thanks for the help though.
June 6, 2009 1:14:13 PM

@ SomeJoe7777: Thank you for this information - I resolved almost identical problem thanks to you! In the beginning I used Acronis True Image (from Hirens boot CD) and I came up to that loop. After I realized that the “Windows installation has seen the new drive before the clone, the disk was initialized, and a partition was created on it.” I recreated the partitions under Partition Magic (in the same boot CD). After a second run with Acronis the result was the same. So I turned to Norton Ghost partition to partition creation and actually that worked. I’ve never had problems before with Acronis (I’m using it a lot).
Once again, Thank You for the information!
:bounce: 
!