Sign in with
Sign up | Sign in
Your question

Raid5 failure - can't rebuild - need help!

Last response: in Storage
Share
October 14, 2008 2:56:56 AM

After some scary issues with hard drive failures in the past I decided to fork over the cash and try something safer. So, I put together a RAID5 array of 750GB discs - three HDDs total.

I am using the "Venus T5" SATA external enclosure which came packaged with the Sil3132 SATA controller.

The setup went fairly easy and I was rolling within minutes. This was close to a year ago.

Well, I have now learned that a RAID5 array may not necessarily be much safer than non-RAID drive backup because something has happened to my array and I can't access anything.

Nothing out of the ordinary triggered the event. I was uncompressing a large file, which was on the RAID array. During this process, Windows Explorer froze, but the uncompressing of the file continued. I waited until the file was completely uncompressed and then I restarted the computer.

When the computer was back online the array was not being seen by Windows XP Professional anymore (never had an issue for close to a year).

Hoping that I could just pop in a new HDD for an easy fix (rebuild) I went out and purchased a 1TB drive and popped it in.

I still do not have any options to rebuild.

Here are some screenshots to show what my array manager indicates.

The first screenshot shows four drives (1, 2, and 4 are the original drives belonging to the array - 3 is the new 1TB drive), and the event log. As you can see, the drives are discovered (Member 0 and Member 2 of Group 0 "Kahuna"), but the array goes offline.

The second screenshot shows when I select the array in the left column. You can see the two HDDs are selected in the right column. I don't have the option to "rebuild".

Any help would be very much appreciated. Thinking a RAID5 array would be relatively safe, I have plenty of files that I would really like to have back.

Thanks!!





More about : raid5 failure rebuild

October 14, 2008 12:54:29 PM

Some more information -

I have tried removing both drives from the external enclosure and connected them directly to the motherboard, so the drives are not connected to the enclosure or RAID controller.

The problem is that neither of the drive are even detected by my bios and then, of course, not detected by Windows.

So, I can't use any software like GetDataBack or RAID Reconstructor.

Right now I am completely stuck and have no idea where to go from here.

Any suggestions? I appreciate any help or ideas.

Thanks!
a b G Storage
October 14, 2008 1:16:03 PM

I don't have hand's-on experience with RAID, but don't you have to use same size disks? Adding a 1TB disc to an array of 750GBs might not work on all controllers (on others it might just use the first 750GB, I don't know).
Related resources
October 14, 2008 1:30:07 PM

Zenthar - thanks for the help.

However, with RAID 5 you can use any size drives, but when the array is put together it rounds down to the smallest drive. So, 250GB of the 1TB drive would not be used. I tried to find a 750GB in town last night but couldn't find any.
October 14, 2008 1:36:18 PM

Heya,

Just as a quick way to test something, I would suggest you download Ubuntu (or any other free OS that has native RAID support) and throw in the LiveCD and boot up with it. It will not install nor write to your drives and literally just load from the CD so that you can test drive the OS (fully active no less). Use it to see if it can access your disks, see if it detects the RAID, etc. A free way to check your disks out and see if Windows is the culprit here. Because really, unless all three drives are literally just corrupt or something, sounds like Windows is just being.... Windows.

Cheers,
a b G Storage
October 14, 2008 1:44:18 PM

Does the enclosure come with a "rebuild" how-to?

The fact that Windows doesn't see the drive is one thing, but the array being offline is another thing.
October 14, 2008 1:55:50 PM

Under Device - create a 'Spare' first.
October 14, 2008 3:52:05 PM

Thanks to all.

malveaux - I will be trying the Ubuntu test right now - just finished burning the disc.

Zenthar - the controller software should automatically rebuild using the parity files, but this doesn't happen. Within the software (SATARAID5), there is a "rebuild RAID group" option but it is greyed out no matter what I do (select the RAID group, etc.)

crimsonfilms - I have now created spares from both the old 750GB drive and the new 1TB drive. There is still no rebuild and I still don't get the option to rebuild. See the screenshots below.

I do have a friend in IT that is willing to help (if you are reading this, THANKS!) so I may not have access to this computer, drives, and enclosure starting tonight. I am open to any suggestions until then.

At this point I am not sure exactly what the problem is. The main issue seems to be that the RAID group is not even seen by Windows at all. Controller issue? Driver issue? How do I test each?





October 14, 2008 5:12:54 PM

I tried booting into Ubuntu, but something happens with the display adapter and the screen goes haywire when Ubuntu comes up (the first two menus are okay - English, boot from CD - but then the screen goes crazy).

So, that is my latest unsuccessful attempt to fix my problem. ;-(
October 14, 2008 5:31:56 PM

Try a dedicated spare and not a global one. Also, check the status of the RAID, it might be rebuilding it in the background. According to the help, Rebuild is for non-fault tolerant RAIDs .
October 14, 2008 5:49:22 PM

Thanks, I actually have not tried that, yet.

I now have tried this, but when I try to create a dedicated spare I get an error saying, "The Requested Operation Failed: Invalid RAID Group number".

The problem with this is that there is only one option for a RAID Group number, which is "0". That is the correct number for the RAID Group. You can see in my screenshots that it says "Kahuna (RG0)".


I am sure that there is no rebuild going on in the background. I have been checking the "Event Log" and "Task Manager" and there is never a mention of a rebuild. In the Event Log, the two devices (HDDs) for the RAID Group are found and validated. Then, for some reason it just goes offline - "Group 0 "Kahuna" status: OFFLINE".

Is there some way to "force" it back online? Why is it going offline in the first place?
Anonymous
a b G Storage
November 20, 2008 2:59:45 AM

i have this exact same problem now. did you have any luck solving it?

thx
March 2, 2009 10:08:34 AM

I have this problem too! How did you fix it in the end?

Thanks.
March 28, 2010 7:07:07 PM

I have this issue too and have not found any results yet.. WTF is going on!
March 28, 2010 7:22:40 PM

I ended up recovering the data using RAID Reconstuctor and then GetDataBack.

I'd recommend avoiding Silicon Image "raid" controllers, I certainly will be from now on.
a c 415 G Storage
March 28, 2010 7:31:29 PM

For folks looking at this (old) thread, you should understand that RAID-5 is not a particularly reliable way to protect data, especially when you start getting into very large arrays. It has nothing to do with the controller and everything to do with the reliability of the disks themselves.

The problem with RAID-5 is that if ANY drive fails then the array can ONLY be recovered if the controller can successfully read EVERY BLOCK from the remaining disks. With HDD unrecoverable read error rates hovering at as much as one per 10^14 bits read, that gives you up to a 10% chance of an unrecoverable read error when reading all the sectors from a single 1TB drive.

Multiply that by several drives and it starts to become likely that you won't be able to recover the data!

RAID 6 is a much more secure organization - it uses two parity drives and unless you happen to get unrecoverable read errors in exactly the same place on two different drives it will be able to recover all your data.
!