Repairing a damaged DIMM slot

I have a DIMM slot on an Asus motherboard that appears to be damaged. I think this was due to a rushed attempt to install some memory upside down (doh! I've been doing this for 10 years and this is the first time I damaged a mobo)... anyway, before plonking down the cash to buy a similar model on ebay, I was thinking I could try to tinker around with the slot to see if I can pull the pins back up (assuming that's what is wrong). Just looking for advice from anyone that has maybe tackled such a problem before. I've read elsewhere about people managing to fix damaged DIMM slots, but these were short on details. I have good experience putting PC's together, but I have never ventured into soldering and the like.

Thanks in advance...
7 answers Last reply
More about repairing damaged dimm slot
  1. Use microscope when you do that.
  2. How is that possible? Have you used sledgehammer and blindfold? :)

    But I'd try to repait it, too if I was you... Let us know if you manage to. And take some pictures; I really wonder, how this mess looks like.
  3. Maybe I should clarify, i'm GUESSING that is what happened. I have not pulled the motherboard out of the case yet and looked at it under a magnifying glass to be sure. I believe this is the case as i was using 4 512MB DIMMs using all the slots (working fine) and went to upgrade to 4 1GB DIMMs. After the upgrade I kept getting no POSTs with memory errors. I tried everything under the sun assuming that the memory was bad, even testing 1 piece at a time in slot 1 and upgrading my power supply, and trying the OLD memory configuration. I then tried one working DIMM in each slot individually and all the slots POSTed fine except for slot B1. Thus, I came to the conclusion that I must have damaged the slot somehow, though I admit I definitely didn't use a sledghammer! Big part of the frustration here, I wasn't exactly jamming it in there and, like I've said, I've installed RAM more times than I can remember.
  4. I have a similar problem with an ECS board. I know this is an old message but I saw no success or failure info. My board has 2 dimm slots. 1gb in each slot. HWINFO32 shows 2 dimms but the one in socket 0 is active and the one in socket 1 shows as "not installed" after it shows the the type and model. Bios does not see it either, but it did originally. Swapping sockets shows both sticks to be functional and the machine runs ok on one but reaches low memory during game play from time to time. I am hoping someone found resolution to this issue and will post it. I tried bios update with no success. The socket had some dirt in the contact holes on either side so I blew out the dust. No Help again. All connections are tight and no damage to mountings can be found. It does seem there is a long empty slot with no contacts showing as the previous message. I can only assume the locks on each end are supposed to force contact when locked in place
    :ouch: Going Bald
  5. Actually, I think the locks snap into place when the stick is fully inserted, but don't provide any other pressure. And they make it easy to pop the stick back out.

    Was your 2nd slot unfilled previously? If there was really material in it, then air alone won't likely fix it. I've always used a high %/quality alcohol for this, VERY lightly applied with something that doesn't leave behind fibers. So a foam cleaning qtip is ok, but not the normal fuzzy ones. You don't want the slot wet, but do want to moisten any particles enough to lift them off/out. Then I'd use that air to quick-dry it.

    The BIOS is the determining factor on whether your RAM is found or not. It should show when you boot, if BIOS is set for quick POST, turn that off.

    The magnifying glass mentioned isn't a bad idea. Look carefully at the metal parts of the slot, the contacts, see if they are tarnished. Try to clean if they are.
  6. The slot was originally empty. I got a new pair of 1gb cards as this was a new (old) machine. It had been on a shelf for 3 years and someone - borrower the 500mb ram that was in it. The bios saw the ram when first placed in the machine, but after about 30 days only one stick remained showing. I tested both and flashed the bios with a new update. (it was successful) but it still does not see the ram. 1gb is used. I will try a better cleaning. Very frustrating
    Thanks for the reply
    Going Bald (still) hehee
  7. In the old days, we used to use very fine emory paper to clean the edges of cards and such which were tarnished, can't really suggest that for RAM slots tho.
Ask a new question

Read More

Motherboards DIMM