Sign in with
Sign up | Sign in
Your question

Audio out of sync when rendered in Vegas

Last response: in Applications
Share
February 26, 2013 12:58:31 PM

Hi,

I have a few VHS tapes that I have previously transferred to my PC via a capture card. Recorded audio is 1 channel. So I've been importing to Vegas Pro 12 to duplicate the audio channel. I also have a plugin that cleans a bit of the noise from that old, rusty VHS footage.

I've rendered a few a while ago, on my old computer. Recently got a new PC and resumed rendering. I'm noticing however that the audio and video are out of sync. I even rendered a small, 2-minute part of the video, and the output is still out of sync.

I made sure that the project frame rate is the same as the rendered template. Tried audio at 48,000 Hz and at 44,100 Hz (read somewhere it might make a difference). Same thing.

I tried saving as MP4, Avi, and mpeg...out of sync with all.

The entire captured footage is in mpeg format, and, needless to say, plays well without any sync issues.

I even tried importing it into vegas and directly rendering a portion (without noise cleaning/audio channel duplication). Same thing. Audio and video out of sync.

I'm running out of ideas. Any suggestions?

Thanks!
March 3, 2013 9:51:54 AM

Thank you for your reply...

I had checked that forum extensively prior to posting here, but nothing I found seemed to work.

Any other suggestions?
m
0
l
Related resources
March 4, 2013 7:24:21 AM

Are they in sync when you import them into vegas in the trimmer window?
Also when you import them into the time line are they 2 separate tracks the audio and video?
m
0
l
March 4, 2013 7:33:40 AM

Yup, they are in sync when I import.

And audio and video are 2 separate tracks. Source recording is 1 channel, so I'm duplicating the audio channel to get stereo output. (I did try rendering without duplicating, rendered vid is also out of sync)
m
0
l
March 4, 2013 8:32:58 AM

there are many things that could go wrong with your technique.
My main guess is that you may have cut a small section of the audio off when you took it into the timeline.
In saying that if it is synced in the timeline's preview player, then it could also be the player itself, have you tried it in VLC and quicktime, etc?
apart from that without seeing what you are doing there are many variables that could cause this.

The plug in could cause it, i would try and render without using this also try another program say premiere pro or even live movie maker (I am just saying to see if it renders synced) and see if you end up with the same result.
m
0
l
March 4, 2013 8:59:50 AM

Thanks for your reply.

I doubt I did, as I repeated the process a few times just to eliminate the possibility of an error on my part. And to eliminiate it being the plugin/my method of duplicating audio channel, I simply imported source audio and rendered directly, without duplicating audio channel or applying plugin. Result? Out of sync audio.

I tried playing in VLC and Windows Media Player, also tried on my Mac with VLC and QuickTime. Same thing.

This is driving me crazy!
m
0
l
July 16, 2013 11:32:14 AM

rawanabusalman said:

This is driving me crazy!


Did you find a solution? I am currently running into a similar problem. I noticed that the audio was synced up correctly at the beginning of every audio chunk. So I cut my audio (because it is sound effects) into small chunks through out instead of one long continuous track. At parts where I could not simply cut out silent parts, I just spliced the audio at a quiet moment, but didn't delete or move anything around.
I don't know if it has something to do with the audio settings (like its hz), but I am testing it out some right now.
m
0
l
July 17, 2013 2:21:38 AM

FrankDisciple said:
rawanabusalman said:

This is driving me crazy!


Did you find a solution? I am currently running into a similar problem. I noticed that the audio was synced up correctly at the beginning of every audio chunk. So I cut my audio (because it is sound effects) into small chunks through out instead of one long continuous track. At parts where I could not simply cut out silent parts, I just spliced the audio at a quiet moment, but didn't delete or move anything around.
I don't know if it has something to do with the audio settings (like its hz), but I am testing it out some right now.


Nopes. Never got it to work. I plan on re-capturing the video from VHS again, just in case something went wrong while capturing. Not sure this would change anything, but I'm about out of ideas.

I'll come back here and post my results once I get around to doing that
m
0
l
March 29, 2014 4:23:09 PM

I had a similar problem but could never find a solution on the Internet. But, after doing some experimentation, I stumbled on a work-around for my sync problem. My problem involved a 2 hour mpeg2 file. The audio and video were in perfect sync while in the Vegas Pro timeline, but when rendered as WVM, or anything else, the audio was out of sync by about 8 seconds.

By accident, one time, the region I rendered (while in my experimentation phase) started a few seconds after the start of the video ... rather than at the very beginning. The rendered results was in perfect sync. So, I tried just a two minute region starting at the beginning of the timeline, and got the audio sync problem. Then I tried another two minute region, but this time with the start of the region 15 seconds into the movie. The results was perfect sync. I don't know what the problem is with the first few frames of the MPEG, but that appears to be where the problem is.
m
0
l
April 23, 2014 12:04:36 AM

Well lucky you. I had two mpeg2 clips which were problematic. I realized that, in one of them, the sync problems were just in the last 10 or so minutes. So I cut the clip in the last 10 minutes, detached audio, and manually tried to sync. It wasn't idea, but it worked well enough.

The second clip, though, was disastrous. It was all out of sync. I tried your suggestion and started it off at 15 seconds. Remained out of sync. I kept trying to push starting by increments of 30 seconds, up till I reached 5 minutes. It was still out of sync. I then rendered a random 1-minute clip from the middle of the 1h30 clip, it also was out of sync.

Don't know what else to do honestly.

Might anyone have any more suggestions I could try?
m
0
l
!