Sign in with
Sign up | Sign in
Your question

Samsung SSD Magician

Last response: in Applications
Share
March 4, 2013 4:52:43 PM

Hi

I have a Samsung SSD 830 series and I installed Samsung Magician Software v 4.0 on Windows 8 Pro x64. What bothers me a lot is that every boot/restart of the pc, the UAC popup window appears (that is normal) asking for permission to let Samsung Magician make changes to the computer. That is VERY FRUSTRATING. (I don't want to change settings or disable UAC)

I tried to do what I've successfully done with other software - create a Task with Task Scheduler to run at log on, with highest privileges, me as admin.
Then created a shortcut linked to that task (schtasks /run /tn "name of task") to bypass UAC popup.
It works with other softs, but not Samsung Magician. I get this error when I try to run the task or launch it via the shortcut:
"Initialization of logger module failed. Cannot start the application"

Can Anyone Please help with this issue?

Thanks a lot

More about : samsung ssd magician

March 10, 2013 7:03:35 AM

bertikul said:
Hi

I have a Samsung SSD 830 series and I installed Samsung Magician Software v 4.0 on Windows 8 Pro x64. What bothers me a lot is that every boot/restart of the pc, the UAC popup window appears (that is normal) asking for permission to let Samsung Magician make changes to the computer. That is VERY FRUSTRATING. (I don't want to change settings or disable UAC)

I tried to do what I've successfully done with other software - create a Task with Task Scheduler to run at log on, with highest privileges, me as admin.
Then created a shortcut linked to that task (schtasks /run /tn "name of task") to bypass UAC popup.
It works with other softs, but not Samsung Magician. I get this error when I try to run the task or launch it via the shortcut:
"Initialization of logger module failed. Cannot start the application"

Can Anyone Please help with this issue?

Thanks a lot



I am having the same problem. So far I have disabled UAC. It started after doing a firmware update, or an optimization, not sure which, since I did both at the same time. I do not get the error you are getting, but am interested how you disable a UAC for the certain application. Can you explain. I would like to try to see if it get rid of my boot message requesting the permission.
a b Ô Samsung
March 10, 2013 6:20:02 PM

msconfig then uncheck the samsung software start a boot
Related resources
March 11, 2013 12:11:38 AM

rmsowell said:
I am having the same problem. So far I have disabled UAC. It started after doing a firmware update, or an optimization, not sure which, since I did both at the same time. I do not get the error you are getting, but am interested how you disable a UAC for the certain application. Can you explain. I would like to try to see if it get rid of my boot message requesting the permission.


Here you go http://www.petri.co.il/bypass-uac-using-desktop-shortcu...
March 23, 2013 5:57:07 PM

Hi, according to this Samsung Magician doesn't need to run at startup. I would avoid messing with the UAC, and Win8 makes it really easy to disable a program at startup:

1. Open Task Manager (Ctrl+Shift+Esc)
2. Select the Start-Up tab
3. Right click on Samsung Magician Application
4. Select Disable

hth,
lux
November 5, 2013 11:11:45 PM

bertikul said:
Hi

I have a Samsung SSD 830 series and I installed Samsung Magician Software v 4.0 on Windows 8 Pro x64. What bothers me a lot is that every boot/restart of the pc, the UAC popup window appears (that is normal) asking for permission to let Samsung Magician make changes to the computer. That is VERY FRUSTRATING. (I don't want to change settings or disable UAC)

I tried to do what I've successfully done with other software - create a Task with Task Scheduler to run at log on, with highest privileges, me as admin.
Then created a shortcut linked to that task (schtasks /run /tn "name of task") to bypass UAC popup.
It works with other softs, but not Samsung Magician. I get this error when I try to run the task or launch it via the shortcut:
"Initialization of logger module failed. Cannot start the application"

Can Anyone Please help with this issue?

Thanks a lot


I finally figured this out. When you create the task and create the "start a program" action you need fill out the "start in (optional)" field. You should enter the directory of the Samsung magician executable here. Make sure you enter the directory location without quotes, even if there are spaces.
You should also enter /AUTOHIDE under the "Add arguments (optional):" field. That did the trick for me.
Hope this helps people as it was driving me nuts.
And yes I know I could have just disabled it from starting. But I needed to figure this out. :) 
November 23, 2013 9:15:42 AM

Easiest fix to this. I started the same way as luxology but fixed it a different way since I want the program to run:

1. Open Task Manager (Ctrl+Shift+Esc)
2. Select the Start-Up tab
3. Right click on Samsung Magician Application
4. Click Properties
5. Click Compatibility Tab
6. Check the box under "Privilege level" next to "Run this program as an administrator"
7. Click Apply on bottom right of window

Done.
January 25, 2014 11:49:02 AM

A shortcut to Samsung Magician is put into your start folder. That's where the startup entry is. All you have to do is remove it from there. There's no need to go messing with msconfig, UAC or anything else, like I started to do when reading this thread.

As was said earlier, there's no need to run it all the time. What hasn't been said is that it's a configuration tool. Do go through the configuration once, though. Most of the stuff is pretty much self-explanatory, or explained with help messages. The data security section you can leave alone unless you want to encrypt the entire disk.

As an aside, Samsung does also run the Rapid Mode Notification utility, which does not complain when it starts up. This runs some sort of continuous optimization process (which you get if you enable Rapid Mode during the config.)
March 2, 2014 9:28:35 AM

fred3233 said:
Easiest fix to this. I started the same way as luxology but fixed it a different way since I want the program to run:

1. Open Task Manager (Ctrl+Shift+Esc)
2. Select the Start-Up tab
3. Right click on Samsung Magician Application
4. Click Properties
5. Click Compatibility Tab
6. Check the box under "Privilege level" next to "Run this program as an administrator"
7. Click Apply on bottom right of window

Done.


This seems to be the best fix for me. Still allows the program to start up and does away with the annoying bootup message. Thanks.
March 18, 2014 1:15:31 AM

I have the 840 pro SSD had same problem and this is what i did. Installed it in C:\Program Files. not x86 as i found programs installed to, "C:\Program Files" do not ask me for UAC at startup. perhaps that folder has elevated permissions in windows :D 
April 11, 2014 9:07:48 AM

jmcb1b said:
fred3233 said:
Easiest fix to this. I started the same way as luxology but fixed it a different way since I want the program to run:

1. Open Task Manager (Ctrl+Shift+Esc)
2. Select the Start-Up tab
3. Right click on Samsung Magician Application
4. Click Properties
5. Click Compatibility Tab
6. Check the box under "Privilege level" next to "Run this program as an administrator"
7. Click Apply on bottom right of window

Done.


This seems to be the best fix for me. Still allows the program to start up and does away with the annoying bootup message. Thanks.




EXCELLENT SOLUTION. JMCB1B

Thanks very much
June 22, 2014 11:14:45 AM

fred3233 said:
Easiest fix to this. I started the same way as luxology but fixed it a different way since I want the program to run:

1. Open Task Manager (Ctrl+Shift+Esc)
2. Select the Start-Up tab
3. Right click on Samsung Magician Application
4. Click Properties
5. Click Compatibility Tab
6. Check the box under "Privilege level" next to "Run this program as an administrator"
7. Click Apply on bottom right of window

Done.


This is what I would want as well.
Although I am not certain of all of the possible consequences of allowing it to "run as admin", there are a few programs that I installed that need to run at startup and the UAC popup every time I reboot is a pain.
The only real concern is whether the "run as administrator" is doing it with "my personal administrator privileges" or is using the "hidden Super Admin" privileges. Since I do not have the "Super Administrator" enabled I assume this not to be the case but would like to be sure.

The program I am running is "Everthing.exe" a very speedy file indexer that allows me to do system wide file searches at speeds much greater than the normal Windows Search. It runs at start-up to see if it needs to add any entries to the already created file tables. I want it to run at every startup but without having to give my OK each time. There should be some sort of "whitelist" for startup programs that a user could use to add any that have this problem. Maybe something as simple as a "Yes and don't ask me again".

A corresponding BLACKLIST (i.e.: NO and don't ask me again) for same would also be handy to prevent those applications that seem to "add themselves" to startup repeatedly requiring me to eliminate them every time they do.

Both would be great tools and I am surprised to hear that they are not already a part of the Windows OS startup features.
!