You must be an admin to install software

Hi guys, i seem to have run into a problem. when i try to install the intel chipset driver from my motherboard website (gigabyte) it stops and a popup says you must have administrator rights to install this sofware? i have xp home sp2 and i AM the admin. i have tried the f8 method for safe mode and still the msg pops up. any ideas?
53 answers Last reply
More about admin install software
  1. doesnt work no matter what i do. i am administrator, its just that some things i cant access, like my intel chipset driver for some reason. i also got the xp cd from a friend who most likely pirated it. maybe this is the reason?
  2. nope, it only gave me the LAN controller which i already have. its weird how i can do all the things an admin can do except for downloading driver chipsets
  3. Check the user profiles in the control panel to make sure your profile is classified as having admin rights.

    You can boot into safe mode with networking, and use the default admin account to install the drivers.

    If you are listed as having admin rights, and still having this problem, you may want to run a malware scan. Make sure you scan while in safe mode with networking, and update the scanner before you scan.
    www.malwarebytes.org/
  4. i tried installing the chipset in safemode and i tried scanning with malware bytes but nothing! i might as well give up, i dont think there is a solution, as i am totally sure that i am admin. just asking but do you really need a chipset driver for your computer, because right now my computer is obviously without a chipset but works perfectly fine. thanks
  5. The chipset driver helps correctly identify the CPU, and tell the north and south bridge what they are capable of doing.

    When you went into safe mode, did you try using the default admin account? If not, try that. While you're there, look at the user accounts, to verify that your account has admin rights.
  6. so the chipset is not needed as it obviously does recognize my cpu (dxdiag recognizes as i5). i went to safe mode , and i am admin. i tried installing the chipset in the admin account, and the msg still pops up saying that i must be admin to download the software. i dont think there is anything that i can do, so ill just leave it as it seems that a driver chipset is not all that important and my computer is functioning fine. thanks
  7. Here is a long shot. Give this a try...
    http://support.microsoft.com/kb/929833
  8. so are chipset drivers all that important? do i HAVE to download them?
  9. Do you have any conflicts in the device manager?
  10. nothing is unstable in my system (at least not that i know of). but in my device manager theres question marks on other devices which are audio device on high definition audio bus (listed 4 times) and sm bus controller (listed once).
  11. The SM bus controller is what facilitates communication with onboard devices. Those are devices that would be installed with the chipset driver.
  12. so is there an update or something that i can download so that there is no question mark?
  13. yes, you need that chipset driver. Try downloading it from another PC, and see if you get the same error. If not, put the file on a flash drive and move it to your PC.
  14. well the sm bus controller is in my chipset driver which i cant download in the first place because of the admin rights problem.
  15. can i just download the sm bus controller separately as for my audio device on high definition audio bus? or is this all available on only a driver? thanks again
  16. If it's not listed seperately on the Gigabyte website, then I wouldn't. I don't really trust those 3rd party driver sites.

    Try downloading the driver file from another PC, and see if you still get the Admin error message.
  17. its not when i download the driver and get the admin msg its when i install it, and halfway through the installation the message pops up and says that setup will close. i have tried installing the driver on this computer (the one im using right now) and it just hangs (my guess is because its a very old computer)
  18. What model is your motherboard?

    I take it, you were able to install other drivers, programs, etc..?
  19. its the gigabyte p55 ga usb3: http://www.newegg.ca/Product/Product.aspx?Item=N82E16813128425&cm_re=p55_usb3-_-13-128-425-_-Product
    yes, i have installed everything; service pack 3, windows updates, games, programs, music, etc. except for that one intel driver.
  20. What rev # is it?
  21. it is revision 1 i think
    how do i check?
  22. It will be written on the motherboard, where it lists the model.
  23. Download/run http://www.belarc.com/free_download.html
    This will tell you everything about your computer.
  24. I should've mentioned, CPUZ will also give you the rev number. It's under the mainboard tab.
    http://www.cpuid.com/cpuz.php
  25. Get them both. They're both free and they both have their strong points.
  26. its rev 11
  27. I see a rev 1.0 and 2.0. I don't see a rev 11. Is that from CPUZ?
  28. yea it said rev 11 but i think it should be 1
  29. If this isn't the link you've been downloading from, try the chipset driver here.
    http://www.gigabyte.com.tw/Support/Motherboard/Driver_Model.aspx?ProductID=3311&ost=xp#anchor_os
  30. yup thats the site i downloaded from.
  31. Is that the same driver model?
  32. yes it is
  33. i tried downloading and installing from revision 1 and 2 but its the same thing
  34. After you download the driver, right click on it, and click 'run as.' You can then choose to run it as the administrator. This may be the problem.
  35. i also tried this, but there is no run as admin (i have xp not win 7 or vista). when i right click on the driver it only says run as owner (which is the account that i am on) and it asks for a password which i have no clue as to what it is.
  36. I also have XP. Here's how you run as Administrator.

    http://img21.imageshack.us/img21/7346/newpictureqj.png

    http://img532.imageshack.us/img532/5459/newpicture1k.png

    The default administrator password is normally blank, so no password will likely be needed.
  37. mine doesnt say administrator though, only owner, and it does require a password as it gives me an error.
  38. Are you running XP home?

    I would suggest running a malware scan (simply precautionary) in safe mode with networking. Make sure to update the database before the scan.
    www.malwarebytes.org/

    After that, you can try creating a new user with administrator rights. Then you can try installing the updates with that new user account.
  39. yes i am using xp home edition service pack 3. i ran malwarebytes as advised before but it found nothing on my system. i also tried making a new user account with admin rights but it says the same thing; you must be an administrator to install this software, setup will close.
  40. I wanted to verify that the download itself wasn't faulty, so I just ran it on my backup PC. It is also running XP SP2. The driver installed without a problem.

    Try start-->run-->sfc /scannow

    If that doesn't help, a repair install is about the only other thing I know of to suggest.
  41. aford - sfc was my suggestion on my third posting on the thread. It was apparently ignored.
  42. the link you gave me earlier only applied to vista and windows 7
  43. The link was for vista and W7, however, the same command is valid in XP as well.
  44. just a question before running it, what exactly does it do? thanks guys
  45. It will check all your system files, and replace any damaged ones.
Ask a new question

Read More

Drivers Software Windows XP