Sign in with
Sign up | Sign in
Your question

New 3850 Installed; Sound no longer works

Last response: in Graphics & Displays
Share
December 28, 2007 1:24:18 PM

I installed a 3850, new PSU, and ram for my brother inlaw. Well as far as the gfx are concerned, the card is a total Knock-Out. Awesome bang for the buck there. However, when trying to install the drivers for the card, the cd was blank. Evidently many other buyers have had this problem as well. I went to ati's site and downloaded the 7.12 catalyst drivers (just the driver itself) and after doing so, the sound ceased working on his PC after the reboot. He has onboard sound and it's an HDMI device, whatever that is. The device manager says it is still working properly however no sound is being played. I uninstalled, rebooted, and reinstalled the audio drivers, but this did not work either.

This is also a common problem for some folks with the 3850 and 3870. Other users are saying the video card drivers are trumping the sound drivers and taking the sound drivers place. I can't figure out how to fix this
December 28, 2007 1:31:09 PM

HDMI transmits audio and video. I think it's trying to work as the sound card... try disabling the onboard sound or the 3850's sound properties. (if that is possible - I don't know as I don't own one)
December 28, 2007 1:32:57 PM

Is HDMI the video card? If so, that's definitely what is trying to happen as that is the device that shows up in the sound menu. No other device is viewable, just the HDMI.
Related resources
December 28, 2007 1:46:17 PM

I think so, does the back of the 3850 have a thin, flat adapter? Should look like this:



I'm pretty sure it's trying to act as the sound, so you can try right-clicking and disabling the HDMI device via Device Manager and check the BIOS to ensure on-board audio is enabled.
December 28, 2007 2:01:39 PM

I don't know if we installed an adapter on the back of it like that. We put the VGA adapter in the spot that black one is in, however.
December 28, 2007 2:11:18 PM

Here's my fix, go into your control panel, sounds and audio devices. Somewhere in there is a drop down box ask which sound device you want to use. Installing the ATi defaults it to the HDMI, it did for me and turned off my 5.1 sound. I can look for the details later if you still need a bit of help.
December 28, 2007 2:31:30 PM

Details would be good, as I am sure I tried this already.
December 28, 2007 2:39:26 PM

Start
>Control Panel
>>Sounds, Speech and Audio Devices (Category View)
>>>Sounds and Audio Devices
>>>>Audio

The drop down box should display which ever you want the sound on, Default is ATi, I put mine back onto on board.
December 28, 2007 2:39:54 PM

Also, as a side note, this PC is 32bit Vista.
December 28, 2007 2:40:18 PM

*edit* Geotech beat me to it!

*edit* Again. Change your Control Panel view to Classic View. It will make it easier to follow our instructions. :) 

Try going to Control Panel -> Sounds and Audio Devices -> Click the Audio tab -> Under 'Sound Playback' click the drop down box and see if there are any other devices that you can select there.
December 28, 2007 2:42:12 PM

ewww vista.
I'll have to try, I'll dual boot vista business.

regeist554 may be correct.
December 28, 2007 2:46:14 PM

I only work in classic view myself as well. I'm not a complete PC dunce. been using them since aol came out ;p I think I may have been in the 4th grade then. 25 now and know enough to do my own hardware installs and fiddle with things, but things like this are a bit out of my league, simply because I don't know WHAT has happened.

I'm almost certain I've done what is being recommended, but when I head over to his house here shortly, I'll give it a go again.

Would an easy fix be simply getting a new sound card and installing?
December 28, 2007 2:50:22 PM

Quote:
I only work in classic view myself as well. I'm not a complete PC dunce. been using them since aol came out ;p
Most excellent! :D  One of my biggest peeves w/ Vista is the way the rearranged all the settings - Classic view, I love you. :) 

Quote:
Would an easy fix be simply getting a new sound card and installing?
I'm just thinking it has the wrong default playback device. Swapping it over to onboard or disabling the HDMI part of the device should fix the problem. Even if you do get a new card, you will still have to make sure it is the default playback / recording device as opposed to the HDMI.

Hopefully this clears things up a bit, if not, don't fear to come back and ask more questions.
December 28, 2007 4:34:22 PM

Ok, he ran the directions as requested and it says "no audio devices are installed."
December 28, 2007 5:46:37 PM

If he has a soundcard, not onboard, you can simply power down the PC, remove the soundcard, reboot. Then once in the desktop go ahead and power down again, re-install the soundcard and boot her up. This should make windows recognize the card again and may give you the option of making it primary all in one shot.

If not then go back through the control panel steps posters above listed and see if your soundcard shows up now.

If you do have onboard sound, hmm well unsure off top of my head, maybe reinstall drivers for sound that came with the board might work?
a b U Graphics card
December 28, 2007 6:01:58 PM

The thing is you should have the Realtek dialog box in the start-bar, it should give you the option to hot-swap between controllers.
I have to manually swap back after connecting HDMI (it's intergrated into the laptop not a dongle), but it doesn't automatically switch despite the auto-plug detect of the Realtek chip.

For me it appears like an orange/red speaker icon separate from the standard one.
December 28, 2007 6:14:03 PM

The same thing happened with my friend when he installed his 3850.
All he had to do was set the audio device in the control panel as some here have already mentioned. As rgeist554 said, the card was trying to act as the sound device.

December 28, 2007 10:38:56 PM

None of the suggest replies have worked. I ended up getting a cheap Soundblaster card installed for the time being. His front ports for mic/headphones don't work, neither do the rear. No device shows up under any audio/sound searches, minus the HDMI device. Not sure what the hell I did, but it looks as if it's not existent now.
a b U Graphics card
December 28, 2007 10:41:35 PM

Double check your BIOS settings, it may have bumped the intergrated audio into a disabled mode if it was on auto-detect.

This happened to someone else in the forum, and they had to go back into the bios to move it back to onboard audio.
December 28, 2007 11:09:50 PM

How do I fiddle with BIOS settings? I remember messing with them a bit a few years back, but I don't do a lot with those any more.
December 28, 2007 11:37:12 PM

several things you can do. Edit: my fix is for XP, but maybe something similar exists in Vista.

1. go to "device manager", expand "sound, video and game controllers", select "ATI function Driver for high definition audio -ati aa01", select "disable". Don't select "delete". If you do, it will just try to reinstall it on next start up. Make sure you select "disable".

2. uninstall the ATI high def audio software thru "add remove programs".

3. uninstall all the ATI 385 drivers. Reinstall the drivers, but select custom install. Then install all the ATI software except the High Def software. Edit: This should work for vista.

When i installed the latest catylist drivers i did the last one. They all have worked for me in the past.
a b U Graphics card
December 29, 2007 1:28:08 AM

teqvet said:
How do I fiddle with BIOS settings? I remember messing with them a bit a few years back, but I don't do a lot with those any more.


Before radically deleting stuff, check your bios by looking at the startup screen and see what the message says, usually it says something like press F1 for BIOS settings.

Double check that first, then consider chopping out portions of the drivers.
December 29, 2007 2:10:38 AM

50bmg said:
several things you can do. Edit: my fix is for XP, but maybe something similar exists in Vista.

1. go to "device manager", expand "sound, video and game controllers", select "ATI function Driver for high definition audio -ati aa01", select "disable". Don't select "delete". If you do, it will just try to reinstall it on next start up. Make sure you select "disable".

2. uninstall the ATI high def audio software thru "add remove programs".

3. uninstall all the ATI 385 drivers. Reinstall the drivers, but select custom install. Then install all the ATI software except the High Def software. Edit: This should work for vista.

When i installed the latest catylist drivers i did the last one. They all have worked for me in the past.



Did that. Did not work.
December 29, 2007 2:11:25 AM

TheGreatGrapeApe said:
Before radically deleting stuff, check your bios by looking at the startup screen and see what the message says, usually it says something like press F1 for BIOS settings.

Double check that first, then consider chopping out portions of the drivers.



I'll look in to this tomorrow, thanks again.
Anonymous
a b U Graphics card
a b \ Driver
March 7, 2009 1:58:18 PM

thnxyou so much for your kindness my friend of posting your problem and solutions..i really appreciate it and i have just downloaded the driver on the site that ws given and i hope it will work..again thank you :) 
Anonymous
a b U Graphics card
a b \ Driver
March 7, 2009 2:28:23 PM

hi one more thing i forgot to say that im running home vista and the drivers thatyou have downloaded was only applicable to XP..so how can i know which drivers should i download?pls respond :( .

April 24, 2009 12:19:25 PM

Quote:
hi one more thing i forgot to say that im running home vista and the drivers thatyou have downloaded was only applicable to XP..so how can i know which drivers should i download?pls respond :( .


Start
>Control Panel
>>Sounds, Speech and Audio Devices (Category View)
>>>Sounds and Audio Devices
>>>>Audio

The drop down box should display which ever you want the sound on, Default is ATi, I put mine back onto on board.

I had these exact problems and all that was needed was to select CMEDIA as the output device. The Bios settings should be returned to their default values in case integrated sound was turned off.

June 26, 2012 11:15:35 PM

rgeist554 said:
I think so, does the back of the 3850 have a thin, flat adapter? Should look like this:

http://regmedia.co.uk/2007/05/14/amd_2900_xt_1.jpg

I'm pretty sure it's trying to act as the sound, so you can try right-clicking and disabling the HDMI device via Device Manager and check the BIOS to ensure on-board audio is enabled.



The BIOS was totally the problem with mine. The onboard audio setting was set to Auto, I switched it to Enabled and presto. Sound... YAY :bounce: 
!