Sign in with
Sign up | Sign in
Your question

Seagate ST3500320AS doesn't work in RAID

Tags:
  • Hard Drives
  • NAS / RAID
  • Seagate
  • Storage
  • Product
Last response: in Storage
Share
November 12, 2008 10:46:51 AM

Hello, ppl!
It seems to me that Seagate drives have a problem in RAID configuration (what is not described in any documents/pricelists).
Situation: I have Gigabyte GA-EP45-DQ6 (ICH10R) + 2x500Gb drives in RAID-0. When I install WinXP (with integrated fresh drivers for ICH), setup sees RAID. I select full format to NTFS, but on 25% HDD LED is going OFF and setup just stops (but computer works). This happen again after reinstall and again on 25%. Well, some people adviced to change strip size to 64K or less (what a dependency???). I made 64K and... system stops on 3%! Viola! (at least I didn't wait so long)
So... what is a HARDWARE RESTRICTION of Barracuda series, that prevets 'em to work in RAID??

I know that Sheatgate has "enterprise" series of drives, but I don't give a __amn what they sell else - my drives have to work.

PS
After I selected "Quick format"... system continued to install! (and worked some days) But I don't want to loose my data on so strange "RAID" just because Seagate sells another drives for a DOUBLE price. I reconfigured my RAID to two simple drives and sit with two pieces of sh....

More about : seagate st3500320as work raid

a b G Storage
November 12, 2008 11:25:25 AM

There is no reson the drive will not work in a RAID array.
The problem is something else, like one of the drives is defective, the controller is flakey, or maybe you using the wrong driver, or maybe you have a loose cable, or could be anything. But the point is, if everything is correct and working as it should, whether the drive is in RAID or stand alone has no bearing on anything.
November 12, 2008 11:59:38 AM

jitpublisher, absolutely agree with you - nothing "special" must be in drive to be RAID. Despite of this fact, Seagate sells something named "ES" series and instead of fixing firmware of "usual" drives, advices me to... buy "ES" drive! (by double price, of course) That "solution" makes me feel frauded by misinformation in Seagate's advert.

Yes, I did tests (with SeaTools) - utility reports that drives is OK. But my system also is OK sinse it worked in RAID some term. Problem happen only on 'full format' stage and I'm not sure this won't happen in real use.

BTW, Hitachi drives tested with ICH10R worked well from start. I think I know what will be my next purchase...
Related resources
a b G Storage
November 12, 2008 12:06:30 PM

The last 2 Seagate drives I owned about 2 years ago....... It started the click, click thing about 1 hour after I installed it. Returned it for another one, and after about a month, it quit spinning up.
Anonymous
a b G Storage
November 13, 2008 3:21:50 PM

Thronik is correct. We bougt two of the same drive about 2 weeks ago and we put them in to a dell server in raid1. After 2 weeks, the raid failed. We thought one of them was wrong, but in simle mode it works fine. And all data was correct on it. Anyway we bought an other one and put it to the server. The raid was rebuiled and worked, but when we started to write the drive the raid failed again. We tested the raid card, it was ok. And before these drive used samsung drives and that worked well. So i think so too,this type dont work well in raid.
December 14, 2008 12:59:44 PM

I have:
- Gigabyte GA-X48-DQ6 (Intel X48 + ICH9R Chipset)
- 3* ST3500320AS 500GB Harddisks (Seagate Barracuda 7200.11)
- 3* Samsung HD103UJ 1TB Harddisks (Spinpoint F1)

The Seagates and the Samsungs both run in their own RAID5 array. The Samsung array didn't have any problem yet, but the Seagate one is having problems, and I'm not sure why.

Yesterday the Intel Matrix Storage Console that comes with the RAID drivers reported the Seagate array was degraded and one of the drives is failing. I ran a full SeaTools test on the supposedly failing drive, but it passed without any error.

Back in Windows I marked the drive as normal and the RAID array started to rebuild (which takes around 20 hours :( ). This morning when I turned on the screen the rebuild was complete, but the same drive was marked as failing again. I'm sure the error status on the drive is removed before the RAID starts rebuilding, so a new error must have been detected during the rebuild or after that. Testing the drive in SeaTools again, but SeaTolls stil can't find any error.

I did notice the supposedly failing drive seems to be older than my other 2 Seagates. The serialnumber is a lot lower than the other 2, and the firmware version is AD14 while the other 2 have firmware version SD15. Could this be the cause of the errors? All 3 drives are the same model and bought in 1 order, I guess the store had a slightly older one on the shelf.
February 23, 2009 11:49:54 PM

Im building a supermicro system for doing digital media production (audio/video). I had originally purchased the (4) ST3500320AS drives for this purpose. Later, once I had the machine all assembled and had begun to configure and install XPpro I was having problems getting the drives to hold up in a RAID configuration. 2 drives were in Raid1, and 2 were in raid0. Approx every 3-4 system boot-ups some sort of error would be detected by the RAID system and the RAID1 would go into "verify" mode. I have had these drives no more than 2 weeks with only about 1 days worth of run time on them. The last straw was today when out of nowhere a S.M.A.R.T. error was thrown on one of the RAID1 drives that put that drive into a perpetual alarm state. Running a verify on it did not clear the RED blinky light on the front of the drive cage. Nothing short of replacement will clear the S.M.A.R.T. error. This is after less that 2 days total runtime! Im not waiting around to see what happens next with these drives as I have no time nor inclination. And, yes these are the same class of drives that had the dreaded BRICKING firmware malfunction that took Seagate 2 firmware rev's to fix. I found that out AFTER I bought these drives. Even though the drives I have "are not affected by the BRICK bug" according to Seagate tech support...

So... I have ordered 4 Western Digital Caviar Black Sata3 500gb drives (which are enterprise class drives) to replace the ST3500320AS's (desktop class drives) which will be sent off to Seagate for "replacement". I say "replacement" in quotes because Seagate doesn't give you NEW equipment for the time and money thrown down the drain on their products they give you REFURBS! After that Ill sell the ST3500320AS's off to the next highest bidder as they are worthless for ANY sort of critical application.
!