Unable to reformat hard drive

I've got an old Maxtor 200mb hard drive that I haven't used for a while. I reconnected it today to reformat and windows recognises the 2 partitions fine, the first is unformatted and the other had some old stuff on it. I tried to delete everything from the second partition but I was unable to delete three files for some reason, like an idiot I didn't write down the error message, something about file tables I think.

I tried to reformat in windows (right clicking the drive in My Computer, selecting format) but it seemed to just stop some way through, no error messages. I cancelled that and rebooted then I tried to reformat using run->cmd->Format G: and it stopped dead at 40%, a little bit of chuntering noise and the hard drive light flashed a little but it wouldn't go above 40%.

Is there anything I can do or at least try to get this drive reformatted?
3 answers Last reply
More about unable reformat hard drive
  1. You mentioned being unable to remove the files from that one partition, have you tried removing the partitions altogether? That being said, the fact that its failing the format, the drive is likely hosed.
  2. I don't have any way of making a boot disk at the moment which I think i'd need to remove the partitions or is there another way of doing that?

    To be honest I figured it probably was done for, I shelved it because it had always been tempremental, throwing I/O errors at me on a daily basis.
  3. The only thing you need a boot disk for is if your trying to format or remove the partition that the computer has booted to. Since this is an extra hdd, you can just right click the partition in Drive Management and choose delete partition. However this has been giving I/O errors previously and now it, wont format. I'd have to say its a waste of time to try and fix. That drive is done for.
Ask a new question

Read More

Hard Drives Storage