Sign in with
Sign up | Sign in
Your question

I may have formatted my external hard drive...HELP

Last response: in Storage
Share
November 14, 2008 12:41:57 PM

Last night I was trying to format my Acer computer because it had a virus. I backed up all of my data to my trusty Buffalo Drivestation Turbo USB and started the format process. I was kinda confused about how to format the computer because Acer uses something called "eRecovery Management." Anyway, it was saying that the drive was being reverted back to its factory settings (I assumed it was talking about the primary drive.) I feel like an idiot now because my external was definitely plugged in and turned on. Low and behold, I rebooted the computer to find that the C drive looked as if nothing had been done to it, but my external was not booting up.

I ended up reformatting the C drive of the Acer by burning recovery disks and using them, but the Buffalo drive still won't boot. It won't come up in "My Computer" for me to access anything, but it is definitely being recognized in the windows disk management utility. It comes up under "Disk 1" as a 465.75 GB partition. It also says that it is of a healthy EISA configuration.

I did some research and found that I might be in luck as long as nothing was written to the drive. I downloaded some recovery software but it can only be used if the drive if it is being recognized in Windows, which it isn't. Does this have anything to do with firmware?

Do I need to take the drive out of the enclosure and plug it directly into the computer? I tried to do this but I couldn't get the damn thing apart.


What should I do?
a b G Storage
November 14, 2008 12:50:38 PM

Have you tried assigning it a drive letter under disk management?
November 14, 2008 1:12:28 PM

Disk Management won't let me. I can only look at the properties. It comes up as a samsung device.
November 19, 2008 11:50:29 AM

Try different USB Ports, plug in and plug it out, and try the back of your PC.
It may be a recognition issue with Windows, make sure to try with another computer to see if would work.
Related resources
!