Sign in with
Sign up | Sign in
Your question

RAID 0 Volume Error on Vista

Last response: in Storage
Share
December 9, 2008 6:09:04 AM

Hello All,

I've used this site previously for research and I generally default here, however, this is my first post so please forgive me if I've posted this thread in the wrong area.

Now to the point! I have a new Home Build (About 1 month now) and I would consider myself an advanced user. I built my own system and had it evaluated and passed by a professional system builder.
Bottom line, things have been fine until the other day when I started normally and received an error message during bootup on the initial BIOS screen when it was analyzing the RAID Array. I have an ASUS Maximus II Formula MoBo and have 2 250gb Seagate Barracuda's set to a 0 RAID configuration. The BIOS screen reports an error to one of my drives and when I boot into the OS it gives me an error message in the taskbar stating, "RAID VOLUME ERRORS: Some data requests to a hard drive in a RAID 0 volume failed but a back-up may be possible. Please try to back-up data immediately." When I x out of that message, I recieve an icon in the taskbar that states, "A drive in a RAID 0 volume is failing. Try to back up data immediately." The Intel Matrix Storage Console reports the error when it's double clicked on the taskbar and all information seems to point to the same drive as all numbers match.

I've contacted Seagate and downloaded and ran SeaTools with both drives and the suspect drive reported errors, however, according to the program, it repaired the errors, I re-ran the program and it then passed the drive, but I'm still getting the red lettered error message for the drive on the BIOS startup screen and the taskbar is still reporting the error. I've checked all of the corresponding entries in my Device Mngr and they all report no problems.

Seagate Tech Support tells me that it's possible my RAID controller is hexxed or my MoBo is bad which I don't believe to be the case. My computer appears to boot fine and the only issue appears to be the error message with the drive.

On a last note, my ASUS MoBo Bios reports that the working drive is hooked to Port 0, whereas, the failing drive is connected to Port 1, yet according to the MoBo layout map, I have each drive connected to Ports 1 and 2 simultaneously with the problem drive hooked to Port 1 and the good drive hooked to Port 2 according to ASUS's directions.

I'm thoroughly confused as to my problem and ANY advice would really be appreciated!

a c 353 G Storage
December 9, 2008 9:24:41 PM

Have the same problem. This is one of the reasons many do not recommend Raid 0. I've be using raid 0 for the last 5/6 years now. I had one previous failure which was my fault, jared a drive during a write. About four days ago I got the same error message on my samsung 250's. During boot it shows one error on 2nd drive. Note this pair along with a pair of WD 320's have been running fine for two yrs.

It appears that a write request failed for one reason or another (ie bad sector on disk, com error, and or software confilict). I think this error is then stored by the Raid controller on the hard drive. This file is then checked during boot and the only way to get rid of it would be to redo your raid - Which whoud norally wipe out your data. Just read a post were an individual deleted his raid volume and recreated it with the same values and was able to boot, and his data was intack Might try this as I've backed up the data - would just need to reload Vista if it failed.

In your case, the HD utility reported an error, and fixed it (probably a bad sector), But the error is still recorded and therefore will be displayed. In my case I'm going to continue to use ( frequent B/U ofcoarse) an see If a 2nd error occurs.
December 10, 2008 6:40:10 AM

As far as the error is concerned, since I last executed the "Make Drive as Normal" function in the controller everything has been fine. I ran Seatoools and Windows Check Disk again abd both reported no errors. My computer boots, games, and applies other programming functions without hesitation, and as it seems, everything seems to be operational again. I have not and will not re-do my RAID array unless I recieve something similar as to an error message but FOR NOW everything seems to be working smoothly.

Again, if anyone has any info, suggestions, comments, or otherwise PLEASE reply as I'm still not convinced that I've solved this issue. Also, just to clarify, I am not recieving any error messages any more as of right now!
!