P5K Deluxe will not Recognize SATA RAID drive

I have just completed building a new computer with an ASUS P5K Deluxe WiFi board. I fired it up and no “beeps” to tell me if the video card, or keyboard, or memory, or any if there are any hardware conflicts. So far, so good. I get the initial screen to read the memory, the CPU, the mouse and the drives, but no hard drive. I have one EIDE CD Rom player installed, so I can install windows XP Pro and one SATA Western Digital WD5000YS RE2 RAID hard drive. When I go into BIOS it recognizes the CD ROM, but not the hard drive. The only reason why I am using this RAID drive is because I got such a good deal on it, but if it will not work on my system, I will get another drive. Is there something I am doing wrong, or should I get another hard drive? If I get another hard drive, should it be EIDE or SATA?
4 answers Last reply
More about deluxe recognize sata raid drive
  1. Be sure to plug the hard drive in to a 'common' MB SATA header, not a 'special raid' header the MB might have. If the drive is not recognized, try another SATA cable. If you decide to use a different drive than the one you have, just buy a SATA drive and plug it in, should be fne. Your DVD being on the IDE has nothing to do with using a SATA HD or not.

    Edit: You do have a SATA power cable from the PSU plus a SATA interface connector to the MB running from your SATA Hard drive?
  2. Okay, thanks. I will plug this HD into another SATA header and I do have the SATA power cable connected to my HD.
  3. Changed HD to different header and still not recognized. In BIOS, all six SATA drives show no HD. All the SATA headers are set for EIDI, so I changed to read RAID and still not recognized. I will get another plain SATA drive.
  4. http://www.asus.com/uk/support/Knowledge-Detail/1/22/P5K_PremiumWiFiAP/B2EED94B-A58D-05F5-0DAF-864FC6F34066/
    It's a solution to a similar issue, but give it a try.
    It has worked for me.
Ask a new question

Read More

Asus NAS / RAID Hard Drives Motherboards