BIOS ROM Checksum Error

So last night while doing some web browsing, my main system starts outputting a flickering signal to the monitor, Firefox crashes, and I get a blue screen followed by a reboot.

When my system reboots, instead of the normal POST stuff I get a message along these lines:

"Award Bootblock version 1.0
Copyright stuff

BIOS ROM Checksum Error"

The system then proceeds to try booting from the CD-ROM and floppy drive to not avail.

I tried clearing the CMOS RAM, but that didn't change anything and I'm not sure what the next step I should take is.

For reference, the motherboard is an ASUS A8N-SLI Premium. The boot drive is a WD 150 gig Raptor SATA drive.
2 answers Last reply
More about bios checksum error
  1. If you can't recover it you will have to take out your BIOS chip and have someone reflash it, chip might have simply malfunctioned, in that case you will need a new, not always easy to come by, bout you can buy one here
    http://stores.ebay.co.uk/BIOS-Service-Center

    Bought one from him worked prefectly :)
  2. dang you need to RMA it. you might get lucky and re-flash with their BIOS recovery tool but it usually never works out like it should. also check all your chips on the mobo for burns/fries. don't see how a BIOS could go corrupt on you like that
Ask a new question

Read More

Chipsets Motherboards