Sign in with
Sign up | Sign in
Your question

ASUS P5AD2 Deluxe DVD ROM Problem!! HELP!!!!!

Tags:
  • Asus
  • DVD Drives
  • Motherboards
Last response: in Motherboards
Share
February 8, 2008 7:56:11 PM

Hello everyone, I am really stumped on this problem. I just did a new build computer using my old P5AD2 Deluxe motherboard that I took out of my main box for an Asus AMD setup. I purchased an HTPC setup and install the P5AD2 Deluxe motherboard with a SATA HDD and an Asus IDE DVD Rom drive. I got everything installed properly and realized that the DVD Rom will not even open. If the IDE Cable is unplugged from the back of the drive, the DVD will open perfectly fine. However as soon as the IDE cable is installed the DVD Rom shows no life. No colors nothing. Need some help with this one please!!!!!!!!!!!!!

More about : asus p5ad2 deluxe dvd rom problem

February 8, 2008 8:25:00 PM

Don't think it's possible to incorrectly install IDE cables upside down with newer drives and motherboards, so I'd suggest trying a different IDE cable. I've had a couple cables go bad before.
February 8, 2008 8:28:36 PM

Check the jumper settings, if it's now the only ATA drive, likely you'll have to change it to Cable Select
Related resources
February 8, 2008 8:50:00 PM

Thanks all for your posts. I just finished trying different cables, no luck, same thing with the jumper. Has anyone ever had a grounding problem between the case/mobo stands? I am thinking maybe the mother board is not grounded properly around the IDE controller. Anyone ever experienced that issue?
February 8, 2008 9:56:40 PM

Check your ATA BIOS settings. Possible the drive is dying
February 8, 2008 11:54:52 PM

I dont think it is the drive dying, because I tried the dvd rom out of my new other computer, once plugged in it had the exact, exact same problem. Would not work as soon as IDE was hooked up. I will try the ATA BIOS next. Also if anyone has had a grounding issue please post!!!!!
!