Sign in with
Sign up | Sign in
Your question

New build wont accept newest Nvidia drivers

Last response: in Systems
Share
January 5, 2008 7:26:59 PM

Hey guys, 1st time poster, hope I'm doing this in all the right locations,

I just finished acquiring all the parts I need for my new build. The build and Windows XP 32 bit Pro installation went fine, but then things got tricky. Before I begin, here is a list of my components just go we are clear.

Mobo - eVGA 780i Sli
CPU - Intel Q6600
Ram - 2gb OCZ DDR26400 SLI-Ready (have 2 more gb but I am waiting for a stable build to put in)
GPU - 2x eVGA 8800GT Superclocked edition (only have 1 installed until system is stable, but have tried with both in to no avail)
PSU - OCZ 700W SLI-Ready

So when Windows finished installing, I'm stuck in 640x480 and 4 colors. I installed the drivers for my Motherboard off the eVGA CD and rebooted, no difference. Then I installed the drivers for the 8800GT from the eVGA CD and rebooted, no difference. I did 300+MB of Windows updates hoping DX9 caused the problem. No Difference. So I ventured to www.evga.com to get the latest drivers and bios for both the motherboard and the 8800gt. The Bios updates went fine, but installing the drivers for the 8800gt went a little wacky. After the reboot, Windows told me I may not have administrator rights to change the display settings (im logged in as administrator). I went to www.nvidia.com and got their newest drivers after using Driver Cleaner, now it says the drivers are for an older version of Windows!

At this current moment, I used Driver Cleaner again and can boot into normal more with 800x600 with 32bit colors with the basic Windows Driver. Has anyone else had this issue? Is it my eVGA 780i or the 8800GT? I mentioned I have 2x 8800GT, I have tried both of them with no difference. Any help would be great.
a b \ Driver
January 5, 2008 7:34:20 PM

What have you done in BIOS? Is there any BIOS setting suggesting SLI be enabled?

How about Device manager? Any yellow exclamation points there?
January 5, 2008 7:52:17 PM

When the drivers are installed, no yellow exclamation points are there. But when I use Driver Cleaner and reboot there is one for Nvidia 8800Gt, which is expected. As for the Bios, I updated them and have modified only small things. My MMemory was not initially recognized as SLI-Ready and the timings were off, so I set those. I'm not overclocking, yet. There is no setting which I can find for anything regarding SLI in there. I'm doing a test right now, I'm uninstalling in device manager and trying the newest offical NVidia drivers again.
Related resources
January 5, 2008 7:57:45 PM

Well that fixed it! The 8800GT's must be uninstalled from Device Manager, reboot, then install newesT NVidia drivers. Thanks for quick response.
a b \ Driver
January 5, 2008 8:07:16 PM

Some of the driver cleaners I have used will 'clean' more than needed. I look to add/remove programs if I need to delete a video driver. That's just me.
!