Sign in with
Sign up | Sign in
Your question

Rediculously Bad HD Performance on P5K-VM; Please Help!

Last response: in Motherboards
Share
February 12, 2008 4:31:59 PM

I am having a big problem with a system I've built - it is unuseably slow and sometimes doesn't boot. Specs:

Mobo: Asus P5K-VM
CPU: Intel E2180 (no OC)
Mem: 1GB Corsair XMS2 PC2-5300
HD: Transcend 32GB Sata SSD TS32GSSD25S-M
OS: WinXP SP2

I think what is wrong is that the system is super slow accessing the HD. I had it initially set up with the sata controller configured as IDE in the BIOS but this was rediculously slow and would freeze for ~10s at a time when clicking anything (installed NTFS 1st and then FAT32). I then followed instructions from http://www.msfn.org/board/enable-AHCI-Intel-ICH9-XP-t109450.html&st=40&start=40 to create a drivers floppy for F6 install of XP and again installed 1st on NTFS and then FAT32 both with the BIOS set to Enhanced AHCI. This makes it faster at 1st but still not "fast" considering nothing is installed and it has never been connected to the internet. Anyway as soon as anything is installed (.NET framework, VGA drivers...), the HD refuses to boot (sometimes it works fine but once it has refused once it won't boot again until the bios is changed (even to the same version) or another drive boots the system then shuts down then I swap drives back & then it tends to work for a bit). When it does boot into windows it can at any time freeze up just doing simple things like Start>notepad.

I don't get why a new motherboard like this would have an issue using a sata drive (BTW on the IDE SSD I also tried everything worked great).

Jo
February 12, 2008 7:43:31 PM

More Info:

HDTach:
SataSSD - RandomAccess 5.2ms, CPU Util 0%, AvgRead 24.9MB/s, Burst 27.0MB/s
Cruzer Micro Flash Drive on same System - RandomAccess 0.6ms, CPU Util 9%, AvgRead 29.4MB/s, Burst 30.9MB/s

(For reference my laptop's regular HD: RandomAccess 14.4ms, CPU Util 8%, AvgRead 51.7MB/s, Burst 183.5MB/s)

which means even a cheap 2GB flash drive beats the SSD on this system. The SSD connected to my main system (MSI P965 Platinum) performed very well as a secondary drive but I'm not sure what's wrong.

Jo
February 12, 2008 7:43:47 PM

Confused, why are you installing XP on a FAT32 partition? XP was built for NTFS. Also, that mobo really shouldn't need a driver to recognize a SATA drive but it's possible you may need them for RAID. If you have program(s) that need to run on a FAT32 you should install Windows 98 on it and dual boot. Otherwise the main reason for a FAT32 would be for your swap files
Related resources
February 12, 2008 7:46:57 PM

I have no preference for FAT32, just did it to see if that would fix the problem and it didn't. The mobo recognizes the disk without F6 only when the BIOS is set to configure Sata as IDE and in this case everything is super slow (even though I've done this without problems on other motherboards).

Jo
February 12, 2008 8:16:07 PM

Download HDD diagnostic from the manufacturer and test it. Make sure its plugged in the right sata port. MAke sure the mobo supports 3.0 sata and not just 1.5 or adjust the jumper accordingly.
February 13, 2008 12:16:58 AM

They don't seem to have a dignostic, but the drive works fine in my system, just not as the primary in the P5K-VM. I'm installing on it now in an old Asus A7V600-X to see if the problem is still present.

Jo
February 13, 2008 12:59:13 AM

roadrunner197069 said:
Download HDD diagnostic from the manufacturer and test it.
Key words in the OP HD: Transcend 32GB Sata SSD TS32GSSD25S-M.
roadrunner197069 said:
Make sure its plugged in the right sata port.
Good point, make sure it is on the ICH9 southbridge, not the add on controller, assuming there is one.
roadrunner197069 said:
MAke sure the mobo supports 3.0 sata and not just 1.5 or adjust the jumper accordingly.
G33 surely supports 3Gb/sec.

Is your CPU under a high load when accessing the HD. If so, make sure you haven't switched from DMA to PIO mode, you have the classic symptoms. Although, with PIO it should even be worse.

Look in the device manager in the properties of the drive controller.

February 13, 2008 3:58:18 AM

Thanks for the suggestions.

The sata drive is on the ICH9 port 1 (also tried the other ports but that didn't matter) - the secondary controller on this board only does parallel ata.

CPU never gets to any significant loading when trying to do anything since the info streams so slowly from the HD. The memory is also mostly unused. I've had issues with PIO mode on another machine's DVD but this happens right from windows install on 2 drives on 2 boards. Actually windows install even took about 5-6 hours each time - drive formats in about 5 seconds and then windows copies files slower & slower for close to an hour and then the part when it says 39minutes left takes a few hours.

Knoppix linux on CD runs nice on the sata DVD. Ubuntu installed works good but I froze that once too.

Jo
February 13, 2008 4:32:34 AM

According to the manufacturer's website ( http://www.transcendusa.com/Products/ModDetail.asp?ModNo=177&SpNo=3&LangNo=0 ) the specs for that SSD are as follows:
============
Size : 100mm x 69.85mm x 9.5mm
Op. Voltage : DC 5V
Op. Temperature : 0°C(32°F) to 70°C(158°F)
Weight : 48g
Certification : CE, FCC, BSMI
Performance : Read up to 30MB/s, Write up to 28MB/s (8GB, 16GB)
*** Read up to 26MB/s, Write up to 13MB/s (32GB) ***
Shock Resistance : 1500G, 0.8ms
Vibration Resistance : 3.0G, 5 - 800Hz
Humidity : 5% to 95%
MTBF : 1,200,000 hours
==================
It's only rated for "up to" 13-MB's/sec for Write operations (meaning probably a bit less in real life).
February 13, 2008 4:34:49 AM

In PIO mode the CPU controls the I/O so the data I/O will be slow but the CPU will get slammed. At any rate it would be odd for it to be in PIO on install, but I hope you checked. It's not clear, did you find an old HDD and try to load XP on it to see the results?
February 13, 2008 5:34:13 AM

He has an older SSD with a max read of ~26MB/sec.

IframedRogerRabbit, I saw those specs earlier, it's a little older drive and not up to the speeds of the newer SSDs. But that doesn't explain the hangs of up to about 10 seconds and the freezing while clicking start -> notepad.

JMecc, it appears that you used another drive and didn't have the same hangs etc. Maybe run chkdsk c: /r from the command prompt. Or, as supremelaw said, try to get mobo specific information from Asus.


February 13, 2008 1:08:25 PM

I can't use the Intel Matrix Drivers, during install this message comes up:

This computer does not meet the minimum requirements for installing the software.
Setup will exit.

In Intel's readme (http://downloadmirror.intel.com/14848/ENG/readme.txt) they don't list ICH9 as a compatible chipset, which is why I modified the Floppy drivers per http://www.msfn.org/board/enable-AHCI-Intel-ICH9-XP-t10....

I think IFramedRoderRabbit is correct in pointing out that the speed specs of this drive are not up to par with what we're used to with 7200rpm drives, but I also agree with where Zorg is going - it still shouldn't be this slow. I've used a 3GB 4200rpm drive on this exact system and it worked fine - seemed at least 10x faster than this SSD and this is what I don't get.

Jo
February 15, 2008 5:06:15 PM

Update:

With an IDE flash disk (Transcend TS8GIFD18), the computer operates much much smoother. What's odd about this is that this is a slower drive (as tested by copying files to & from it on my computer and with HDTach: RandomAccess 0.3ms, CPU Util 0%, AvgRead 9.6MB/s, Burst 9.8MB/s). The one spot it wins in is random access - I'm not sure why the random access of the Sata is so bad but it is still much better than my laptop's spinning drive random access and the spinning drive is very reponsive.

Why do you all think the unresponsiveness of the system stems from? Any guesses welcome as I'd really like to find out.

Jo
!