Sign in with
Sign up | Sign in
Your question

AHCI (help please)

Last response: in Motherboards
Share
February 18, 2008 2:54:07 PM

I just purchased an Asus P5E mobo and I've got 2 SATA HD's. When my friend and I set things up, I noticed that the BIOS had the HD's set as (maybe not exact wording) but "Set as IDE". AHCI was one of the choices but we didn't chose that at the time. Now I have Windows XP installed and everything is working fine, but someone told me that unless I had the AHCI set up, I was only getting IDE speeds on those HD's and not the 3.0 gig speed of the SATA drives. I went back into the BIOS and changed it but then when the PC rebooted it crashed. So I now have it set back to "Set as IDE". Question, is it true that I'm only using half my drives speeds unless they are set to AHCI...and what is this AHCI? Plus, if I try to set it up as AHCI, do I have to reinstall Windows again and lose all my stuff I've installed on the HD so far? *LOTS OF STUFF installed = SEVERAL HOURS OF reloading :(  * if I have to reload.

Can anyone help me clear this up with what I should do..or should I leave the system alone as it is. Runs fine but I'd hate to be cheating myself out of the speeds I paid for when I got the SATA drives.

Thanks in advance to any replies and sorry for anything I misstated or left out.

Big Ro

More about : ahci

February 19, 2008 6:35:51 PM

To enable AHCI in XP, you are supposed to add the Intel Matrix Storage Manager during the XP install (press F6). Google Intel Matrix Storage Manager and you will find many information on this topic. You can also enable it after the XP install but it's complicated since editing the Windows Registry is involved.

AHCI has nothing to do with SATA speed. It queues up disk access requests and calculates the best paths to fulfill these requests.

Unless you are running a server, you do not need AHCI. AHCI improves performance in a multi-users with many concurrent disk accesses environment. In a single user system, your performance will sufer, theoretically, due to the AHCI overhead.
!