Sign in with
Sign up | Sign in
Your question

Need help with LG GGC-H20L HD-DVD/BluRay ODD

Last response: in Storage
Share
January 9, 2009 1:32:39 PM

If you have this drive, or know a lot about vlite, you can help me.

I have one installed on a computer that I've been rebuilding. Up until this week, the drive was working fine. I could read CDs (data and audio), DVDs (data and movie), BDs and HD-DVDs. I could also burn DVD+Rs (and hadn't tried any other variety).

Then, in an attempt to create a slipstream of Vista SP1, I installed vLite. I also left a couple of different data CDs in the drive during reboots (in particular, the UPSMon CD for an Ultra UPS, and the Cyberpower CD for a Cyberpower UPS).

Now, the drive reads BDs, HD-DVDs, movie DVDs and some data CDs (e.g. the MCE 2K5 install disk), but does not recognize empty DVD+Rs for writing, and does not recognize some data CDs and DVDs (e.g. the Cyberpower CD and the Vista Ultimate 32-bit install DVD).

Questions (primarily for owners of the same drive using Vista, or users of vLite, but open to all):

1. Under my device properties (details tab), there is a property "Class lower filters". My configuration lists "clbstor" as the first filter, plus a second filter that is written as 4 asian characters: 쳔朜樰耀. Do you have a set of class lower filters like this for your drive?

2. Does this sound like a HW problem or a software configuration problem?

3. Does vLite install any DVD drivers and/or filters?

I note that when the drive doesn't recognize a disk, the blue light flashes for a while and then stops, and the O/S seems to kind of hang for a while. The address bar in Windows Explorer slowly turns green from left to right (as if it's progressing through something), but then it acts as if there's no disk in the drive.

Other notes:
- I am using Cyberlink Hi-Def suite v. 7 (OEM), with the file version of PowerDVD.exe being 7.03.4211.0. It includes one update after the install CD that came with the drive.
- The populated data CDs and DVDs that don't work in this drive seem to work fine on another computer.

Any help is appreciated! I am hoping this is a software problem, because I don't want to have to replace the drive.
January 12, 2009 1:53:05 PM

More info:

1. The list of class lower filters changed. Specifically, the last entry in the list changed from the set of Chinese characters I noted originally, to a different, shorter set of Chinese characters. I suspect that this is due to a buggy driver (clbstor, which is by CyberLink).

Note: I only say that they're Chinese because when I use the Chinese character set of a font the characters appear the same. But they could be displaying with the wrong character set in both the dialog box and in notepad. And they could simply be past-end bytes that happen to fall into the Chinese character set portion of the unicode domain.

2. There appears to be an order-of-operations dependency to the problem. If I boot, login, and put in the Win Vista Ult 32-bit DVD, I can read it. But if I boot, login, and put in the Cyberpower CD, I can't read that. If I then put in the same Win Vista Ult 32-bit DVD, I can't read it either.

3. I found a bunch of updates for components of CyberLink Ultra High-def suite (Power2Go, InstantBurn, PowerDVD, etc.) that I haven't installed, and I will be trying those next. Will post results here, but this is looking increasingly like a driver problem and not a HW problem.
January 13, 2009 8:47:56 PM

Cyberlink PowerDVD Ultra OEM install had some defects and was not Vista-compatible. I uninstalled all cyberlink software, and the DVD drive began to work fine for all Data CDs and DVDs. I then went through and installed Cyberlink's suite and several patches, and now things appear to be working except for burning DVD images. There is no longer a driver problem, and I no longer see the unexpected characters for the class lower filters.
February 16, 2009 11:14:57 AM

I had problems until I installed the power2go app on the disk. this installed some DLL that it needed.
then it worked fine.
that was on XP
!