Sign in with
Sign up | Sign in
Your question

Error Loading OS

Last response: in Storage
Share
January 9, 2009 7:13:20 PM

I recently got a new Velociraptor 300gb SATA drive and figured I'd finally switch to Vista from XP, so I loaded up a new install and dual-booted to it, keeping my XP install on my old 74gb hard drive intact.(The Vista install on the Velociraptor was G:)  Everything worked fine, but unfortunately because of various circumstances regarding RAM and my motherboard(Asus P5NSLI) I decided I'd go back to using XP. I still wanted to use the new hard drive as my main drive though, so I booted into my old Windows XP drive(C:)  and ran Western Digital's Data Lifeguard Tools, telling it to format the new 300gb drive and copy all my Windows XP drive contents over to make it the new boot drive.

But when I restarted and tried to boot to the new drive, I got a simple "Error loading OS" message and nothing happens. I tried setting it as the 1st boot device in the BIOS, and still got the error. Tried disconnecting my other hard drive so the new one is the only one there, but I still get the error. The BIOS sees it just fine, and if I boot into my old hard drive, I can access it and see that all the files appear to be there. (But one thing is odd, in that whenever I boot into my old hard drive, it still brings up the dual-boot option asking if I want to boot to Vista or an "Earlier" version of Windows. I'm wondering if this is related.)

Anyone know what the problem is?

More about : error loading

January 11, 2009 12:09:50 AM

Updating this: I thought maybe it was having problems because I didn't remove the old hard drive when I rebooted after copying, so I formatted the new drive and used Data Lifeguard to copy everything over again and I made sure to remove the old drive before starting the system back up. But I still got the "Error loading OS" message.

I tried using the EASEUS Partition Manager to copy the drive and I restarted, but got a different error message when I restarted(something like "Disk Operating System Not Found" or similar). I tried using the Recovery Console and fixmbr and fixboot, but neither of those worked. I tried using the WinXP install disk to "repair" the install, but it didn't detect the copy of XP. It did detect the hard drive, so I tried installing WinXP fresh on the new drive with my old drive disconnected, but when it rebooted after copying the setup files over it gave me a "error loading operating system" message.

Vista64 ran without any problems on this thing for several weeks, I just don't understand what's wrong with it now. Nothing I can think of is working. I can see the drive in Windows, I can see all the copied files over there, it just will not load up.
!