Drives disappear after vista update?

Hey everyone,

The first vista updates on my rig weren't quite sucessful. I ended up losing both a hard drive and my dvd burner... They are not listed in the devices, nor the disk management (for the HDD).

Funnily enough, I only lost one hard drive out of three, and the DVD Drive. I ended up downloading the nForce drivers for my 790i, which didn't change anything. I then thought that the sata connector might have blown... nope. I simply unplugged, rebooted, plugged, and it worked.

However, this method does not work for the DVD Drive. Any ideas?

** I am currently downloading SP1, hoping that it may fix it, but keep in mind that everything worked fine without updates...

Thanks for any support.

Patrick
10 answers Last reply
More about drives disappear vista update
  1. your specs would help.
  2. Well specifications won't really help, you already know what motherboard I have, and that I have Vista Ultimate.

    Here are the only specs you need.


    EVGA nForce 790i ftw
    E8400
    2GB DDR3-1333 (only 2gb was in at the time of the error)
    Vista Ultimate x64

    Drive is an LG, but keep in mind that it happened with my WD Hard Drive as well.
  3. Is it vista x64? do the drives show up in device manager?
  4. Yes, it is x64.

    No it doesn't show up in device manager. I've tried changing the sata connector, but no change.

    I'll mess a bit with it, but I don't understand why an update would suddenly make it unusable.
  5. odd. As a last resort you can explore you bios, see if you can emulate IDE over sata ports. There isn't really any performance difference. The only time you can't do this is if your running RAID, are using Esata or have hotswap drives.

    IF you open computer management, (right click computer, manage) and go to disk management and there is nothing, then i've got nothing...sorry..
  6. Yeah, that's why I'm confused about this too... when my hard drive disappeared, it didn't even show in disk management...

    I try a few other things and I'll post, if anyone has any ideas, please post.

    Thanks for any post.
  7. I'll try it out, thank you.
  8. Hey guys,

    Thanks for the help, finally got it working. I ended unplugging the drive, plugging it back in (like I did with my Hard Drives); at this point it showed in other devices, so I installed the drivers, and it is finally working.

    I have no idea what happened.

    Thanks anyway.

    Patrick
  9. nothing...
Ask a new question

Read More

Windows Vista Hard Drives Storage