Sign in with
Sign up | Sign in
Your question
Closed

Seagate 1.5TB HD showing as 500GB

Last response: in Storage
Share
January 18, 2009 11:14:54 PM

Hello all, sorry if this has been covered, but I have not been able to turn up a thread on this subject.

I can use some help installing my new Seagate 1.5TB HD as a data drive. Everything is telling me it is a 500GB drive, including the bios, a right click, and accessing the Disk Management function from Computer Management. The last function is where I was intending to format the drive and mount, but I am concerned that I will only be formating 1/3 of the drive.

I have updated my bios, and ran Seagate's DiscWizard. DiscWizard told me that I had to have a Seagate drive installed to utilize the app. For the record, I have a Seagate drive installed ;D

Sorry for the newb question here but are my concerns correct, or will the formatting of the drive make the adjustments that I am looking for?

Sys Specs:

Gigabyte GA-P35-DS3L
Intel E2180
NVIDIA 8800 GT
C: WD Black Cav 500GB (has my OS)
E: Samsung Spinpoint 400BG (Full of data)
D: Seagate 1.5TB (unpartioned, unformatted, drive in question)

TIA, Erazz
January 19, 2009 3:03:59 AM

Odd to say the least.

I would download the Seatgate DOS drive tools for CD and burn the image with ISO recorder or other ISO burning software.

Unplug the other drives and boot the CD. See what the DOS tools say. It's really odd that the BIOS is seeing it wrong.

Maybe it's a bad drive.

January 19, 2009 3:27:13 AM

Will give it a go and report back. Thanks for the reply.
Related resources
March 13, 2009 11:25:33 AM

What were your findings? I am having the same issue. My Seagate 1.5 is showing only at 500gb. I also have a Gigabye mobo.
a c 342 G Storage
March 13, 2009 1:07:12 PM

Yeah, as Zorg says, the DOS Tools from Seagate will help you. You make a disk from it and boot from this disk. It installs a mini-DOS and runs some good diagnostics. There are short and long tests of the disk surface and I warn you, the long test is REALLY long because it writes, reads and writes to every sector individually, and that's a lot for 1.5TB! It takes many hours!

However, the info I would look for is the size of the disk. It may state it in MB or GB, but be aware that Seagate calls a GB exactly 1,000,000,000 bytes. So the numbers should match up - the disk size should be 1,500 of these, just as the disk label says. Microsoft, on the other hand, calls a Gigabyte 1,024 x 1,024 x 1,024 bytes and their measurement will give you a smaller number of "GB" for the same drive.

In DOS Tools there is one place where you can deliberately tell the drive to restrict itself to a smaller value than its true size. You don't want to do that, but there is a reason I'm going there. The trick is to know that the measurement is done in terms of the number of disk sectors available. Every disk sector will hold 512 bytes. So, for example, if you are limited to using 2^28 sectors (the limit imposed by the older "28-bit LBA" system), that comes to 268,435,456 sectors or 137,438,953,472 bytes, the reason that HDD's used under that older system cannot exceed 128 GB by Microsoft's way of counting.

Now, in your case, this 1.5 TB hard drive SHOULD have about 3,221,225,472 sectors to yield 1,649,267,441,664 bytes capacity. But somehow it appears to have only about 1,073,741,824 sectors for a capacity of 549,755,813,888 bytes. In the DOS Tools page for forcing the disk to limit itself, look at what it says is the current limit on the number of sectors. Is it the 3 billion + sector count, or only the 1 billion number? If it is the smaller number, or something close, it is possible that someone has previously set the limit for some unknown reason. In that case, in this same section of DOS Tools, there is a place you can tell it to restore this disk to its full size. Do that, exit from DOS Tools, and reboot into it again. Now check what it says about disk size to be sure.

On the other hand, if DOS Tools reports the disk size (that is, maximum sectors available) is the full size already, then you know that there is nothing at all wrong with the HDD unit. The problem must be somewhere else, either in the HDD controller on your mobo, or in the software drivers for it. In that case check the mobo manufacturer's website. There you should be able to find out if this is a known problem and how to fix it. It could be in the mobo's BIOS, and hopefully there is a way to download a BIOS update file plus a utility to "flash" your BIOS chip. Alternatively, there could be a software driver for the mobo's drive controller that needs to be updated in Windows.

Let us know what you find.
March 19, 2009 6:16:29 AM

aries said:
What were your findings? I am having the same issue. My Seagate 1.5 is showing only at 500gb. I also have a Gigabye mobo.


aries, i wish i had a fix for you. All I did, was give the drive to a friend, with a similar system, and he was able to format it at full size. when i got it back from him, it worked fine.
April 2, 2009 9:55:30 PM

Same problem here.

SeaTools for DOS v2.13PGE say: "Device is 48 Bit Addressed - Number of LBAs 2930275054 ( 1500.31 GB )

When I choose the option to Set Capacity To MAX Native, in the log there is a message:
"Error on SetMaxAddressEXT(2930277167) = 51:10
Check to be sure that the drive has been Power Cycled"

Same error happens when I try to set the capacity to any other number, such as 32 GB.

It passes the Short Test with no errors.

The strangest thing is that at the very beginning (first time I connected the disk), it was visible as 1500GB. I tried to format it, got some error in Partition Magic and after restarting this 500 GB problem appeared.

May 19, 2009 8:56:23 PM

I have the same problem. First it read 150 Gig, I used SeaTools and at first it did not help. The next day I tried it I work but that only raised to 811Gigs. Then I put the capacity amount in by typing in "1500.304" I think it read on the screen in SeaTools and that left me with only 8 Gigs. For this program to work for eac change the HD must be powered down for at least 30 sec. before you can boot up the floppy to try it again.
I am at 811 GIGs know and when I get home to day I will try to raise it higher. It seem to be trial-&-error with program and the drive that is being used.

If there is other programs out there that can control the capacity without the trail-&-error or someother method that can be used please post.

Thanks for all the help...

Sign,

Missing 689 Gigs on my Seagate 1.5 HD
September 3, 2009 4:59:02 PM

I have three of the Seagate 7200.11 1.5TB drives and also have a Gigabyte MB.

At first, the did show up at 1.5TB, but, after trying to install Linux in a software RAID configuration, now they are showing 500GB ?!?

A person should not have to go through the hassle of using special utilities just to get their new hard drives to work as they were supposed to. It's unfortunate that I've had them for more than 30 days so I can't just return them :/ 

I will try the Seagate tools ISO that you burn to CD then boot the CD and see what happens.
September 4, 2009 12:07:11 PM

Ok, so far I checked two of my 1.5s and both reported to be 500GB. Tried to fix each one using the bootable Seagate Seatools CD. I tried the "Set Maximum Native Size" or such and it wouldn't work on either, setting each to only ~5GB :( 
a c 342 G Storage
September 4, 2009 2:36:10 PM

First of all, you are all right that nobody should have to fight to make a 1.5 TB drive show that size. It should come that way.

Second, for the rare cases where the drive size is wrong, using Seatools for DOS to reset the Seagate drive's capacity to max is kind of a backup procedure. If that also fails, as some of you report, run the diagnostic tests and note the results. Then contact Seagate and tell them your problem and test results. They can help you decide whether there is some simple thing that can be adjusted, or whether the drive really is faulty and needs to be replaced for free.
September 19, 2009 11:50:22 PM

I have a 160GB Seagate ST316 hard drive (internal) that refuses to show more than 32GB. It did work until something caused the PC to fail; don't have a clue if it was a power surge or just drive failure. I replaced the drive and I've been reading all this stuff, did a low level format without success (it just did 32GB).
With Seagate's DOS tool I got the 51:10 error no matter what space setting I tried, even 32GB.
But the Seagate tool did show the drive's correct LBA and 160GB capacity. I even did a Zero ALL test and it wrote to the full size (LBA and 160GB).
The tool appears to know the correct size but I still can't set the capacity; neither 160GB (max LBA) nor 32GB.
Just keep getting the Error on SetMaxAddress.... = 51:10.
I now assume the drive has a physical problem even though the Tool did write the entire 160GB.
I surrender....
Norm
March 4, 2010 4:53:07 AM

like one of the first posters I too ran into a seagate 1.5 TB drive only showing 500GB when initially plugged into a Gigabyte MOBO.
downloaded not the windows tool but the SeaTools for DOS. burned files directly to cd.
booted up, clicked mouse to set to max, simple!!
i was dreading a two week mail order return to tigerdirect; thanks to toms hardware forum no troubles!!

Normw3dya,
i filled out there online survey where they asked if the drive only shows 32gb. that must be a common issue with a common fix. never surrender when there is a hammer near by.
a c 342 G Storage
March 4, 2010 3:48:04 PM

I've never run into the error message a few have quoted here - error 51:10 when trying to reset the drive to max value. That particular tool does NOT have you specify what the "max" is - it reads that info from the drive itself and uses it. So I have to suspect that, if this step cannot be done successfully, either the drive is faulty, the software is faulty, or the mobo or cables are at fault. I recommend consulting Seagate's Tech Support for their guidance on that.

Now, I think I see hints of not understanding how to set a limit on the apparent size of a drive using Seatools for DOS. Note here that I'm NOT talking about the "set to maximum" step above, in which you do not provide a target value. I am talking about an option Seatools can execute for Seagate drives only to instruct the drive to pretend that its maximum capacity is less that the real hardware max. That can be useful in some situations. (I had to use it to limit a 160 GB Seagate to behave as if it were 137 GB on an older mobo with no 48-bit LBA support.) In that tool you must enter a size limit, but you do NOT do it as a GB number! The prompt asks you for the maximum number of Logical Blocks. Now, a Logical Block can store 512 bytes of data. So you have to figure your size backwards from GB to Block count. Or, in my case, I knew the system could not send the drive an address larger than 2^28 because it only supported the original version of LBA, a 28-bit binary address system. So I entered the value 2^28, which is 268,435,456 as the maximum number of Logical Blocks that could be used. (At 512 byte per block, this comes to 137,438,953,472 bytes - see where the "137 GB limit" comes from?)

johnskiA said he had tried entering a size of "1500.304", thinking he was specifying a size in GB. If the system ignored that decimal point (not a digit), 1500304 Logical Blocks would give 768,155,648 bytes, close to the 8 GB he says was his result.
!