Sign in with
Sign up | Sign in
Your question

K9N SLI Platinum: Weird USB Problem

Last response: in Motherboards
Share
February 26, 2008 9:06:04 AM

The K9N SLI Platinum already worked for a year or so. Suddenly, USB doesn't work any more, or to be more precise it sometimes (very unfrequent) works for a few seconds. The controller is recognized by Windows XP and different Linux Distros. However, when, for example, I connect an optical mouse, it doesn't light up, and nothing happens. No entries in /var/log/messages or dmesg.

So, since it doesn't work under different operating systems, I thought this had to be a hardware error. However the other functions of the MB still worked, so I decided to buy a PCI USB Card with 4 Ports. It also doesn't work, although the controller is recognized! The really strange thing is that it works in the rare cases when the onboard USB ports do work for a few seconds. I also tried to disable the onboard controller, but that didn't change anything.

What I really cannot understand is what kind of error can cause all connected USB controllers on a mainboard to malfunction! :cry: 

Thanks in advance!
February 26, 2008 9:44:29 AM

How many USB did you try? It might be that the problem is in the opposite shore ...

But if you were trying more than 2 USB devices then it's indeed really strange ..

Don't have anything on my mind yet, come back to you if I have any ..

February 26, 2008 10:13:09 AM

I tried a sufficient number of devices, at least 5 or 6 I think...

Quote:
Don't have anything on my mind yet, come back to you if I have any ..

Thx
Related resources
February 26, 2008 10:48:51 AM

The only thing come up to my mind right now is the PSU . .

I had similar problem at my office before with two or three desktop (branded one) back then. I reformat and reinstalled the OS, but still all USBs are dead ...

I sent it back to the vendor since it's still under warranty, and according to them it was PSU fault. I don't bother to check whether they really replaced the PSU since I cannot open the CPU without losing the warranty ..

If you have any PSU that you can steal, try to replace it ...
January 27, 2009 1:23:13 PM

I am having the same problem with the same board. I can plug in USB devices, and they usually work for a short period, but when I try to transfer files to a USB flash drive, my pc freezes. I tried every USB port and numerous different flash drives, resetting defaults in the BIOS, turned off support for legacy devices in the BIOS. The BIOS and all drivers are updated. Everything else on my pc works fine except the headphone jack in the front. When I plug in headphones, it thinks I plugged it into the port on the back. I double checked, and they are plugged in correctly on the motherboard. It seems to be an electrical problem with the board. If anyone comes up with a solution, please let me know.
!