Sign in with
Sign up | Sign in
Your question

Drive disappearing

Last response: in Storage
Share
January 21, 2009 7:04:03 AM

Hi everyone,
I've been looking for a solution for this problem for like several days already, but couldn't find a clear answer (and a similar problem) so I just thought I would ask for some help here before going any further.

First, my specs:
AMD Athlon X2 4800+
Samsung DDR 4GB RAM (1GBx4)
ASUS A8N-SLI Premium
Samsung HD160JJ SATA300
Seagate Barracuda 200GB x2 SATA150
Windows Vista x64 / Windows 7 Beta 1 x64.


I self-built my PC on May 2006. I set up the Samsung 160GB HD for the OS, and the other two Seagates in Raid 0 for file storage, and have been using without a single problem.. until recently.

The problem is was that the RAIDed drive (F:\) randomly disappears. It just vanishes from Computer (explorer) and Device Manager and Disk Management. The device manager still shows the Silicon Image Sil3114 SoftRaid 5 Controller (on-board), but the drive is gone.

Here's what I tried doing till now:


When I rebooted, the BIOS showed the drives and Windows also detected the drive. But not until after some time I find the drive gone from explorer again.

I tried running chkdsk, and when run in windows, the disk checks for about half the way and the window suddenly disappears along with the drive entry. When I try to access F:\ It says the path is invalid. I also tried boot-time chkdsk, but that also is unable to finish and just proceeds to windows.

Similar thing happened when I tried to defrag the drive with any 3rd party defragger (O&O, PerfectDisk etc), at some moment the process stops and the drive is gone from the listing.


At this point I decided something was definitely wrong with my drive, so I decided I would try formatting and rebuild the RAID set (remove and create again). Fortunately I had a 1TB external e-SATA drive so I could backup all my data from the 400GB RAID drive. But again during the copying progress, the process halted at a certain file and the drive disappeared. It was one of my music files, so I remembered the name, rebooted, and browsed to that exact file where it halted, and tried copying again. As I had predicted, the drive disappeared as soon as the copying progress began.


Now, I rebooted, and went into the RAID setting (that appears before booting Windows- right after POST) and deleted the array, and tried going ahead, but this time it just won't load the OS select screen. -_-;; I rebooted again, and tried selecting the JBOD option. (Now that I look it up I see it's "Just a Bunch of Disks" option... but oh well I just wanted to see each drives as separate in windows) Now windows booted up, and the Disk Management told me that two disks needed to be initialized... so I did that, and created a simple volume on the 1st drive (200GB), formatted it and ran a chkdsk.

Chkdsk was running fine until... at some moment it just stopped and the drive disappeared again. WTF?

I kinda have a feeling it could be a bad sector on the certain location of the drive that's doing this...


So, any help anyone? T_T

More about : drive disappearing

February 3, 2009 2:10:22 AM

Woot.

I have the exact same problem bro. Just did some harddrive upgrades, put a mirrored 1tb set on the silicon chipset, and they just disappear. Thought it was only after I left my machine idle, but tonite I was doing some work and listening to music. The music stopped and programs started saying they couldn't find my files, BAM, drive disappeared.

I am using the same motherboard and OS as you. It has to be a vista x64/silicon driver issue. While it is good to see that I'm not the only one with this problem, I take little satisfaction in saying that I have not been able to find a fix.

I'll post back if I find anything.
February 3, 2009 6:09:10 AM

Ok, I I don't know if it's a permanent fix but I think it's definitely effective as the drive hasn't yet disappeared again since the fix:

I backed up all my files from my 400GB RAID drive to a 1TB external HDD I have, then went in to the RAID bios during boot, and removed the RAID array, then did a format on both of the 2 drives (in the bios), recreated the array. Booted into windows, created a volume and ran a chkdsk on it... and didn't disappear during the process! It's working now without any problems ever since. (so far) :) 

In my case it was working all fine for some 2 years then the problem happened, so I might presume something might have gone corrupt, but I don't know if this same simple process is gonna work for everyone with this problem... but guess it's worth a try.
Related resources
March 18, 2009 8:55:38 PM

I am having the same problem. But this is a standard 500GB SATA drive on an ASUS Striker II Formula. Just dissapears after being idle for a while.
March 29, 2009 6:32:13 PM

Well I'm pretty sure I have found out the issue I was having. One of my drives just died.
I guess they were losing sync after being on for awhile? Or just one drive flaking out.

I never got any warnings from with in windows. Though, it was pretty cool that a couple days before the drive died, I was in suse and it popped up a warning that 1 of my drives was about to die! It detected SMART errors.

The green lizard just went up a notch in my book.
!