Sign in with
Sign up | Sign in
Your question

Very strange (memory?) problem

Tags:
  • Memory
Last response: in Memory
Share
February 27, 2008 2:39:57 PM

As a relatively experienced pc builder, I've come across many problems and managed to solve most all. However, this one is proving a PITA.

I built the following PC for a friend:

E4300 @ stock
Asus P5B
2x1GB Geil PC-4300
Asus 7600GT
Silverstone ST50EF-Plus Short Cable (500W)

The PC seems to run fine except when running any application that utilises DX8 or DX9 graphics. Applications using OpenGL graphics run without problem.

I made a clean install of WinXP (SP2) and then ran the DirectX Diagnostic on the system. Sure enough, it failed on DX8 and DX9 tests. I then tried with a different (known good) graphics card and had the same problem. I also checked the 7600GT in a different system and it worked fine.

I checked overall system stability with Prime95 for several hours and had no problems.

I checked the memory stability with Memtest86+ 1.70 and found no errors.

I therefore assumed the motherboard was the cause of the problem and returned it to the supplier. However, they tested it and found no problem.

I then retested the motherboard with a different PSU (Tagan 650W) and with different memory (OCZ PC2-6400) and everything worked fine.

I then replaced the OCZ memory with the original Geil memory and the problem returned.

I then tested each module individually and found that one of the modules seems to be faulty. This time, when booting into WinXP with the 'faulty' module, the system takes longer to boot into XP and, when it finally loads, the bottom half of the wallpaper is black. The top half renders correctly. Any attempt to use the system after load caused the system to hang (unable to open the program menu).

I'm currently rerunning Memtest86+ with just the faulty module installed, but again I receive no errors.

I have a couple of other memory testing applications to try, but my problem is that, in order to RMA the faulty module, I have to be able to recreate the problem to prove to the supplier that it's faulty.

Considering the above testing methodology, is there anything I may have missed? Am I correct in believing that the memory is the problem?

If anyone has any ideas as to the possible cause of the problem, or can suggest other things to test, then please let me know.


Thanks in advance

More about : strange memory problem

a b } Memory
February 27, 2008 3:35:00 PM

Sounds like your Geil memory is falling short with your system under the stress of running software applications in Windows environment, unlike memtest which does not run in Windows. Try finding the default voltage of your Northbridge and bump that default voltage up a notch or two. Otherwise, the PC6400 you used works fine in Windows..use it.
February 27, 2008 6:09:44 PM

Thanks for the response.

I retested the memory in a different C2D system and, whilst it can pass all DOS-based memory tests (Memtest86+, GoldMemory), it still fails the dxdiag Direct3D tests as in the other system. I also took the time to check that both modules loaded with the correct timings (according to specification) using MemSet.

At least I am now confident that the memory is the real cause of the problem, and can provide a detailed methodology for the supplier to recreate the problem. Time to RMA.

This is now top of my list of strange problems encountered.

!