Sign in with
Sign up | Sign in
Your question

Jumpy DivX AVI playback on new 1TB WD HDD

Last response: in Storage
Share
February 4, 2009 7:08:29 AM

I have been getting jumpy or choppy playback when playing avi, divx or mp4 files on my new SATA2 WD 1TB internal slave hard drive.

I just installed the drive (WD10EACS) on my Asus A7N8X-E Deluxe mobo via one of the available SATA ports. Initially the HDD was not recognised in the SATA boot section and the PC just hung on that screen. Removing the drive resulted in a normal boot.

I had to upgrade my bios with Michael McClay's "Uber Bios", version 1013 which had the latest bios release from Asus and the updated Silicon Image SATA bios combined (A7N8X-E Deluxe Uber 1013 Sata Enhanced with new SATA bios v4.2.50). I believe these are the most recent drivers for both the Mobo and the Sata. I flashed the bios using the Asus bios flash utility via windows XP (some people suggest this is not recommended - any views?), rebooted with the new HDD and it loaded windows fine.

So, i got the drive working as a slave drive in windows, which is what i wanted, and I put three roughly equal partitions on it in windows using the disk management utility. I did a quick format on all the partitions of the drive (I then did a full format on partitions 2 and 3). I copied the same dixv file to each partioned section of the drive and the result is the same, jumpy image and sound. The jumps occur at random time during the playback with reference to the time frame of the file. The jumps only seem to start occurring after about 30 seconds of playback, then apparently at random intervals 10-60 seconds apart. The same file played on one of my internal IDE or external usb drives drives works flawlessly.

It's a SATA2 drive and i've jumpered it to limit the speed to 150 MB/s as my mobo does not support the higher transfer rates. I have not tried removing the jumper to see if it will operate at full speed yet.

Unfortunately I cannot roll back to an earlier bios version to see if this eliminates the problem as the SATA drive is not recognised and windows will not boot. I could try flashing the bios from a floppy but I would have to get a floppy drive from somewhere and I don't know if it will cure it.

I have three other IDE hard drives and a Radeon X800XT Platinum 256MB, quite a bit of power but I have 500W PSU that should cope with the demand. I only use this PC for playing films on so no great stress on the system.

This is a WD “green” drive so I wonder if it is something to do with the power management of the drive? Is there a way to increase the buffer in my video program (VLC - video LAN player)?

Any other suggestions or advice on this matter would be greatly appreciated.

pekboy

search terms (jumpy stuttering nonlinear fractured poor bad choppy Western Digital WD Hard disk drive HDD playback jumps soundtrack skips)
a b G Storage
February 4, 2009 10:47:58 AM

Have you tried changing out the SATA cable?
Have you checked in device manager to make sure its running in SATA mode and not IDE mode which might put it in PIO mode?
February 4, 2009 2:32:46 PM

Thanks for the reply. I'll try swapping the cable over tonight. How do I find out if it running in SATA mode or not? There are not conflictsor errors showing in the device manager with the SCSI or RAID controller?

Cheers
Related resources
a b G Storage
February 4, 2009 2:37:45 PM

Under device manager, go to the primary ide controller, if its there.
February 4, 2009 6:10:35 PM

I can see primary and secondary IDE controllers in device manager but I can't see a way of finding out which drives are associated with it. I have 3 x IDE drives and 1 x SATA.
!