Sign in with
Sign up | Sign in
Your question

Microsoft .NET trouble

Last response: in Windows XP
Share
June 26, 2010 8:52:30 PM

This trouble started with an attempt to install MS .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for >NET version 2.0 through 3.5 (KB951847) x86 patch.
Would get failures for the install.
So naturally I began reading the MS forums and found a thread stating the issue was most likely caused by a damaged .NET Framework component and to resolve remove previous versions and reinstall v3.5 and provided a link for the tool to do the removal.
http://social.answers.microsoft.com/Forums/en-US/vistaw... yeah, I know its for Vista but couldn't find anything in the XP forum
So removed all .NET versions and attempted to install v3.5. The install failed. Did some more investigation and found information that stated .NET Framework was dependent on earlier versions. So I started with Version 1 and installed OK, went to Version 1.1 still OK. Tried Ver 2.0, Failed.
Found yet another link http://support.microsoft.com/kb/923100 and started the process all over again with the same results, nothing installed successfully further then Ver 1.1
Then tried http://social.answers.microsoft.com/Forums/en-US/vistaw... Yep another Vista forum but this provided a fix for installing .NET 2.0 but once again couldn't install Ver 2.0 SP2 or the 3.0 or 3.5 versions.
I did find a mostly undocumented Ver 4.0 which did install but doesn't correct the issue with the program that stopped working after removing Ver 3.0 & 3.5.

Some other items I've uncovered which have been suggested in other forums posts for this problem are not on the machine in question;
Internet Information Services [IIS] is not installed
and
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Security\ServiceModel 3.0.0.0
nor
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer\WOW64
Exist


Most recent error log for Ver 3.0
dd_dotnetfx3error.txt
[06/26/10,10:29:22] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
[06/26/10,10:29:34] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
[06/26/10,10:29:34] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.

Most recent error log for Ver 2.0 SP2
dd_dotnetfx20error.txt
[06/26/10,13:35:40] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
[06/26/10,13:37:27] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.

Both the above suggest a dependence check failed but at a loss as to what action I should take.

So now that you know the background, this is where I stand. I have Microsoft .NET Framework 1.1 with Security Update (KB979906), Microsoft .NET Framework 2.0, Microsoft .NET Framework 4 Client Profile and 4 Extended installed. Machine is running MS Windows XP Pro Ver 2002 w/SP3

I'll keep looking but let me know if anyone out there has another idea I haven't already tried.

More about : microsoft net trouble

July 5, 2010 4:36:07 AM

A few interesting items surfaced. While Microsoft support was unable to correct the trouble and the final suggestion was a clean install, which is what I've done at this point, in the process for getting my updates up to date I've noticed the security update which appeared to have caused the issue, KB951847, isn't showing in the required updates. I am however seeing several new updates for .NET Framework 2.0 to 3.5
m
0
l
!