Sign in with
Sign up | Sign in
Your question

CPU speed re[prting in windows vista

Last response: in CPUs
Share
February 14, 2008 3:18:33 AM

Hi I have a core 2 duo e6300 running on intel 965 motherboard. I have windows vista installed. Though I have disabled speed step Cpu z still shows the processor speed runnning on 1598Mhz sometimes jumping to 2133 Mhz and back. though there no such problem in windows Xp.

Can someone tell me how stop windows vista from downclocking the processor amd I have tried the power settings mode.
a b à CPUs
February 14, 2008 3:40:45 AM

After you disable speedstep in BIOS, Save and Exit. VISTA has nothing to do with Speedstep.
February 14, 2008 3:44:25 AM

It does sound like it's still enabled in the BIOS. Vista has power management turned on by default whereas XP does not. Hence why XP runs at full speed and Vista throttles.

Once disabled in the BIOS though, both should be the same.
Related resources
February 14, 2008 4:24:39 AM

Did you also disable C1E in BIOS? If not, disable it.
February 19, 2008 6:42:07 AM

EIST is disabled and there is no option of C1E in the bios and I hve tried tinkering with the power settings. but still CPU Z is reporting my processor running at 1600 MHz instead of 2133
February 20, 2008 8:28:32 AM

Run Prime95 25.6 and look at CPU-Z while it is running. If your CPU shows the full 1.86G, or whatever you have it OCed to, then ignore it. I just noticed that you said you didn't have the problem in XP, which you would have if it was C1E.
a b à CPUs
February 20, 2008 10:20:50 AM

Vista does not and can not downclock a processor. This is a function of the Bios, not the operating system. Please gp into your Bios and correct your power saving options.
February 20, 2008 1:14:10 PM

Errr... if XP can down clock, I'm sure Vista can.

Even the power schemes in power options can or will have an effect.

I'd disable C1E and leave EIST on. That way by using the power options, if you set it for min power management, it will actually force everything to run lower at idle. If you set it to always on, it should bump it up to max, even at idle.

Thanks to Zorg, I figured that out. :D 
a b à CPUs
February 20, 2008 1:26:06 PM

@OP>what Grimmy said. In Control Panel/Power Options the default setting is 'balanced' which will downclock the processor when it can to save power. Select 'high peformance' to avoid the downclock. I know, this happened to me yesterday when I reformatted and reinstalled VISTA 64.
February 23, 2008 6:02:09 PM

Well there is a correction first of all MyCpu is e6400 not e 6300. and secondly today I checked windows xp again, the problem is present there also , I have disabled Eist put the power options on home/office in windows Xp and high performance in windows vista but still cpu Z shows the process to be running on 1598 mhz instead of 2133.

I am using an intel p 965 motherboard.
February 23, 2008 6:27:33 PM

If you want to try,

Be sure that in the bios:

1.) C1E = Disabled
2.) EIST = Enabled

The default settings in power options I see:

Minimal Power Managment - will cause multiplier to drop as well as the vcore at idle
Always On - will cause the multiplier to be at stock even when the PC is idle.

I just double checked my settings, and it does work for me. Thing is if those options are missing/deleted, not sure if that will work right anymore, by creating a new one.

But if you do want it to run at full speed all the time, and the above doesn't work, both C1E/EIST need to be disabled in the bios, although not all bios may have it, like a brand name or perhaps laptop since its designed to run on battery power perhaps.
!