Sign in with
Sign up | Sign in
Your question

Samsung 1TB hdd, 33mb capacity error

Last response: in Storage
Share
February 13, 2009 10:28:42 AM

Hi guys,
Major problem here with a brand new hard drive. We bought a new samsung 1tb hdd, plugged it in to the motherboard, and BIOS only detects the drive as being 33mb in size, and Disk Management in Windows XP (Service pack 2) only sees a possible 7.87gb available for partitioning on the drive. I have heard that my motherboard is responsible for this (It is a Gigabyte GA-965p-DS3P rev3.3), someone mentioned that it was either a flaw of the p965 chipset or it is an error particular to the combination of gigabyte motherboards and samsung hard drives.

System specs:

E6600 Core 2
GA-965P-DS3P
2gb 800mhz DDR2
RADEON 2900XT 512mb
2x 250gb WD HDD's
1x 1tb Samsung HDD
600w CoolerMaster GreenPower

I have searched the interwebs far and wide to find a solution but nothing has worked so far. People said to use Atola's HDD capacity restore tool (http://blog.atola.com/restoring-factory-hard-drive-capa...) which correctly detected the 1tb capacity but was not able to restore it. They also recommended Samsung's ESTool, which I burnt to CD and booted from startup but it gave me an error saying that the drive letter for the CD Drive was missing (or something) and that there was insufficient memory available (along that vein). I also tried HDAT2 from CD boot, and that gave me a similar error.

I then tried to download the F7a BIOS upgrade, which is the latest available from the Gigabyte website for my motherboard (Other websites claim that F13o is the latest BIOS but from what I have found it is only for the 965P-DS3 rev3.3 motherboard, not DS3P) but I'm not entirely sure how to install the BIOS update... the DS3 f13o autoexe.bat was able to boot from within XP and give me a menu for flashing the BIOS, but the f7a BIOS would not boot the autoexe.bat.

I have no idea what to do next! Can someone help?
February 14, 2009 4:18:44 AM

Sorry to bump, I need help soon!
Thanks.
Related resources
February 14, 2009 9:15:34 AM

ESTool would not boot from the CD when I restarted, it gave me some stupid error about not being able to locate the cd drive letter or something. Is there a way from running ESTool from within XP?
February 14, 2009 11:19:10 PM

No love? Is there another forum I can post on that might garner me some help on the topic?
a b V Motherboard
February 14, 2009 11:22:52 PM

Some hdd's come with installation software on them and are formatted to a partition for that software,did yours??,and,,did you look at the hdd with fdisk,from dos??...:) 
February 15, 2009 4:40:59 AM

I didn't use fdisk, but i did use chkdsk through DOS boot and it still reported the hard drive as having 8064mb available. Any other ideas? I also flashed the BIOS today to f7a, and it still has the same problem. Native IDE mode for the SATA controller is disabled and it is set to LEGACY IDE which I have heard from other sources is a possible solution.
February 15, 2009 11:34:55 AM

I finally had the chance to try the drive in some other machines, where it is still not working correctly, must be DOA. Will replace it tomorrow, hopefully there will be no further problems.
February 15, 2009 11:43:25 AM

the drive isn't faulty. you have to clear the "host protected area". if you have a linux box, use hdparm. else google around for how to do that.
February 15, 2009 11:53:56 AM

hmmm how do you know this? Ill look into it.
May 22, 2009 6:19:22 AM

Yeah it is a HPA issue, samsung hdd's don't like gigabytes dual bios setup,

goto
http://redirectingat.com/?id=372X587&url=http%3A//www.h...

dload the hdat2iso, burn it, boot it, run hdat2, select hdd, select set max _____, (can't remember), and scroll through the size options untill you hit 1000gb

you will notice the 33mb, 7.97gb and so on that everyone is complaining about,

tell it to make it a permanent fix, and then reboot, your drive will be happy and all your favourite data back.

p.s. all those people that say backup backup, quit it, the drive was for back ups and how do you propose i backup 2TB of data, that's 430 DVD's, and noone has a decent sized tape drive at home.
Be helpfull not a smarty pants
Adz
May 22, 2009 11:12:22 AM

I have exactly the same problem - I have Samsiung 1TB and Gigabyte 965P-DQ6 motherboard with dual BIOS. WINXP sp3 installation sees 8064MB available and offers 8063 for partition. Installation of SATA RAID drivers does not help.
So did any of solutions work?
Anonymous
a b V Motherboard
a b Ô Samsung
a b G Storage
March 3, 2010 1:30:25 PM

If still have a problem for "1tb appears 32-33 mb", try this:

- First, update your motherboard bios driver.
- Download "samsung ESTOOL" from this page: "http://www.sekercioglu.eu/?download=Samsung%20ESTOOL%20..."
- Extrack and write this iso, to a cd, as bootable cd
- Boot your computer from this cd
- A blue screen appears. Enter with bottom buttons of screen.
- A new DOS screen. Select "SET MAX ADDRESS" and next "PROCESS"
- Appears on the screen "Process completed!"
- Press ESC. Appears a black screen. And will write "HDD utility etc." Exit as press Ctrl+Alt+Del.
- Your PC will boot again. Press Del and Enter BIOS. Check your HDD driver capacity again, from Hardware. If appears 33 mb, come your HDD and seek it again. Its capacity will be "1000 GB".
- And finally, a format. Thats it!
!